aboutsummaryrefslogtreecommitdiff
path: root/devel/libdispatch
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-05-11 13:15:45 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-05-11 13:15:45 +0000
commit8e333308211c2bdccff1ce35bd20137270945a6e (patch)
tree5ff68e9d5b3d3836bb14f862c334a93871111f7f /devel/libdispatch
parent9809cc72d14ace198094bec1b7a8ccfa76d64295 (diff)
downloadports-8e333308211c2bdccff1ce35bd20137270945a6e.tar.gz
ports-8e333308211c2bdccff1ce35bd20137270945a6e.zip
Notes
Diffstat (limited to 'devel/libdispatch')
-rw-r--r--devel/libdispatch/Makefile12
1 files changed, 5 insertions, 7 deletions
diff --git a/devel/libdispatch/Makefile b/devel/libdispatch/Makefile
index 5109cfbc0735..d84263b4bac2 100644
--- a/devel/libdispatch/Makefile
+++ b/devel/libdispatch/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: libdispatch
-# Date created: 2009-09-23
-# Whom: stas
-#
+# Created by: stas
# $FreeBSD$
-#
PORTNAME= libdispatch
PORTVERSION= 210
@@ -22,7 +18,9 @@ USE_LDCONFIG= yes
# This is needed because PIC support check in autoconf could fail for clang otherwise.
CONFIGURE_ENV= lt_cv_prog_compiler_pic_works=yes
-OPTIONS= CLANG "Build with LLVM/Clang (required for blocks support)" on
+OPTIONS_DEFINE= CLANG
+OPTIONS_DEFAULT= CLANG
+CLANG_DESC= Build with LLVM/Clang (required for blocks support)
MAN3= dispatch.3 dispatch_after.3 dispatch_api.3 dispatch_apply.3 \
dispatch_async.3 dispatch_benchmark.3 dispatch_group_create.3 \
@@ -92,7 +90,7 @@ BROKEN= Does not link on sparc64-9
.endif
.endif
-.if !defined(WITHOUT_CLANG)
+.if ${PORT_OPTIONS:MCLANG}
. if ${OSVERSION} < 900024
BUILD_DEPENDS+= clang:${PORTSDIR}/lang/clang \
${LOCALBASE}/lib/libBlocksRuntime.so:${PORTSDIR}/devel/compiler-rt