aboutsummaryrefslogtreecommitdiff
path: root/devel/libdlna
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2008-03-20 14:12:15 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2008-03-20 14:12:15 +0000
commit28471ace511063f8886f9fb07cddad0be9ab7cdc (patch)
tree8c5a6068842f92ee0802057ee1bca8e8276b1789 /devel/libdlna
parent369eef652b418f61133e0b422cd53a3606225ca8 (diff)
downloadports-28471ace511063f8886f9fb07cddad0be9ab7cdc.tar.gz
ports-28471ace511063f8886f9fb07cddad0be9ab7cdc.zip
Notes
Diffstat (limited to 'devel/libdlna')
-rw-r--r--devel/libdlna/Makefile37
-rw-r--r--devel/libdlna/distinfo3
-rw-r--r--devel/libdlna/pkg-descr6
-rw-r--r--devel/libdlna/pkg-plist7
4 files changed, 53 insertions, 0 deletions
diff --git a/devel/libdlna/Makefile b/devel/libdlna/Makefile
new file mode 100644
index 000000000000..e4128f4f81ea
--- /dev/null
+++ b/devel/libdlna/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: devel/libdlna
+# Date created: Sat Feb 9 20:20:00 UTC 2008
+# Whom: Dave Grochowski <malus.x@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libdlna
+PORTVERSION= 0.2.3
+CATEGORIES= devel
+MASTER_SITES= http://libdlna.geexbox.org/releases/ \
+ http://critical.ch/distfiles/ \
+ http://energy.critical.ch/distfiles/
+
+MAINTAINER= malus.x@gmail.com
+COMMENT= Reference DLNA open-source implementation
+
+LIB_DEPENDS+= avcodec:${PORTSDIR}/multimedia/ffmpeg \
+ avformat:${PORTSDIR}/multimedia/ffmpeg
+
+HAS_CONFIGURE= yes
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_GNOME= pkgconfig
+USE_LDCONFIG= yes
+
+CONFIGURE_ARGS+= --prefix="${PREFIX}" --disable-optimize
+CONFIGURE_ENV+= LDFLAGS=-L${LOCALBASE}/lib
+
+CFLAGS+= -I${LOCALBASE}/include
+
+post-patch:
+ @${REINPLACE_CMD} -e \
+ 's#\(PKGCONFIG_DIR = \).*#\1${LOCALBASE}/libdata/pkgconfig#' \
+ ${WRKSRC}/Makefile
+
+.include <bsd.port.mk>
diff --git a/devel/libdlna/distinfo b/devel/libdlna/distinfo
new file mode 100644
index 000000000000..c31937c36125
--- /dev/null
+++ b/devel/libdlna/distinfo
@@ -0,0 +1,3 @@
+MD5 (libdlna-0.2.3.tar.bz2) = 2c974f95b711e5fd07f78fc4ebfcca66
+SHA256 (libdlna-0.2.3.tar.bz2) = 8eb7941cbae088026dd394fbe6f465cae6dd848edc430c6313f04cf57d1192b4
+SIZE (libdlna-0.2.3.tar.bz2) = 37142
diff --git a/devel/libdlna/pkg-descr b/devel/libdlna/pkg-descr
new file mode 100644
index 000000000000..0e8be7362137
--- /dev/null
+++ b/devel/libdlna/pkg-descr
@@ -0,0 +1,6 @@
+libdlna aims at being the reference open-source implementation of DLNA (Digital
+Living Network Alliance) standards. Its primary goal is to provide DLNA support
+to uShare, an embedded DLNA & UPnP A/V Media Server, but it will be used to
+build both DLNA servers and players in the long term.
+
+WWW: http://libdlna.geexbox.org/
diff --git a/devel/libdlna/pkg-plist b/devel/libdlna/pkg-plist
new file mode 100644
index 000000000000..a8d9e0634d45
--- /dev/null
+++ b/devel/libdlna/pkg-plist
@@ -0,0 +1,7 @@
+include/dlna.h
+lib/libdlna.a
+lib/libdlna.so
+lib/libdlna.so.0
+lib/libdlna.so.0.2.3
+libdata/pkgconfig/libdlna.pc
+@dirrmtry libdata/pkgconfig