aboutsummaryrefslogtreecommitdiff
path: root/devel/libdombey
diff options
context:
space:
mode:
authorThomas Abthorpe <tabthorpe@FreeBSD.org>2010-04-24 20:03:03 +0000
committerThomas Abthorpe <tabthorpe@FreeBSD.org>2010-04-24 20:03:03 +0000
commit6da0297d84be6fdd83ebbf4214e035c2278b3e8b (patch)
tree32cfaca64e76dbb78496b2ac83f882337fc473c6 /devel/libdombey
parent14a74017e8f7f561158be16fe1dfc66880a9ce3e (diff)
downloadports-6da0297d84be6fdd83ebbf4214e035c2278b3e8b.tar.gz
ports-6da0297d84be6fdd83ebbf4214e035c2278b3e8b.zip
Notes
Diffstat (limited to 'devel/libdombey')
-rw-r--r--devel/libdombey/Makefile21
-rw-r--r--devel/libdombey/distinfo3
-rw-r--r--devel/libdombey/pkg-descr16
-rw-r--r--devel/libdombey/pkg-plist2
4 files changed, 42 insertions, 0 deletions
diff --git a/devel/libdombey/Makefile b/devel/libdombey/Makefile
new file mode 100644
index 000000000000..a8cfbf121d65
--- /dev/null
+++ b/devel/libdombey/Makefile
@@ -0,0 +1,21 @@
+# New ports collection makefile for: libdombey
+# Date created: Fri, 23 Apr 2010 14:24:06 EDT
+# Whom: James Bailie <jimmy@mammothcheese.ca>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libdombey
+PORTVERSION= 1.0
+CATEGORIES= devel
+MASTER_SITES= http://www.mammothcheese.ca/
+
+MAINTAINER= jimmy@mammothcheese.ca
+COMMENT= SCGI application server in a library
+
+MAN8= libdombey.8
+MANCOMPRESSED= yes
+
+USE_LDCONFIG= yes
+
+.include <bsd.port.mk>
diff --git a/devel/libdombey/distinfo b/devel/libdombey/distinfo
new file mode 100644
index 000000000000..28f8d8b7514b
--- /dev/null
+++ b/devel/libdombey/distinfo
@@ -0,0 +1,3 @@
+MD5 (libdombey-1.0.tar.gz) = e86209512ffa6d2915ca8eca852e154b
+SHA256 (libdombey-1.0.tar.gz) = bdb0ad139f393af4f61aa9429ea4ba6c9bbc55dbb42e7951ed11013fc7dd01e8
+SIZE (libdombey-1.0.tar.gz) = 11765
diff --git a/devel/libdombey/pkg-descr b/devel/libdombey/pkg-descr
new file mode 100644
index 000000000000..5b2e91b72cb3
--- /dev/null
+++ b/devel/libdombey/pkg-descr
@@ -0,0 +1,16 @@
+libdombey implements an SCGI application server which is incapable of
+generating responses on its own. The programmer writes an initialization
+function and a function to generate responses, then compiles and links his
+or her code against the library to create a complete multi-process SCGI
+application server.
+
+libdombey is intended for use in applications where client requests are
+either GET requests or POST requests encoded with x-www-form-urlencoding.
+It drops connections over which it receives POST requests encoded as
+multipart/form-data.
+
+WWW: http://www.mammothcheese.ca/libdombey.html
+
+--
+James Bailie <jimmy@mammothcheese.ca>
+http://www.mammothcheese.ca
diff --git a/devel/libdombey/pkg-plist b/devel/libdombey/pkg-plist
new file mode 100644
index 000000000000..6b21dbb95ee6
--- /dev/null
+++ b/devel/libdombey/pkg-plist
@@ -0,0 +1,2 @@
+lib/libdombey.so.1.0
+include/dombey.h