aboutsummaryrefslogtreecommitdiff
path: root/devel/libdsp/Makefile
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2001-01-22 16:33:23 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2001-01-22 16:33:23 +0000
commita08d7ea8350ca9b00619dcaea789200e2beb2e60 (patch)
tree1a9ac18d902bc2e1b914c3ed3b6c7078e7d0d10c /devel/libdsp/Makefile
parent0ae3e3a34205824b718a048a154089ba7063765c (diff)
downloadports-a08d7ea8350ca9b00619dcaea789200e2beb2e60.tar.gz
ports-a08d7ea8350ca9b00619dcaea789200e2beb2e60.zip
Notes
Diffstat (limited to 'devel/libdsp/Makefile')
-rw-r--r--devel/libdsp/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/devel/libdsp/Makefile b/devel/libdsp/Makefile
new file mode 100644
index 000000000000..90ed74ee2097
--- /dev/null
+++ b/devel/libdsp/Makefile
@@ -0,0 +1,30 @@
+# ex:ts=8
+# New ports collection makefile for: libdsp
+# Date created: Jan 16, 2001
+# Whom: Ying-Chieh Liao <ijliao@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libdsp
+PORTVERSION= 3.3.4
+CATEGORIES= devel audio
+MASTER_SITES= http://www.pp.clinet.fi/~visitor/dlbins/
+DISTNAME= libdsp-src
+
+MAINTAINER= ijliao@FreeBSD.org
+
+# dont use "USE_LIBTOOL=yes" because there's no configure script
+BUILD_DEPENDS= libtool:${PORTSDIR}/devel/libtool
+
+INSTALLS_SHLIB= yes
+
+WRKSRC= ${WRKDIR}/${PORTNAME:S/dsp/DSP/}-${PORTVERSION}
+MAKEFILE= Makefile.FreeBSD
+
+USE_GMAKE= yes
+
+post-patch:
+ @${PERL} -pi -e "s|%%PREFIX%%|${PREFIX}|g" ${WRKSRC}/${MAKEFILE}
+
+.include <bsd.port.mk>