aboutsummaryrefslogtreecommitdiff
path: root/devel/libedit
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2005-09-13 12:40:03 +0000
committerRenato Botelho <garga@FreeBSD.org>2005-09-13 12:40:03 +0000
commitc69c3ca70e30cbe937472e3f94894b03facea992 (patch)
tree54d65329f1a89f18e7c4397c12d5b36768e527f8 /devel/libedit
parentdd7669fcb18cb373299e35c7dbeb63bf293c51db (diff)
downloadports-c69c3ca70e30cbe937472e3f94894b03facea992.tar.gz
ports-c69c3ca70e30cbe937472e3f94894b03facea992.zip
Notes
Diffstat (limited to 'devel/libedit')
-rw-r--r--devel/libedit/Makefile14
-rw-r--r--devel/libedit/distinfo4
-rw-r--r--devel/libedit/files/patch-makelist11
3 files changed, 23 insertions, 6 deletions
diff --git a/devel/libedit/Makefile b/devel/libedit/Makefile
index eb9dd33d5a65..21812fba59ca 100644
--- a/devel/libedit/Makefile
+++ b/devel/libedit/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= libedit
-PORTVERSION= 2.6.7
-PORTREVISION= 1
+PORTVERSION= 2.6.9
CATEGORIES= devel
MASTER_SITES= ftp://ftp.astron.com/pub/libedit/ \
http://www.canonware.com/download/libedit/
@@ -17,9 +16,10 @@ COMMENT= Command line editing library
USE_REINPLACE= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --disable-readline
INSTALLS_SHLIB= yes
+OPTIONS= READLINE "Enable readline compatibility" off
+
MAN3= editline.3
MAN5= editrc.5
MLINKS= editline.3 el_init.3 \
@@ -41,8 +41,14 @@ MLINKS= editline.3 el_init.3 \
editline.3 history.3
MANCOMPRESSED= no
+.include <bsd.port.pre.mk>
+
+.if !defined(WITH_READLINE)
+CONFIGURE_ARGS+= --disable-readline
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|CFLAGS -O|CFLAGS|g ; \
s|MAJOR="2"|MAJOR="5"|g' ${WRKSRC}/configure
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/devel/libedit/distinfo b/devel/libedit/distinfo
index 48e4a35871ac..984e83f3e632 100644
--- a/devel/libedit/distinfo
+++ b/devel/libedit/distinfo
@@ -1,2 +1,2 @@
-MD5 (libedit-2.6.7.tar.gz) = 6640a3d3d58f0ce1d8c69cfd5cc5a517
-SIZE (libedit-2.6.7.tar.gz) = 150783
+MD5 (libedit-2.6.9.tar.gz) = a007a8134d9daf4340c985085441ca6d
+SIZE (libedit-2.6.9.tar.gz) = 156318
diff --git a/devel/libedit/files/patch-makelist b/devel/libedit/files/patch-makelist
new file mode 100644
index 000000000000..da82137a8109
--- /dev/null
+++ b/devel/libedit/files/patch-makelist
@@ -0,0 +1,11 @@
+--- makelist.orig Tue Sep 13 00:37:41 2005
++++ makelist Tue Sep 13 00:38:08 2005
+@@ -145,7 +145,7 @@
+ #
+ -fh)
+ cat $FILES | $AWK '/el_action_t/ { print $3 }' | \
+- sort | tr '[a-z]' '[A-Z]' | $AWK '
++ sort | tr '[:lower:]' '[:upper:]' | $AWK '
+ BEGIN {
+ printf("/* Automatically generated file, do not edit */\n");
+ printf("#ifndef _h_fcns_c\n#define _h_fcns_c\n");