aboutsummaryrefslogtreecommitdiff
path: root/devel/libedit
diff options
context:
space:
mode:
authorAlejandro Pulver <alepulver@FreeBSD.org>2007-09-29 20:59:12 +0000
committerAlejandro Pulver <alepulver@FreeBSD.org>2007-09-29 20:59:12 +0000
commit0f64b5f4ef092801c649f354477563e7592c8f4f (patch)
tree15cc85920fcee69bbc074fb0570efcb9ebd57851 /devel/libedit
parent1bed6d552b9b496ca49b49721a52517cee75076d (diff)
downloadports-0f64b5f4ef092801c649f354477563e7592c8f4f.tar.gz
ports-0f64b5f4ef092801c649f354477563e7592c8f4f.zip
Notes
Diffstat (limited to 'devel/libedit')
-rw-r--r--devel/libedit/Makefile5
-rw-r--r--devel/libedit/files/patch-configure32
-rw-r--r--devel/libedit/files/patch-readline.c11
-rw-r--r--devel/libedit/pkg-plist3
4 files changed, 50 insertions, 1 deletions
diff --git a/devel/libedit/Makefile b/devel/libedit/Makefile
index 0a4684fcd44d..55a8f15579d6 100644
--- a/devel/libedit/Makefile
+++ b/devel/libedit/Makefile
@@ -7,6 +7,7 @@
PORTNAME= libedit
PORTVERSION= 2.6.10
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= ftp://ftp.astron.com/pub/libedit/ \
http://www.canonware.com/download/libedit/
@@ -16,7 +17,6 @@ COMMENT= Command line editing library
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
-CONFIGURE_ARGS= --disable-readline
MAN3= editline.3
MAN5= editrc.5
@@ -39,6 +39,9 @@ MLINKS= editline.3 el_init.3 \
editline.3 history.3
MANCOMPRESSED= no
+post-extract:
+ ${MV} ${WRKSRC}/readline ${WRKSRC}/editline
+
post-patch:
@${REINPLACE_CMD} -e 's|CFLAGS -O|CFLAGS|g ; \
s|MAJOR="2"|MAJOR="6"|g' ${WRKSRC}/configure
diff --git a/devel/libedit/files/patch-configure b/devel/libedit/files/patch-configure
new file mode 100644
index 000000000000..dbfe24c7f10c
--- /dev/null
+++ b/devel/libedit/files/patch-configure
@@ -0,0 +1,32 @@
+--- configure.orig 2006-11-24 18:13:57.000000000 +0100
++++ configure 2007-09-25 20:39:26.000000000 +0200
+@@ -4601,7 +4601,7 @@
+ LIB_S="libedit.so.$LIB_MAJOR"
+ LIB_S_LINK="libedit.so"
+ LIB_S_LINKS="$LIB_S $LIB_S_LINK"
+- S_LDFLAGS="-shared"
++ S_LDFLAGS="-shared -Wl,-soname=${LIB_S_LINK}.${LIB_MAJOR}"
+ elif test "x$ABI" = "xaout" ; then
+ LIB_S="libedit.so.$LIB_MAJOR.$LIB_MINOR"
+ LIB_S_LINKS=
+@@ -4623,17 +4623,9 @@
+
+ if test "x$enable_readline" = "xyes" ; then
+ CCSRCS="$CCSRCS readline.c"
+- IHDRS="$IHDRS readline/readline.h"
+- IHDR_LINKS="readline.h readline/history.h"
+- HDR_DIRS="$HDR_DIRS include/readline"
+- LIB_A_LINKS="$LIB_A_LINKS libedit.a libreadline.a"
+- if test "x$ABI" = "xelf" ; then
+- LIB_S_LINKS="$LIB_S_LINKS $LIB_S_LINK libreadline.so"
+- elif test "x$ABI" = "xaout" ; then
+- LIB_S_LINKS="$LIB_S_LINKS $LIB_S libreadline.so.$LIB_MAJOR.$LIB_MINOR"
+- elif test "x$ABI" = "xmacho" ; then
+- LIB_S_LINKS="$LIB_S_LINKS $LIB_S_LINK libreadline.dylib"
+- fi
++ IHDRS="$IHDRS editline/readline.h"
++ IHDR_LINKS="readline.h editline/history.h"
++ HDR_DIRS="$HDR_DIRS include/editline"
+ fi
+
+ case "${host}" in
diff --git a/devel/libedit/files/patch-readline.c b/devel/libedit/files/patch-readline.c
new file mode 100644
index 000000000000..5b976c3fd543
--- /dev/null
+++ b/devel/libedit/files/patch-readline.c
@@ -0,0 +1,11 @@
+--- readline.c.orig 2006-11-24 17:52:04.000000000 +0100
++++ readline.c 2007-09-25 17:59:54.000000000 +0200
+@@ -61,7 +61,7 @@
+ #include "el.h"
+ #include "fcns.h" /* for EL_NUM_FCNS */
+ #include "histedit.h"
+-#include "readline/readline.h"
++#include "editline/readline.h"
+ #include "filecomplete.h"
+
+ void rl_prep_terminal(int);
diff --git a/devel/libedit/pkg-plist b/devel/libedit/pkg-plist
index 26288bbc86a3..57c553ae16da 100644
--- a/devel/libedit/pkg-plist
+++ b/devel/libedit/pkg-plist
@@ -1,4 +1,7 @@
+include/editline/history.h
+include/editline/readline.h
include/histedit.h
lib/libedit.a
lib/libedit.so.6
lib/libedit.so
+@dirrm include/editline