aboutsummaryrefslogtreecommitdiff
path: root/devel/libee/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2011-06-27 14:36:11 +0000
committerMartin Wilke <miwi@FreeBSD.org>2011-06-27 14:36:11 +0000
commitcc570daf104bd7425db9f1ccea172542d8f79fc5 (patch)
tree256acbcb575ad114e852530ad480fcb9ef16b896 /devel/libee/Makefile
parent683a0971e745c042b83c8e0a20de4e2f2faae60d (diff)
downloadports-cc570daf104bd7425db9f1ccea172542d8f79fc5.tar.gz
ports-cc570daf104bd7425db9f1ccea172542d8f79fc5.zip
Notes
Diffstat (limited to 'devel/libee/Makefile')
-rw-r--r--devel/libee/Makefile24
1 files changed, 24 insertions, 0 deletions
diff --git a/devel/libee/Makefile b/devel/libee/Makefile
new file mode 100644
index 000000000000..f960be94a5b9
--- /dev/null
+++ b/devel/libee/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: libee
+# Date created: 2011-06-20
+# Whom: Jim Riggs <ports@christianserving.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libee
+PORTVERSION= 0.3.1
+CATEGORIES= devel
+MASTER_SITES= http://www.libee.org/files/download/
+
+MAINTAINER= pgollucci@FreeBSD.org
+COMMENT= An event expression library inspired by CEE
+
+LIB_DEPENDS= estr:${PORTSDIR}/devel/libestr
+
+USE_LDCONFIG= yes
+
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= LIBESTR_CFLAGS="-I${LOCALBASE}/include" LIBESTR_LIBS="-L${LOCALBASE}/lib -lestr"
+CONFIGURE_ARGS+= --prefix="${PREFIX}" --disable-testbench
+
+.include <bsd.port.mk>