aboutsummaryrefslogtreecommitdiff
path: root/devel/libelf
diff options
context:
space:
mode:
authorPeter Pentchev <roam@FreeBSD.org>2005-09-05 22:36:33 +0000
committerPeter Pentchev <roam@FreeBSD.org>2005-09-05 22:36:33 +0000
commit2a14592aac0295cb9d52c9f90243d12497ee8581 (patch)
tree75bed12ad30ba8a771c71a8649f2d75154fcc101 /devel/libelf
parentde7c1f389c9495fe26e1607ba91c60feaef95281 (diff)
downloadports-2a14592aac0295cb9d52c9f90243d12497ee8581.tar.gz
ports-2a14592aac0295cb9d52c9f90243d12497ee8581.zip
Update to libelf 0.8.6. In addition to the update in the PR, fix a build
issue on FreeBSD 4.x, whose <elf.h> does not define ELFMAG and SELFMAG. PR: 85120 Submitted by: Vasil Dimov <vd@datamax.bg>
Notes
Notes: svn path=/head/; revision=142035
Diffstat (limited to 'devel/libelf')
-rw-r--r--devel/libelf/Makefile17
-rw-r--r--devel/libelf/distinfo4
-rw-r--r--devel/libelf/files/patch-Makefile.in11
-rw-r--r--devel/libelf/files/patch-configure27
-rw-r--r--devel/libelf/files/patch-lib::sys_elf.h.in16
-rw-r--r--devel/libelf/pkg-plist1
6 files changed, 55 insertions, 21 deletions
diff --git a/devel/libelf/Makefile b/devel/libelf/Makefile
index 6b1b43f46c86..ca31eb021dff 100644
--- a/devel/libelf/Makefile
+++ b/devel/libelf/Makefile
@@ -6,11 +6,10 @@
#
PORTNAME= libelf
-PORTVERSION= 0.8.5
-PORTREVISION= 1
+PORTVERSION= 0.8.6
CATEGORIES= devel
-MASTER_SITES= ${MASTER_SITE_SUNSITE} \
- http://www.mr511.de/software/
+MASTER_SITES= http://www.mr511.de/software/ \
+ ${MASTER_SITE_SUNSITE}
MASTER_SITE_SUBDIR= libs .
MAINTAINER= roam@FreeBSD.org
@@ -26,4 +25,14 @@ USE_GETTEXT= yes
NOMAN= defined
+USE_REINPLACE= yes
+
+FILES_TO_PATCH=lib/32.fsize.c lib/64.xlatetof.c lib/cook.c lib/gelf.h lib/gelftrans.c
+
+post-patch:
+ ${REINPLACE_CMD} \
+ -e 's/Elf64_Xword/Elf64_Word/g' \
+ -e 's/Elf64_Sxword/Elf64_Sword/g' \
+ ${FILES_TO_PATCH:S,^,${WRKSRC}/,}
+
.include <bsd.port.mk>
diff --git a/devel/libelf/distinfo b/devel/libelf/distinfo
index 3d8dec774019..6126978d62fb 100644
--- a/devel/libelf/distinfo
+++ b/devel/libelf/distinfo
@@ -1,2 +1,2 @@
-MD5 (libelf-0.8.5.tar.gz) = c1daf069367871350ece779b7de20047
-SIZE (libelf-0.8.5.tar.gz) = 132111
+MD5 (libelf-0.8.6.tar.gz) = d444fb0068cdfed01bb1fd1e91d29270
+SIZE (libelf-0.8.6.tar.gz) = 144198
diff --git a/devel/libelf/files/patch-Makefile.in b/devel/libelf/files/patch-Makefile.in
new file mode 100644
index 000000000000..7e3c457ecaec
--- /dev/null
+++ b/devel/libelf/files/patch-Makefile.in
@@ -0,0 +1,11 @@
+--- Makefile.in.orig Fri Aug 19 16:51:51 2005
++++ Makefile.in Fri Aug 19 16:52:13 2005
+@@ -23,7 +23,7 @@
+ exec_prefix = @exec_prefix@
+ libdir = @libdir@
+
+-pkgdir = $(libdir)/pkgconfig
++pkgdir = $(prefix)/libdata/pkgconfig
+
+ MV = mv -f
+ RM = rm -f
diff --git a/devel/libelf/files/patch-configure b/devel/libelf/files/patch-configure
index e81a68b8b75f..d3853c7be889 100644
--- a/devel/libelf/files/patch-configure
+++ b/devel/libelf/files/patch-configure
@@ -1,18 +1,15 @@
-
-$FreeBSD$
-
---- configure.old Sun Dec 14 14:11:54 2003
-+++ configure Sun Dec 14 14:13:28 2003
-@@ -1139,7 +1139,7 @@
+--- configure.orig Fri Aug 19 16:00:37 2005
++++ configure Fri Aug 19 16:05:31 2005
+@@ -1142,7 +1142,7 @@
fi
--for ac_hdr in unistd.h fcntl.h elf.h sys/elf.h link.h sys/link.h
-+for ac_hdr in unistd.h fcntl.h sys/elf.h link.h sys/link.h
+-for ac_hdr in unistd.h stdint.h fcntl.h
++for ac_hdr in unistd.h stdint.h fcntl.h elf.h
do
ac_safe=`echo "$ac_hdr" | sed 'y%./+-%__p_%'`
echo $ac_n "checking for $ac_hdr""... $ac_c" 1>&6
-@@ -3055,7 +3055,7 @@
+@@ -3218,7 +3218,7 @@
fi
case "$host" in
@@ -21,12 +18,12 @@ $FreeBSD$
if test "$GCC" = yes; then
-@@ -3112,13 +3112,12 @@
- then
- SHLIB_SFX='-$(VERSION).so'
- else
-- SHLIB_SFX='.so.$(VERSION)'
-+ SHLIB_SFX='.so.$(MAJOR)'
+@@ -3273,13 +3273,12 @@
+ PICFLAGS='-fPIC -DPIC'
+ if test "$mr_enable_gnu_names" = yes
+ then SHLIB_SFX='-$(VERSION).so'
+- else SHLIB_SFX='.so.$(VERSION)'
++ else SHLIB_SFX='.so.$(MAJOR)'
fi
SHLINK_SFX='.so'
SONAME_SFX='.so.$(MAJOR)'
diff --git a/devel/libelf/files/patch-lib::sys_elf.h.in b/devel/libelf/files/patch-lib::sys_elf.h.in
new file mode 100644
index 000000000000..b9c8e0b181fa
--- /dev/null
+++ b/devel/libelf/files/patch-lib::sys_elf.h.in
@@ -0,0 +1,16 @@
++++ lib/sys_elf.h.in.orig Mon Sep 5 22:31:49 2005
+--- lib/sys_elf.h.in Mon Sep 5 22:33:06 2005
+@@ -77,6 +77,13 @@
+ */
+ #ifdef __LIBELF_HEADER_ELF_H
+
++#ifndef ELFMAG
++#define ELFMAG "\177ELF"
++#endif /* ELFMAG */
++#ifndef SELFMAG
++#define SELFMAG 4
++#endif /* SELFMAG */
++
+ # ifndef ELF32_FSZ_ADDR
+ # define ELF32_FSZ_ADDR 4
+ # define ELF32_FSZ_HALF 2
diff --git a/devel/libelf/pkg-plist b/devel/libelf/pkg-plist
index e5538a33018f..445fb8e55e39 100644
--- a/devel/libelf/pkg-plist
+++ b/devel/libelf/pkg-plist
@@ -6,5 +6,6 @@ include/libelf/elf_repl.h
lib/libelf.a
lib/libelf.so
lib/libelf.so.%%LIBVER%%
+libdata/pkgconfig/libelf.pc
share/locale/de/LC_MESSAGES/libelf.mo
@dirrm include/libelf