aboutsummaryrefslogtreecommitdiff
path: root/devel/libelf
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2012-06-12 09:17:03 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2012-06-12 09:17:03 +0000
commit36aec2ee4d4789c8cc6ad940264e1a101d8a7977 (patch)
treefadc33ad2f29c6931b7a10a46ca3d20a561a3331 /devel/libelf
parent59642d1219c0fc9ff42830b664320824c78e3a3f (diff)
downloadports-36aec2ee4d4789c8cc6ad940264e1a101d8a7977.tar.gz
ports-36aec2ee4d4789c8cc6ad940264e1a101d8a7977.zip
Convert to new options framework
Notes
Notes: svn path=/head/; revision=299101
Diffstat (limited to 'devel/libelf')
-rw-r--r--devel/libelf/Makefile14
1 files changed, 8 insertions, 6 deletions
diff --git a/devel/libelf/Makefile b/devel/libelf/Makefile
index faa49727670a..5d836ffbd580 100644
--- a/devel/libelf/Makefile
+++ b/devel/libelf/Makefile
@@ -16,9 +16,11 @@ MASTER_SITE_SUBDIR= libs
MAINTAINER= ports@FreeBSD.org
COMMENT= A public ELF file access library similar to libelf(3) in Solaris
-OPTIONS= EXTENDED "ELF format extensions" on \
- NLS "Native Language Support" on \
- SANITY "Avoid loading invalid ELF files" on
+OPTIONS_DEFINE= EXTENDED NLS SANITY
+OPTIONS_DEFAULT= EXTENDED SANITY
+
+EXTENDED_DESC= ELF format extensions
+SANITY_DESC= Avoid loading invalid ELF files
.include <bsd.port.options.mk>
@@ -28,7 +30,7 @@ USE_LDCONFIG= yes
NOMAN= defined
-.if !defined(WITHOUT_NLS)
+.if ${PORT_OPTIONS:MNLS}
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib -lintl
CONFIGURE_ARGS+= --enable-nls
@@ -39,13 +41,13 @@ CONFIGURE_ARGS+= --disable-nls
PLIST_SUB+= GETTEXT="@comment "
.endif
-.if !defined(WITHOUT_EXTENDED)
+.if ${PORT_OPTIONS:MEXTENDED}
CONFIGURE_ARGS+= --enable-extended-format
.else
CONFIGURE_ARGS+= --disable-extended-format
.endif
-.if !defined(WITHOUT_SANITY)
+.if ${PORT_OPTIONS:MSANITY}
CONFIGURE_ARGS+= --enable-sanity-checks
.else
CONFIGURE_ARGS+= --disable-sanity-checks