aboutsummaryrefslogtreecommitdiff
path: root/devel/libelf
diff options
context:
space:
mode:
authorPeter Pentchev <roam@FreeBSD.org>2006-09-26 08:29:19 +0000
committerPeter Pentchev <roam@FreeBSD.org>2006-09-26 08:29:19 +0000
commit085ab5a6791fa6af6c562b0dbc7ab7b4bc269564 (patch)
tree26985ed7a12fddf5ecb7e861b1d41ae07082c34b /devel/libelf
parent4524384997e632086b16c72c16cd7c1ab0120adf (diff)
downloadports-085ab5a6791fa6af6c562b0dbc7ab7b4bc269564.tar.gz
ports-085ab5a6791fa6af6c562b0dbc7ab7b4bc269564.zip
Notes
Diffstat (limited to 'devel/libelf')
-rw-r--r--devel/libelf/Makefile32
-rw-r--r--devel/libelf/distinfo6
-rw-r--r--devel/libelf/files/patch-configure28
-rw-r--r--devel/libelf/pkg-plist2
4 files changed, 51 insertions, 17 deletions
diff --git a/devel/libelf/Makefile b/devel/libelf/Makefile
index 8216d7df5898..55f7b0edbbb2 100644
--- a/devel/libelf/Makefile
+++ b/devel/libelf/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= libelf
-PORTVERSION= 0.8.8
+PORTVERSION= 0.8.9
CATEGORIES= devel
MASTER_SITES= http://www.mr511.de/software/ \
${MASTER_SITE_SUNSITE}
@@ -15,18 +15,34 @@ MASTER_SITE_SUBDIR= libs
MAINTAINER= roam@FreeBSD.org
COMMENT= A public ELF file access library similar to libelf(3) in Solaris
+OPTIONS= EXTENDED 'ELF format extensions' on \
+ NLS 'Native Language Support' on
+
+.include <bsd.port.pre.mk>
+
GNU_CONFIGURE= yes
-CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib -lintl"
-CONFIGURE_ARGS+= --enable-shared --disable-compat \
- --enable-extended-format
-INSTALLS_SHLIB= yes
+CONFIGURE_ARGS+= --enable-shared --disable-compat
+USE_LDCONFIG= yes
PLIST_SUB+= LIBVER=${PORTVERSION:R}
-USE_GETTEXT= yes
NOMAN= defined
-.include <bsd.port.pre.mk>
+.if !defined(WITHOUT_NLS)
+CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib -lintl"
+CONFIGURE_ARGS+= --enable-nls
+USE_GETTEXT= yes
+PLIST_SUB+= GETTEXT=""
+.else
+CONFIGURE_ARGS+= --disable-nls
+PLIST_SUB+= GETTEXT="@comment "
+.endif
+
+.if !defined(WITHOUT_EXTENDED)
+CONFIGURE_ARGS+= --enable-extended-format
+.else
+CONFIGURE_ARGS+= --disable-extended-format
+.endif
.if ${OSVERSION} < 600102
diff --git a/devel/libelf/distinfo b/devel/libelf/distinfo
index fa4b361cd2d3..c207e6622e8f 100644
--- a/devel/libelf/distinfo
+++ b/devel/libelf/distinfo
@@ -1,3 +1,3 @@
-MD5 (libelf-0.8.8.tar.gz) = be84e553686dd50c8b6d520f86f46521
-SHA256 (libelf-0.8.8.tar.gz) = 3cba77187ea8ec59c10afecbbaecee2c1aaa12161843ad9f86f768342552d226
-SIZE (libelf-0.8.8.tar.gz) = 146485
+MD5 (libelf-0.8.9.tar.gz) = 11904a77b948bcfab671e80100b6098d
+SHA256 (libelf-0.8.9.tar.gz) = 9eafb75460233a354012a6e7f2af54fe7e569dadb6bb532ffaa59df22d36ba18
+SIZE (libelf-0.8.9.tar.gz) = 146250
diff --git a/devel/libelf/files/patch-configure b/devel/libelf/files/patch-configure
index d3853c7be889..bad5f309dc6f 100644
--- a/devel/libelf/files/patch-configure
+++ b/devel/libelf/files/patch-configure
@@ -1,6 +1,6 @@
---- configure.orig Fri Aug 19 16:00:37 2005
-+++ configure Fri Aug 19 16:05:31 2005
-@@ -1142,7 +1142,7 @@
+--- configure.orig Tue Sep 26 10:18:31 2006
++++ configure Tue Sep 26 10:19:11 2006
+@@ -1144,7 +1144,7 @@
fi
@@ -9,7 +9,7 @@
do
ac_safe=`echo "$ac_hdr" | sed 'y%./+-%__p_%'`
echo $ac_n "checking for $ac_hdr""... $ac_c" 1>&6
-@@ -3218,7 +3218,7 @@
+@@ -3256,7 +3256,7 @@
fi
case "$host" in
@@ -18,7 +18,7 @@
if test "$GCC" = yes; then
-@@ -3273,13 +3273,12 @@
+@@ -3311,13 +3311,12 @@
PICFLAGS='-fPIC -DPIC'
if test "$mr_enable_gnu_names" = yes
then SHLIB_SFX='-$(VERSION).so'
@@ -34,3 +34,21 @@
else
echo "configure: warning: shared libraries not supported for $host" 1>&2
mr_enable_shared=no
+@@ -3507,7 +3506,7 @@
+ ac_given_srcdir=$srcdir
+ ac_given_INSTALL="$INSTALL"
+
+-trap 'rm -fr `echo "Makefile lib/Makefile po/Makefile w32/Makefile libelf.pc config.h lib/sys_elf.h" | sed "s/:[^ ]*//g"` conftest*; exit 1' 1 2 15
++trap 'rm -fr `echo "Makefile lib/Makefile po/Makefile libelf.pc config.h lib/sys_elf.h" | sed "s/:[^ ]*//g"` conftest*; exit 1' 1 2 15
+ EOF
+ cat >> $CONFIG_STATUS <<EOF
+
+@@ -3622,7 +3621,7 @@
+
+ cat >> $CONFIG_STATUS <<EOF
+
+-CONFIG_FILES=\${CONFIG_FILES-"Makefile lib/Makefile po/Makefile w32/Makefile libelf.pc"}
++CONFIG_FILES=\${CONFIG_FILES-"Makefile lib/Makefile po/Makefile libelf.pc"}
+ EOF
+ cat >> $CONFIG_STATUS <<\EOF
+ for ac_file in .. $CONFIG_FILES; do if test "x$ac_file" != x..; then
diff --git a/devel/libelf/pkg-plist b/devel/libelf/pkg-plist
index 445fb8e55e39..a3dce78e89d8 100644
--- a/devel/libelf/pkg-plist
+++ b/devel/libelf/pkg-plist
@@ -7,5 +7,5 @@ lib/libelf.a
lib/libelf.so
lib/libelf.so.%%LIBVER%%
libdata/pkgconfig/libelf.pc
-share/locale/de/LC_MESSAGES/libelf.mo
+%%GETTEXT%%share/locale/de/LC_MESSAGES/libelf.mo
@dirrm include/libelf