aboutsummaryrefslogtreecommitdiff
path: root/devel/libev
diff options
context:
space:
mode:
authorVsevolod Stakhov <vsevolod@FreeBSD.org>2010-08-17 14:28:15 +0000
committerVsevolod Stakhov <vsevolod@FreeBSD.org>2010-08-17 14:28:15 +0000
commit5fa73c384b7638e1cf1eb1f0240317d8c1bae742 (patch)
tree662bc3c8a4db0ceba9d3a70c68e86d26443271b0 /devel/libev
parentf52f1ea90452a81c16b080db24bf80fce6daa5f4 (diff)
- Update to 3.9
- Add kqueue to recommended backends - Fix TABs in Makefile PR: 149681 Submitted by: mm
Notes
Notes: svn path=/head/; revision=259430
Diffstat (limited to 'devel/libev')
-rw-r--r--devel/libev/Makefile17
-rw-r--r--devel/libev/distinfo6
-rw-r--r--devel/libev/files/patch-ev.c15
3 files changed, 27 insertions, 11 deletions
diff --git a/devel/libev/Makefile b/devel/libev/Makefile
index 16da6b43c02b..230d6f2b8ba9 100644
--- a/devel/libev/Makefile
+++ b/devel/libev/Makefile
@@ -5,18 +5,19 @@
# $FreeBSD$
#
-PORTNAME= libev
-PORTVERSION= 3.8
-PORTEPOCH= 1
-CATEGORIES= devel
-MASTER_SITES= http://dist.schmorp.de/libev/Attic/
+PORTNAME= libev
+PORTVERSION= 3.9
+PORTEPOCH= 1
+CATEGORIES= devel
+MASTER_SITES= http://dist.schmorp.de/libev/ \
+ http://dist.schmorp.de/libev/Attic/
-MAINTAINER= vsevolod@FreeBSD.org
-COMMENT= A full-featured and high-performance event loop library
+MAINTAINER= vsevolod@FreeBSD.org
+COMMENT= A full-featured and high-performance event loop library
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
-MAN3= ev.3
+MAN3= ev.3
.include <bsd.port.mk>
diff --git a/devel/libev/distinfo b/devel/libev/distinfo
index 28d6f6c48db0..b6cbf4fcb29d 100644
--- a/devel/libev/distinfo
+++ b/devel/libev/distinfo
@@ -1,3 +1,3 @@
-MD5 (libev-3.8.tar.gz) = 4897453c077056769777d43e5495ded1
-SHA256 (libev-3.8.tar.gz) = 25e353af5707bc4261276e02901ad469e1a46c589eaf5f66c5d3275c98b12294
-SIZE (libev-3.8.tar.gz) = 470250
+MD5 (libev-3.9.tar.gz) = 40fe7d56d70db83cc0c22a6a68d87a96
+SHA256 (libev-3.9.tar.gz) = 0b81cb55a8eb0a2e3d2364a397e244812dd6dd496e860ed7bf143e39e4c21c2e
+SIZE (libev-3.9.tar.gz) = 473062
diff --git a/devel/libev/files/patch-ev.c b/devel/libev/files/patch-ev.c
new file mode 100644
index 000000000000..945cf988824d
--- /dev/null
+++ b/devel/libev/files/patch-ev.c
@@ -0,0 +1,15 @@
+--- ev.c.orig 2010-08-16 08:33:48.667681306 +0200
++++ ev.c 2010-08-16 08:33:51.449982136 +0200
+@@ -1470,10 +1470,12 @@
+ unsigned int flags = ev_supported_backends ();
+
+ #ifndef __NetBSD__
++#ifndef __FreeBSD__
+ /* kqueue is borked on everything but netbsd apparently */
+ /* it usually doesn't work correctly on anything but sockets and pipes */
+ flags &= ~EVBACKEND_KQUEUE;
+ #endif
++#endif
+ #ifdef __APPLE__
+ /* only select works correctly on that "unix-certified" platform */
+ flags &= ~EVBACKEND_KQUEUE; /* horribly broken, even for sockets */