aboutsummaryrefslogtreecommitdiff
path: root/devel/libev
diff options
context:
space:
mode:
authorVsevolod Stakhov <vsevolod@FreeBSD.org>2011-09-16 16:17:40 +0000
committerVsevolod Stakhov <vsevolod@FreeBSD.org>2011-09-16 16:17:40 +0000
commita0e9aa0bec90756b70f0864509e8e84177e68e46 (patch)
treecc2fea8d46b3d994ab5122f071bd28255947d2e3 /devel/libev
parent3f6d1d4ea71b6d61dca49a04721983741a831364 (diff)
Notes
Diffstat (limited to 'devel/libev')
-rw-r--r--devel/libev/Makefile15
-rw-r--r--devel/libev/distinfo4
-rw-r--r--devel/libev/files/libev.pc.in10
-rw-r--r--devel/libev/files/patch-configure58
-rw-r--r--devel/libev/files/patch-ev++.h32
-rw-r--r--devel/libev/files/patch-ev.c8
-rw-r--r--devel/libev/pkg-plist3
7 files changed, 39 insertions, 91 deletions
diff --git a/devel/libev/Makefile b/devel/libev/Makefile
index fe5923035cd8..a4a4e41813a1 100644
--- a/devel/libev/Makefile
+++ b/devel/libev/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= libev
-PORTVERSION= 3.9
-PORTREVISION= 1
+PORTVERSION= 4.04
PORTEPOCH= 1
CATEGORIES= devel
MASTER_SITES= http://dist.schmorp.de/libev/ \
@@ -18,13 +17,17 @@ COMMENT= A full-featured and high-performance event loop library
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
+USE_GNOME= pkgconfig
MAN3= ev.3
+PKGCONFIGDIR?= ${PREFIX}/libdata/pkgconfig
+
post-patch:
- @${REINPLACE_CMD} -e 's/if EV_MINIMAL/if defined(EV_MINIMAL) \&\& EV_MINIMAL/g' \
- ${WRKSRC}/ev.h \
- ${WRKSRC}/ev.c \
- ${WRKSRC}/ev++.h
+ @${SED} -e 's|%PREFIX%|${PREFIX}|g ; s|%VERSION%|${PORTVERSION}|g' \
+ ${FILESDIR}/libev.pc.in > ${WRKDIR}/libev.pc
+
+post-install:
+ @${INSTALL_DATA} ${WRKDIR}/libev.pc ${PKGCONFIGDIR}/
.include <bsd.port.mk>
diff --git a/devel/libev/distinfo b/devel/libev/distinfo
index 87ebea481668..e36a85846a04 100644
--- a/devel/libev/distinfo
+++ b/devel/libev/distinfo
@@ -1,2 +1,2 @@
-SHA256 (libev-3.9.tar.gz) = 0b81cb55a8eb0a2e3d2364a397e244812dd6dd496e860ed7bf143e39e4c21c2e
-SIZE (libev-3.9.tar.gz) = 473062
+SHA256 (libev-4.04.tar.gz) = ab3a09e967e3b868055cd9363fd236aa093f8643d19cc7042e90e0dfe905b012
+SIZE (libev-4.04.tar.gz) = 471713
diff --git a/devel/libev/files/libev.pc.in b/devel/libev/files/libev.pc.in
new file mode 100644
index 000000000000..59a5e0c43578
--- /dev/null
+++ b/devel/libev/files/libev.pc.in
@@ -0,0 +1,10 @@
+prefix=%PREFIX%
+libdir=${prefix}/lib
+includedi=${prefix}/include
+
+Name: libev
+Description: High-performance event loop/event model
+Version: %VERSION%
+Libs: -L${libdir} -lev
+Cflags: -I${includedir}
+
diff --git a/devel/libev/files/patch-configure b/devel/libev/files/patch-configure
index 947059bd02a9..985565c13e16 100644
--- a/devel/libev/files/patch-configure
+++ b/devel/libev/files/patch-configure
@@ -1,50 +1,16 @@
---- configure.orig 2008-01-21 14:41:04.171283374 +0300
-+++ configure 2008-01-21 14:42:41.856789774 +0300
-@@ -3458,18 +3458,6 @@
- echo "${ECHO_T}$ac_cv_prog_cc_g" >&6; }
- if test "$ac_test_CFLAGS" = set; then
- CFLAGS=$ac_save_CFLAGS
--elif test $ac_cv_prog_cc_g = yes; then
-- if test "$GCC" = yes; then
-- CFLAGS="-g -O2"
-- else
-- CFLAGS="-g"
-- fi
--else
-- if test "$GCC" = yes; then
-- CFLAGS="-O2"
-- else
-- CFLAGS=
-- fi
- fi
- { echo "$as_me:$LINENO: checking for $CC option to accept ISO C89" >&5
- echo $ECHO_N "checking for $CC option to accept ISO C89... $ECHO_C" >&6; }
-@@ -5473,18 +5461,6 @@
- echo "${ECHO_T}$ac_cv_prog_cxx_g" >&6; }
- if test "$ac_test_CXXFLAGS" = set; then
- CXXFLAGS=$ac_save_CXXFLAGS
--elif test $ac_cv_prog_cxx_g = yes; then
-- if test "$GXX" = yes; then
-- CXXFLAGS="-g -O2"
-- else
-- CXXFLAGS="-g"
-- fi
--else
-- if test "$GXX" = yes; then
-- CXXFLAGS="-O2"
-- else
-- CXXFLAGS=
-- fi
- fi
- ac_ext=cpp
- ac_cpp='$CXXCPP $CPPFLAGS'
-@@ -19140,9 +19116,6 @@
-
+--- ./configure.orig 2011-02-16 09:03:29.000000000 +0100
++++ ./configure 2011-08-19 16:59:46.000000000 +0200
+@@ -10433,13 +10433,6 @@
+ # Only expand once:
+-
+-
-if test "x$GCC" = xyes ; then
-- CFLAGS="$CFLAGS -O3"
+- CFLAGS="-O3 $CFLAGS"
-fi
-
-
-
+-
+-
+ for ac_header in sys/inotify.h sys/epoll.h sys/event.h port.h poll.h sys/select.h sys/eventfd.h sys/signalfd.h
+ do :
+ as_ac_Header=`$as_echo "ac_cv_header_$ac_header" | $as_tr_sh`
diff --git a/devel/libev/files/patch-ev++.h b/devel/libev/files/patch-ev++.h
deleted file mode 100644
index da46ef2bbb37..000000000000
--- a/devel/libev/files/patch-ev++.h
+++ /dev/null
@@ -1,32 +0,0 @@
---- ev++.h.orig 2009-08-17 19:12:04.000000000 +0400
-+++ ev++.h 2009-08-17 19:20:40.000000000 +0400
-@@ -76,7 +76,7 @@
- ASYNC = EV_ASYNC,
- EMBED = EV_EMBED,
- # undef ERROR // some systems stupidly #define ERROR
-- ERROR = EV_ERROR,
-+ ERROR = EV_ERROR
- };
-
- enum
-@@ -464,7 +464,7 @@
- }
-
- template<class K, void (K::*method)(watcher &w, int)>
-- static void method_thunk (EV_P_ ev_watcher *w, int revents)
-+ static void method_thunk (struct ev_loop *, ev_watcher *w, int revents)
- {
- (static_cast<K *>(w->data)->*method)
- (*static_cast<watcher *>(w), revents);
-@@ -478,9 +478,9 @@
- }
-
- template<class K, void (K::*method)()>
-- static void method_noargs_thunk (EV_P_ ev_watcher *w, int revents)
-+ static void method_noargs_thunk (struct ev_loop *, ev_watcher *w, int /*revents*/)
- {
-- static_cast<K *>(w->data)->*method
-+ (static_cast<K *>(w->data)->*method)
- ();
- }
-
diff --git a/devel/libev/files/patch-ev.c b/devel/libev/files/patch-ev.c
index 945cf988824d..1821cc675d9d 100644
--- a/devel/libev/files/patch-ev.c
+++ b/devel/libev/files/patch-ev.c
@@ -1,8 +1,8 @@
---- ev.c.orig 2010-08-16 08:33:48.667681306 +0200
-+++ ev.c 2010-08-16 08:33:51.449982136 +0200
-@@ -1470,10 +1470,12 @@
+--- ./ev.c.orig 2011-02-09 00:17:37.000000000 +0100
++++ ./ev.c 2011-08-19 17:01:35.000000000 +0200
+@@ -1591,10 +1591,12 @@
unsigned int flags = ev_supported_backends ();
-
+
#ifndef __NetBSD__
+#ifndef __FreeBSD__
/* kqueue is borked on everything but netbsd apparently */
diff --git a/devel/libev/pkg-plist b/devel/libev/pkg-plist
index f9685302cf1a..35b33fcfc153 100644
--- a/devel/libev/pkg-plist
+++ b/devel/libev/pkg-plist
@@ -1,6 +1,7 @@
lib/libev.a
lib/libev.la
lib/libev.so
-lib/libev.so.3
+lib/libev.so.4
+libdata/pkgconfig/libev.pc
include/ev.h
include/ev++.h