aboutsummaryrefslogtreecommitdiff
path: root/devel/libev
diff options
context:
space:
mode:
authorVsevolod Stakhov <vsevolod@FreeBSD.org>2007-12-18 14:46:56 +0000
committerVsevolod Stakhov <vsevolod@FreeBSD.org>2007-12-18 14:46:56 +0000
commitaa33df36e50e010b6b2e011db08f4925a6e3ae26 (patch)
treeb2ba6880ccbfb21080aef923713bd38a21610eaf /devel/libev
parentf84cbe4fe825a4247fb37b901043d7baefaa5fae (diff)
downloadports-aa33df36e50e010b6b2e011db08f4925a6e3ae26.tar.gz
ports-aa33df36e50e010b6b2e011db08f4925a6e3ae26.zip
Notes
Diffstat (limited to 'devel/libev')
-rw-r--r--devel/libev/Makefile21
-rw-r--r--devel/libev/distinfo3
-rw-r--r--devel/libev/files/patch-Makefile.in19
-rw-r--r--devel/libev/pkg-descr6
-rw-r--r--devel/libev/pkg-plist7
5 files changed, 56 insertions, 0 deletions
diff --git a/devel/libev/Makefile b/devel/libev/Makefile
new file mode 100644
index 000000000000..5f81121b5ba0
--- /dev/null
+++ b/devel/libev/Makefile
@@ -0,0 +1,21 @@
+# New ports collection makefile for: libev
+# Date created: 18 Dec 2007
+# Whom: vsevolod
+#
+# $FreeBSD$
+#
+
+PORTNAME= libev
+PORTVERSION= 1.86
+CATEGORIES= devel
+MASTER_SITES= http://dist.schmorp.de/libev/Attic/
+
+MAINTAINER= vsevolod@FreeBSD.org
+COMMENT= A full-featured and high-performance event loop library
+
+GNU_CONFIGURE= yes
+USE_LDCONFIG= yes
+
+MAN3= ev.3
+
+.include <bsd.port.mk>
diff --git a/devel/libev/distinfo b/devel/libev/distinfo
new file mode 100644
index 000000000000..e0d5b06c61e2
--- /dev/null
+++ b/devel/libev/distinfo
@@ -0,0 +1,3 @@
+MD5 (libev-1.86.tar.gz) = b90a196f7cd8e9b09c2c2caa39615188
+SHA256 (libev-1.86.tar.gz) = 8db02bba92cc563399e9628f687c978b6b33530c8cae7f82e32645f3ca646d53
+SIZE (libev-1.86.tar.gz) = 389386
diff --git a/devel/libev/files/patch-Makefile.in b/devel/libev/files/patch-Makefile.in
new file mode 100644
index 000000000000..473f03de0f0a
--- /dev/null
+++ b/devel/libev/files/patch-Makefile.in
@@ -0,0 +1,19 @@
+--- Makefile.in.orig 2007-12-18 04:49:11.000000000 +0300
++++ Makefile.in 2007-12-18 17:18:57.194279648 +0300
+@@ -142,14 +142,14 @@
+ VERSION_INFO = 1:0
+
+ EXTRA_DIST = LICENSE libev.m4 autogen.sh \
+- ev.h ev_vars.h ev_wrap.h event_compat.h ev++.h event.h \
++ ev.h ev_vars.h ev_wrap.h event_compat.h ev++.h \
+ ev_epoll.c ev_select.c ev_poll.c ev_kqueue.c ev_port.c ev_win32.c \
+ ev.3 ev.pod
+
+
+ man_MANS = ev.3
+
+-include_HEADERS = ev.h event_compat.h ev++.h event.h
++include_HEADERS = ev.h event_compat.h ev++.h
+
+ lib_LTLIBRARIES = libev.la
+
diff --git a/devel/libev/pkg-descr b/devel/libev/pkg-descr
new file mode 100644
index 000000000000..c83c000f62f7
--- /dev/null
+++ b/devel/libev/pkg-descr
@@ -0,0 +1,6 @@
+Libev is a high-performance event loop/event model with lots of features.
+It is modelled (very losely) after libevent and the Event perl module,
+but aims to be faster and more correct, and also more featureful. And
+also smaller.
+
+WWW: http://software.schmorp.de/pkg/libev
diff --git a/devel/libev/pkg-plist b/devel/libev/pkg-plist
new file mode 100644
index 000000000000..195e5234ce6c
--- /dev/null
+++ b/devel/libev/pkg-plist
@@ -0,0 +1,7 @@
+lib/libev.a
+lib/libev.la
+lib/libev.so
+lib/libev.so.1
+include/ev.h
+include/ev++.h
+include/event_compat.h