aboutsummaryrefslogtreecommitdiff
path: root/devel/libev
diff options
context:
space:
mode:
authorVsevolod Stakhov <vsevolod@FreeBSD.org>2015-07-13 11:39:56 +0000
committerVsevolod Stakhov <vsevolod@FreeBSD.org>2015-07-13 11:39:56 +0000
commit6de76292e03d74f1b5fa81314969027accaeb7d5 (patch)
treed94ed1fb321f612d98ee759fab4d2089f6ffa16c /devel/libev
parentf2a359f6d2e56ab7cd4c2f90bacd5ef6810a3a0b (diff)
downloadports-6de76292e03d74f1b5fa81314969027accaeb7d5.tar.gz
ports-6de76292e03d74f1b5fa81314969027accaeb7d5.zip
Notes
Diffstat (limited to 'devel/libev')
-rw-r--r--devel/libev/Makefile7
-rw-r--r--devel/libev/distinfo4
-rw-r--r--devel/libev/files/patch-ev.c27
3 files changed, 12 insertions, 26 deletions
diff --git a/devel/libev/Makefile b/devel/libev/Makefile
index 3f1ea9586bcf..c22382e9b9e7 100644
--- a/devel/libev/Makefile
+++ b/devel/libev/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= libev
-PORTVERSION= 4.15
-PORTREVISION= 1
+PORTVERSION= 4.20
PORTEPOCH= 1
CATEGORIES= devel
MASTER_SITES= http://dist.schmorp.de/libev/ \
@@ -12,6 +11,8 @@ MASTER_SITES= http://dist.schmorp.de/libev/ \
MAINTAINER= vsevolod@FreeBSD.org
COMMENT= Full-featured and high-performance event loop library
+LICENSE= BSD2CLAUSE
+
GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
USES= libtool pkgconfig
@@ -24,6 +25,6 @@ post-patch:
${FILESDIR}/libev.pc.in > ${WRKDIR}/libev.pc
post-install:
- @${INSTALL_DATA} ${WRKDIR}/libev.pc ${STAGEDIR}${PKGCONFIGDIR}/
+ ${INSTALL_DATA} ${WRKDIR}/libev.pc ${STAGEDIR}${PKGCONFIGDIR}/
.include <bsd.port.mk>
diff --git a/devel/libev/distinfo b/devel/libev/distinfo
index 075714a0a554..89ea50c99456 100644
--- a/devel/libev/distinfo
+++ b/devel/libev/distinfo
@@ -1,2 +1,2 @@
-SHA256 (libev-4.15.tar.gz) = b2dd43a073556f5350cbed05b6ef444dcc4b563f4e0b1009d7bf448261606feb
-SIZE (libev-4.15.tar.gz) = 513919
+SHA256 (libev-4.20.tar.gz) = f870334c7fa961e7f31087c7d76abf849f596e3048f8ed2a0aaa983cd73d449e
+SIZE (libev-4.20.tar.gz) = 530091
diff --git a/devel/libev/files/patch-ev.c b/devel/libev/files/patch-ev.c
index cf554c717d5c..7e2ddde60bc1 100644
--- a/devel/libev/files/patch-ev.c
+++ b/devel/libev/files/patch-ev.c
@@ -1,26 +1,11 @@
---- ./ev.c.orig 2011-02-09 00:17:37.000000000 +0100
-+++ ./ev.c 2011-08-19 17:01:35.000000000 +0200
-@@ -967,8 +967,8 @@
- #define ecb_unreachable() __builtin_unreachable ()
- #else
- /* this seems to work fine, but gcc always emits a warning for it :/ */
-- ecb_inline void ecb_unreachable (void) ecb_noreturn;
-- ecb_inline void ecb_unreachable (void) { }
-+ ecb_inline ecb_noreturn void ecb_unreachable (void);
-+ ecb_inline ecb_noreturn void ecb_unreachable (void) { }
- #endif
-
- /* try to tell the compiler that some condition is definitely true */
-@@ -2443,10 +2443,12 @@
+--- ev.c.orig 2015-07-13 11:32:52 UTC
++++ ev.c
+@@ -2603,7 +2603,7 @@ ev_recommended_backends (void) EV_THROW
+ {
unsigned int flags = ev_supported_backends ();
- #ifndef __NetBSD__
-+#ifndef __FreeBSD__
+-#ifndef __NetBSD__
++#if !defined(__NetBSD__) && !defined(__FreeBSD__)
/* kqueue is borked on everything but netbsd apparently */
/* it usually doesn't work correctly on anything but sockets and pipes */
flags &= ~EVBACKEND_KQUEUE;
- #endif
-+#endif
- #ifdef __APPLE__
- /* only select works correctly on that "unix-certified" platform */
- flags &= ~EVBACKEND_KQUEUE; /* horribly broken, even for sockets */