aboutsummaryrefslogtreecommitdiff
path: root/devel/libexecinfo
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2017-09-22 10:48:45 +0000
committerMathieu Arnold <mat@FreeBSD.org>2017-09-22 10:48:45 +0000
commitb71796d585770ba247cf80126abc37abf7e80c7f (patch)
tree68c05507318cc11cd26946d1c2ac6e6521ddc45e /devel/libexecinfo
parent3fcd0e41ded1b4e3f014c63e00cf2ee71fa39ad5 (diff)
Notes
Diffstat (limited to 'devel/libexecinfo')
-rw-r--r--devel/libexecinfo/Makefile30
-rw-r--r--devel/libexecinfo/distinfo2
-rw-r--r--devel/libexecinfo/files/patch-Makefile10
-rw-r--r--devel/libexecinfo/files/patch-execinfo.c64
-rw-r--r--devel/libexecinfo/pkg-descr6
-rw-r--r--devel/libexecinfo/pkg-plist4
6 files changed, 0 insertions, 116 deletions
diff --git a/devel/libexecinfo/Makefile b/devel/libexecinfo/Makefile
deleted file mode 100644
index 64d06b620934..000000000000
--- a/devel/libexecinfo/Makefile
+++ /dev/null
@@ -1,30 +0,0 @@
-# Created by: Maxim Sobolev <sobomax@FreeBSD.org>
-# $FreeBSD$
-
-PORTNAME= libexecinfo
-PORTVERSION= 1.1
-PORTREVISION= 3
-CATEGORIES= devel
-MASTER_SITES= LOCAL/itetcu
-
-MAINTAINER= ports@FreeBSD.org
-COMMENT= Library for inspecting program's backtrace
-
-LICENSE= BSD2CLAUSE
-
-USES= tar:bzip2 uidfix
-USE_LDCONFIG= yes
-MAKE_FLAGS= LIBDIR=${PREFIX}/lib \
- INCLUDEDIR=${PREFIX}/include
-
-CFLAGS+= -fno-omit-frame-pointer
-
-PORTDOCS= README
-
-OPTIONS_DEFINE= DOCS
-
-post-install-DOCS-on:
- @${MKDIR} ${STAGEDIR}${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}
-
-.include <bsd.port.mk>
diff --git a/devel/libexecinfo/distinfo b/devel/libexecinfo/distinfo
deleted file mode 100644
index c5be96404cde..000000000000
--- a/devel/libexecinfo/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (libexecinfo-1.1.tar.bz2) = c9a21913e7fdac8ef6b33250b167aa1fc0a7b8a175145e26913a4c19d8a59b1f
-SIZE (libexecinfo-1.1.tar.bz2) = 4841
diff --git a/devel/libexecinfo/files/patch-Makefile b/devel/libexecinfo/files/patch-Makefile
deleted file mode 100644
index 79e7d86e39eb..000000000000
--- a/devel/libexecinfo/files/patch-Makefile
+++ /dev/null
@@ -1,10 +0,0 @@
---- Makefile.orig 2004-07-19 05:19:55 UTC
-+++ Makefile
-@@ -34,6 +34,7 @@ SHLIB_MAJOR= 1
- SHLIB_MINOR= 0
-
- NOPROFILE= yes
-+NO_PROFILE= yes
-
- DPADD= ${LIBM}
- LDADD= -lm
diff --git a/devel/libexecinfo/files/patch-execinfo.c b/devel/libexecinfo/files/patch-execinfo.c
deleted file mode 100644
index 367da87546d8..000000000000
--- a/devel/libexecinfo/files/patch-execinfo.c
+++ /dev/null
@@ -1,64 +0,0 @@
---- execinfo.c.orig 2004-07-19 05:21:09 UTC
-+++ execinfo.c
-@@ -69,7 +69,8 @@ backtrace(void **buffer, int size)
- char **
- backtrace_symbols(void *const *buffer, int size)
- {
-- int i, clen, alen, offset;
-+ size_t clen, alen;
-+ int i, offset;
- char **rval;
- char *cp;
- Dl_info info;
-@@ -78,7 +79,6 @@ backtrace_symbols(void *const *buffer, i
- rval = malloc(clen);
- if (rval == NULL)
- return NULL;
-- (char **)cp = &(rval[size]);
- for (i = 0; i < size; i++) {
- if (dladdr(buffer[i], &info) != 0) {
- if (info.dli_sname == NULL)
-@@ -92,14 +92,14 @@ backtrace_symbols(void *const *buffer, i
- 2 + /* " <" */
- strlen(info.dli_sname) + /* "function" */
- 1 + /* "+" */
-- D10(offset) + /* "offset */
-+ 10 + /* "offset */
- 5 + /* "> at " */
- strlen(info.dli_fname) + /* "filename" */
- 1; /* "\0" */
- rval = realloc_safe(rval, clen + alen);
- if (rval == NULL)
- return NULL;
-- snprintf(cp, alen, "%p <%s+%d> at %s",
-+ snprintf((char *) rval + clen, alen, "%p <%s+%d> at %s",
- buffer[i], info.dli_sname, offset, info.dli_fname);
- } else {
- alen = 2 + /* "0x" */
-@@ -108,12 +108,15 @@ backtrace_symbols(void *const *buffer, i
- rval = realloc_safe(rval, clen + alen);
- if (rval == NULL)
- return NULL;
-- snprintf(cp, alen, "%p", buffer[i]);
-+ snprintf((char *) rval + clen, alen, "%p", buffer[i]);
- }
-- rval[i] = cp;
-- cp += alen;
-+ rval[i] = (char *) clen;
-+ clen += alen;
- }
-
-+ for (i = 0; i < size; i++)
-+ rval[i] += (long) rval;
-+
- return rval;
- }
-
-@@ -155,6 +158,6 @@ backtrace_symbols_fd(void *const *buffer
- return;
- snprintf(buf, len, "%p\n", buffer[i]);
- }
-- write(fd, buf, len - 1);
-+ write(fd, buf, strlen(buf));
- }
- }
diff --git a/devel/libexecinfo/pkg-descr b/devel/libexecinfo/pkg-descr
deleted file mode 100644
index ff5b94b5e983..000000000000
--- a/devel/libexecinfo/pkg-descr
+++ /dev/null
@@ -1,6 +0,0 @@
-This is a quick-n-dirty BSD licensed clone of backtrace facility found
-in the GNU libc, mainly intended for porting Linuxish code to BSD
-platforms, however it can be used at any platform which has a gcc
-compiler.
-
-WWW: http://www.gnu.org/software/libc/manual/html_node/Backtraces.html
diff --git a/devel/libexecinfo/pkg-plist b/devel/libexecinfo/pkg-plist
deleted file mode 100644
index a98da8db420b..000000000000
--- a/devel/libexecinfo/pkg-plist
+++ /dev/null
@@ -1,4 +0,0 @@
-include/execinfo.h
-lib/libexecinfo.a
-lib/libexecinfo.so
-lib/libexecinfo.so.1