aboutsummaryrefslogtreecommitdiff
path: root/devel/libffi
diff options
context:
space:
mode:
authorKubilay Kocak <koobs@FreeBSD.org>2013-03-03 10:27:00 +0000
committerKubilay Kocak <koobs@FreeBSD.org>2013-03-03 10:27:00 +0000
commit4d8d32166f373a83f2548e0d70e1561eb21ee624 (patch)
tree9e81df06b2398e3e824626beffb96ca02e2f04fc /devel/libffi
parent86e8ef21c66523644e7917f20aad733ed376ebcb (diff)
Notes
Diffstat (limited to 'devel/libffi')
-rw-r--r--devel/libffi/Makefile20
-rw-r--r--devel/libffi/distinfo4
-rw-r--r--devel/libffi/files/patch-configure11
-rw-r--r--devel/libffi/files/patch-src__powerpc_ffi.c14
4 files changed, 12 insertions, 37 deletions
diff --git a/devel/libffi/Makefile b/devel/libffi/Makefile
index ab47437c860f..cd4542d886d6 100644
--- a/devel/libffi/Makefile
+++ b/devel/libffi/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= libffi
-PORTVERSION= 3.0.11
+PORTVERSION= 3.0.12
CATEGORIES= devel
MASTER_SITES= SOURCEWARE
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -10,13 +10,15 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
COMMENT= Foreign Function Interface
-OPTIONS_DEFINE= TEST
-TEST_DESC= Run regression test suite
+TEST_DEPENDS= runtest:${PORTSDIR}/misc/dejagnu
+
+OPTIONS_DEFINE= TESTS
+TESTS_DESC= Include tools for test suite
.include <bsd.port.options.mk>
-.if ${PORT_OPTIONS:MTEST}
-BUILD_DEPENDS+= runtest:${PORTSDIR}/misc/dejagnu
+.if ${PORT_OPTIONS:MTESTS}
+BUILD_DEPENDS:= ${TEST_DEPENDS}
.endif
GNU_CONFIGURE= yes
@@ -29,15 +31,13 @@ INFO= libffi
MAN3= ffi.3 ffi_call.3 ffi_prep_cif.3 ffi_prep_cif_var.3
-.if ${PORT_OPTIONS:MTEST}
-post-build:
- @cd ${WRKSRC} && ${MAKE} check
-.endif
-
post-install:
@${LN} -sf ../lib/libffi-${PORTVERSION}/include/ffi.h \
${PREFIX}/include/
@${LN} -sf ../lib/libffi-${PORTVERSION}/include/ffitarget.h \
${PREFIX}/include/
+regression-test: build
+ @cd ${WRKSRC} && ${MAKE} check
+
.include <bsd.port.mk>
diff --git a/devel/libffi/distinfo b/devel/libffi/distinfo
index 30133f808cee..bb5334368b4d 100644
--- a/devel/libffi/distinfo
+++ b/devel/libffi/distinfo
@@ -1,2 +1,2 @@
-SHA256 (libffi-3.0.11.tar.gz) = 70bfb01356360089aa97d3e71e3edf05d195599fd822e922e50d46a0055a6283
-SIZE (libffi-3.0.11.tar.gz) = 794220
+SHA256 (libffi-3.0.12.tar.gz) = 2ea0db90c2bbcc907c3aefc3f76e9dfc3b35c7a0fb75a4319f5248e0172c1e9e
+SIZE (libffi-3.0.12.tar.gz) = 844641
diff --git a/devel/libffi/files/patch-configure b/devel/libffi/files/patch-configure
deleted file mode 100644
index 9ef83c9e31c8..000000000000
--- a/devel/libffi/files/patch-configure
+++ /dev/null
@@ -1,11 +0,0 @@
---- configure.orig 2013-01-11 13:46:23.000000000 -0500
-+++ configure 2013-01-11 13:46:50.000000000 -0500
-@@ -14254,7 +14254,7 @@
-
- libffi_cv_as_x86_pcrel=yes
- echo '.text; foo: nop; .data; .long foo-.; .text' > conftest.s
-- if $CC $CFLAGS -c conftest.s 2>&1 | $EGREP -i 'illegal|warning' > /dev/null; then
-+ if $CC -c conftest.s 2>&1 | $EGREP -i 'illegal|warning' > /dev/null; then
- libffi_cv_as_x86_pcrel=no
- fi
-
diff --git a/devel/libffi/files/patch-src__powerpc_ffi.c b/devel/libffi/files/patch-src__powerpc_ffi.c
deleted file mode 100644
index 1838cd58a9ca..000000000000
--- a/devel/libffi/files/patch-src__powerpc_ffi.c
+++ /dev/null
@@ -1,14 +0,0 @@
---- src/powerpc/ffi.c.orig 2013-02-02 17:22:50.000000000 +0100
-+++ src/powerpc/ffi.c 2013-02-02 15:30:37.000000000 +0100
-@@ -664,9 +664,11 @@
- switch (type)
- {
- #ifndef __NO_FPRS__
-+#if FFI_TYPE_LONGDOUBLE != FFI_TYPE_DOUBLE
- case FFI_TYPE_LONGDOUBLE:
- flags |= FLAG_RETURNS_128BITS;
- /* Fall through. */
-+#endif
- case FFI_TYPE_DOUBLE:
- flags |= FLAG_RETURNS_64BITS;
- /* Fall through. */