aboutsummaryrefslogtreecommitdiff
path: root/devel/libffi
diff options
context:
space:
mode:
authorJung-uk Kim <jkim@FreeBSD.org>2013-01-29 00:35:32 +0000
committerJung-uk Kim <jkim@FreeBSD.org>2013-01-29 00:35:32 +0000
commit57945c1ebe6536db7611966ed98053e993ae98b9 (patch)
tree1237d87fa7c34f19bb431060ef80850ad8b99c8b /devel/libffi
parentf93276336223c226017fc35c5fd60b3bd8009495 (diff)
downloadports-57945c1ebe6536db7611966ed98053e993ae98b9.tar.gz
ports-57945c1ebe6536db7611966ed98053e993ae98b9.zip
Notes
Diffstat (limited to 'devel/libffi')
-rw-r--r--devel/libffi/Makefile32
-rw-r--r--devel/libffi/distinfo4
-rw-r--r--devel/libffi/files/patch-configure20
-rw-r--r--devel/libffi/files/patch-src_arm_sysv.S73
-rw-r--r--devel/libffi/pkg-plist2
5 files changed, 30 insertions, 101 deletions
diff --git a/devel/libffi/Makefile b/devel/libffi/Makefile
index 0df6d579f8db..87baf15943ad 100644
--- a/devel/libffi/Makefile
+++ b/devel/libffi/Makefile
@@ -1,26 +1,38 @@
-# New ports collection makefile for: libffi
-# Date created: 14, June, 1998
-# Whom: Horance Chou <horance@freedom.ie.cycu.edu.tw>
-#
+# Created by: Horance Chou <horance@freedom.ie.cycu.edu.tw>
# $FreeBSD$
-#
PORTNAME= libffi
-PORTVERSION= 3.0.9
+PORTVERSION= 3.0.11
CATEGORIES= devel
-MASTER_SITES= ftp://sourceware.org/pub/libffi/
+MASTER_SITES= ftp://sourceware.org/pub/libffi/ \
+ http://www.mirrorservice.org/sites/sourceware.org/pub/libffi/
-MAINTAINER= bkoenig@alpha-tierchen.de
+MAINTAINER= ports@FreeBSD.org
COMMENT= Foreign Function Interface
+OPTIONS_DEFINE= TEST
+TEST_DESC= Run regression test suite
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MTEST}
+BUILD_DEPENDS= runtest:${PORTSDIR}/misc/dejagnu
+.endif
+
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
-USE_GNOME= gnomehack pkgconfig
+USE_GNOME= gnomehack
+USE_PKGCONFIG= build
PLIST_SUB= PORTVERSION=${PORTVERSION}
INFO= libffi
-MAN3= ffi.3 ffi_call.3 ffi_prep_cif.3
+MAN3= ffi.3 ffi_call.3 ffi_prep_cif.3 ffi_prep_cif_var.3
+
+.if ${PORT_OPTIONS:MTEST}
+post-build:
+ @cd ${WRKSRC} && ${GMAKE} check
+.endif
post-install:
@${LN} -sf ../lib/libffi-${PORTVERSION}/include/ffi.h ${PREFIX}/include/
diff --git a/devel/libffi/distinfo b/devel/libffi/distinfo
index fbc191518a26..30133f808cee 100644
--- a/devel/libffi/distinfo
+++ b/devel/libffi/distinfo
@@ -1,2 +1,2 @@
-SHA256 (libffi-3.0.9.tar.gz) = 589d25152318bc780cd8919b14670793f4971d9838dab46ed38c32b3ee92c452
-SIZE (libffi-3.0.9.tar.gz) = 731719
+SHA256 (libffi-3.0.11.tar.gz) = 70bfb01356360089aa97d3e71e3edf05d195599fd822e922e50d46a0055a6283
+SIZE (libffi-3.0.11.tar.gz) = 794220
diff --git a/devel/libffi/files/patch-configure b/devel/libffi/files/patch-configure
index dffd4235e917..9ef83c9e31c8 100644
--- a/devel/libffi/files/patch-configure
+++ b/devel/libffi/files/patch-configure
@@ -1,21 +1,11 @@
---- configure.orig 2010-11-22 12:53:14.000000000 +0100
-+++ configure 2010-11-22 12:53:26.000000000 +0100
-@@ -12231,6 +12231,9 @@
- powerpc-*-freebsd*)
- TARGET=POWERPC_FREEBSD; TARGETDIR=powerpc
- ;;
-+ powerpc64-*-freebsd*)
-+ TARGET=POWERPC; TARGETDIR=powerpc
-+ ;;
- powerpc*-*-rtems*)
- TARGET=POWERPC; TARGETDIR=powerpc
- ;;
-@@ -14484,7 +14487,7 @@
+--- configure.orig 2013-01-11 13:46:23.000000000 -0500
++++ configure 2013-01-11 13:46:50.000000000 -0500
+@@ -14254,7 +14254,7 @@
libffi_cv_as_x86_pcrel=yes
echo '.text; foo: nop; .data; .long foo-.; .text' > conftest.s
-- if $CC $CFLAGS -c conftest.s 2>&1 | grep -i warning > /dev/null; then
-+ if $CC -c conftest.s 2>&1 | grep -i warning > /dev/null; then
+- if $CC $CFLAGS -c conftest.s 2>&1 | $EGREP -i 'illegal|warning' > /dev/null; then
++ if $CC -c conftest.s 2>&1 | $EGREP -i 'illegal|warning' > /dev/null; then
libffi_cv_as_x86_pcrel=no
fi
diff --git a/devel/libffi/files/patch-src_arm_sysv.S b/devel/libffi/files/patch-src_arm_sysv.S
deleted file mode 100644
index ebdd6811715a..000000000000
--- a/devel/libffi/files/patch-src_arm_sysv.S
+++ /dev/null
@@ -1,73 +0,0 @@
---- src/arm/sysv.S.orig 2008-02-15 02:15:41.000000000 +0100
-+++ src/arm/sysv.S 2008-04-01 13:25:02.000000000 +0200
-@@ -83,14 +83,6 @@
- # define call_reg(x) mov lr, pc ; mov pc, x
- #endif
-
--/* Conditionally compile unwinder directives. */
--#ifdef __ARM_EABI__
--#define UNWIND
--#else
--#define UNWIND @
--#endif
--
--
- #if defined(__thumb__) && !defined(__THUMB_INTERWORK__)
- .macro ARM_FUNC_START name
- .text
-@@ -101,7 +93,6 @@
- bx pc
- nop
- .arm
-- UNWIND .fnstart
- /* A hook to tell gdb that we've switched to ARM mode. Also used to call
- directly from other local arm routines. */
- _L__\name:
-@@ -112,7 +103,6 @@
- .align 0
- .arm
- ENTRY(\name)
-- UNWIND .fnstart
- .endm
- #endif
-
-@@ -145,11 +135,8 @@
- ARM_FUNC_START ffi_call_SYSV
- @ Save registers
- stmfd sp!, {r0-r3, fp, lr}
-- UNWIND .save {r0-r3, fp, lr}
- mov fp, sp
-
-- UNWIND .setfp fp, sp
--
- @ Make room for all of the new args.
- sub sp, fp, r2
-
-@@ -219,7 +206,6 @@
- RETLDM "r0-r3,fp"
-
- .ffi_call_SYSV_end:
-- UNWIND .fnend
- .size CNAME(ffi_call_SYSV),.ffi_call_SYSV_end-CNAME(ffi_call_SYSV)
-
- /*
-@@ -231,12 +217,9 @@
- */
-
- ARM_FUNC_START ffi_closure_SYSV
-- UNWIND .pad #16
- add ip, sp, #16
- stmfd sp!, {ip, lr}
-- UNWIND .save {r0, lr}
- add r2, sp, #8
-- .pad #16
- sub sp, sp, #16
- str sp, [sp, #8]
- add r1, sp, #8
-@@ -291,6 +274,5 @@
- #endif
-
- .ffi_closure_SYSV_end:
-- UNWIND .fnend
- .size CNAME(ffi_closure_SYSV),.ffi_closure_SYSV_end-CNAME(ffi_closure_SYSV)
-
diff --git a/devel/libffi/pkg-plist b/devel/libffi/pkg-plist
index 73404b1c0920..03a26337d72f 100644
--- a/devel/libffi/pkg-plist
+++ b/devel/libffi/pkg-plist
@@ -5,7 +5,7 @@ lib/libffi-%%PORTVERSION%%/include/ffitarget.h
lib/libffi.a
lib/libffi.la
lib/libffi.so
-lib/libffi.so.5
+lib/libffi.so.6
libdata/pkgconfig/libffi.pc
@dirrm lib/libffi-%%PORTVERSION%%/include
@dirrm lib/libffi-%%PORTVERSION%%