aboutsummaryrefslogtreecommitdiff
path: root/devel/libformat/files/Makefile.lib
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-01-08 15:28:49 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-01-08 15:28:49 +0000
commit5fbb6a0053cd4d055e935f15fab87ccf9b7a3fed (patch)
tree913f5581a261cf4da463b6ea4804181de08d6e8f /devel/libformat/files/Makefile.lib
parent385201700b7e5ef62fec232b91724e9d5ac9fa73 (diff)
downloadports-5fbb6a0053cd4d055e935f15fab87ccf9b7a3fed.tar.gz
ports-5fbb6a0053cd4d055e935f15fab87ccf9b7a3fed.zip
Notes
Diffstat (limited to 'devel/libformat/files/Makefile.lib')
-rw-r--r--devel/libformat/files/Makefile.lib17
1 files changed, 17 insertions, 0 deletions
diff --git a/devel/libformat/files/Makefile.lib b/devel/libformat/files/Makefile.lib
new file mode 100644
index 000000000000..8a6d09693084
--- /dev/null
+++ b/devel/libformat/files/Makefile.lib
@@ -0,0 +1,17 @@
+PREFIX?= /usr/local
+SHLIB_VER?= 1
+
+LIB= format
+LIBDIR= ${PREFIX}/lib
+SHLIB_MAJOR= ${SHLIB_VER}
+SHLIB_MINOR= 0
+NOPROFILE= true
+NOOBJ= true
+
+INCS= format.h
+INCSDIR= ${PREFIX}/include
+INCDIR= ${INCSDIR} # for pre-bsd.incs.mk API
+
+SRCS= format.cpp
+
+.include <bsd.lib.mk>