aboutsummaryrefslogtreecommitdiff
path: root/devel/libformat
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-01-08 15:28:49 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-01-08 15:28:49 +0000
commit5fbb6a0053cd4d055e935f15fab87ccf9b7a3fed (patch)
tree913f5581a261cf4da463b6ea4804181de08d6e8f /devel/libformat
parent385201700b7e5ef62fec232b91724e9d5ac9fa73 (diff)
downloadports-5fbb6a0053cd4d055e935f15fab87ccf9b7a3fed.tar.gz
ports-5fbb6a0053cd4d055e935f15fab87ccf9b7a3fed.zip
Notes
Diffstat (limited to 'devel/libformat')
-rw-r--r--devel/libformat/Makefile18
-rw-r--r--devel/libformat/distinfo2
-rw-r--r--devel/libformat/files/Makefile.lib17
-rw-r--r--devel/libformat/files/patch-ltmain.sh15
-rw-r--r--devel/libformat/pkg-plist17
5 files changed, 31 insertions, 38 deletions
diff --git a/devel/libformat/Makefile b/devel/libformat/Makefile
index 78a75cb18196..7619fca4c69f 100644
--- a/devel/libformat/Makefile
+++ b/devel/libformat/Makefile
@@ -7,29 +7,21 @@
#
PORTNAME= libformat
-PORTVERSION= 0.1.7
-PORTREVISION= 1
+PORTVERSION= 1.1
CATEGORIES= devel
-MASTER_SITES= http://home.pages.at/kingleo/development/
-DISTNAME= Format-${PORTVERSION}
+MASTER_SITES= http://kingleo.pages.at/development/cpp/
+DISTNAME= ${PORTNAME:S/^lib//}-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= C++ library that supports printf style like format printing
-USE_REINPLACE= yes
-GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
+MAKEFILE= ${FILESDIR}/Makefile.lib
INSTALLS_SHLIB= yes
-MAN3= Format.3
-
-post-patch:
- @${REINPLACE_CMD} -e 's| install-data-local||g' ${WRKSRC}/doc/Makefile.in
-
post-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
-.for file in doc/Format.html doc/Format.txt src/testMakefile src/testformat.cpp
+.for file in ChangeLog README testformat.cpp
${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
.endfor
.endif
diff --git a/devel/libformat/distinfo b/devel/libformat/distinfo
index 367ed4b2efe9..2a2b031d1585 100644
--- a/devel/libformat/distinfo
+++ b/devel/libformat/distinfo
@@ -1 +1 @@
-MD5 (Format-0.1.7.tar.gz) = 935bc16964348cf3e38ec2ea7610582e
+MD5 (format-1.1.tar.gz) = d94b8ade7cbf7bae2dea044f7535f6b7
diff --git a/devel/libformat/files/Makefile.lib b/devel/libformat/files/Makefile.lib
new file mode 100644
index 000000000000..8a6d09693084
--- /dev/null
+++ b/devel/libformat/files/Makefile.lib
@@ -0,0 +1,17 @@
+PREFIX?= /usr/local
+SHLIB_VER?= 1
+
+LIB= format
+LIBDIR= ${PREFIX}/lib
+SHLIB_MAJOR= ${SHLIB_VER}
+SHLIB_MINOR= 0
+NOPROFILE= true
+NOOBJ= true
+
+INCS= format.h
+INCSDIR= ${PREFIX}/include
+INCDIR= ${INCSDIR} # for pre-bsd.incs.mk API
+
+SRCS= format.cpp
+
+.include <bsd.lib.mk>
diff --git a/devel/libformat/files/patch-ltmain.sh b/devel/libformat/files/patch-ltmain.sh
deleted file mode 100644
index 41c7024cd341..000000000000
--- a/devel/libformat/files/patch-ltmain.sh
+++ /dev/null
@@ -1,15 +0,0 @@
---- ltmain.sh.orig Thu Jan 10 04:26:41 2002
-+++ ltmain.sh Wed Apr 17 01:13:43 2002
-@@ -4247,10 +4247,12 @@
- fi
-
- # Install the pseudo-library for information purposes.
-+ if /usr/bin/false; then
- name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
- instname="$dir/$name"i
- $show "$install_prog $instname $destdir/$name"
- $run eval "$install_prog $instname $destdir/$name" || exit $?
-+ fi
-
- # Maybe install the static library, too.
- test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
diff --git a/devel/libformat/pkg-plist b/devel/libformat/pkg-plist
index 93e025416f5b..f252472f6c75 100644
--- a/devel/libformat/pkg-plist
+++ b/devel/libformat/pkg-plist
@@ -1,9 +1,8 @@
-include/Format.hh
-lib/libFormat.a
-lib/libFormat.so
-lib/libFormat.so.0
-%%PORTDOCS%%share/doc/libformat/Format.html
-%%PORTDOCS%%share/doc/libformat/Format.txt
-%%PORTDOCS%%share/doc/libformat/testMakefile
-%%PORTDOCS%%share/doc/libformat/testformat.cpp
-%%PORTDOCS%%@dirrm share/doc/libformat
+include/format.h
+lib/libformat.a
+lib/libformat.so
+lib/libformat.so.1
+%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/testformat.cpp
+%%PORTDOCS%%@dirrm %%DOCSDIR%%