aboutsummaryrefslogtreecommitdiff
path: root/devel/libfortuna
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2014-02-19 09:25:46 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2014-02-19 09:25:46 +0000
commitbb5a4c33575d685eeb1c434d1d2b5dd52492d32d (patch)
tree42592fddc0088664a0ddda790d906d56f67f02b1 /devel/libfortuna
parent6140644bbaeffbeae5d0a9c59b7fb52f83162359 (diff)
downloadports-bb5a4c33575d685eeb1c434d1d2b5dd52492d32d.tar.gz
ports-bb5a4c33575d685eeb1c434d1d2b5dd52492d32d.zip
Notes
Diffstat (limited to 'devel/libfortuna')
-rw-r--r--devel/libfortuna/Makefile1
-rw-r--r--devel/libfortuna/files/patch-Makefile33
2 files changed, 33 insertions, 1 deletions
diff --git a/devel/libfortuna/Makefile b/devel/libfortuna/Makefile
index ee71396ffa34..16b730540b4a 100644
--- a/devel/libfortuna/Makefile
+++ b/devel/libfortuna/Makefile
@@ -18,5 +18,4 @@ GH_ACCOUNT= waitman
GH_TAGNAME= ${GH_COMMIT}
GH_COMMIT= 4a52e16
-NO_STAGE= yes
.include <bsd.port.mk>
diff --git a/devel/libfortuna/files/patch-Makefile b/devel/libfortuna/files/patch-Makefile
new file mode 100644
index 000000000000..ba12f13198c7
--- /dev/null
+++ b/devel/libfortuna/files/patch-Makefile
@@ -0,0 +1,33 @@
+--- ./Makefile.orig 2014-02-19 10:24:15.411792348 +0100
++++ ./Makefile 2014-02-19 10:25:09.252791282 +0100
+@@ -18,18 +18,18 @@
+ rm -f *.so
+
+ install:
+- mkdir $(PREFIX)/include/fortuna
+- $(INSTALL) -m 644 ./src/fortuna.h $(PREFIX)/include/fortuna/
+- $(INSTALL) -m 644 ./src/px.h $(PREFIX)/include/fortuna/
+- $(INSTALL) -m 644 ./src/rijndael.h $(PREFIX)/include/fortuna/
+- $(INSTALL) -m 644 ./src/sha2.h $(PREFIX)/include/fortuna/
+- $(INSTALL) -m 644 ./src/c.h $(PREFIX)/include/fortuna/
+- $(INSTALL) -m 644 ./src/blf.h $(PREFIX)/include/fortuna/
+- $(INSTALL) -m 644 ./src/sha1.h $(PREFIX)/include/fortuna/
+- $(INSTALL) -m 644 ./src/internal.h $(PREFIX)/include/fortuna/
+- $(INSTALL) -m 644 ./src/md5.h $(PREFIX)/include/fortuna/
+- $(INSTALL) -m 644 ./libfortuna.a $(PREFIX)/lib/
+- $(INSTALL) -m 644 ./libfortuna.so $(PREFIX)/lib/
++ mkdir $(DESTDIR)$(PREFIX)/include/fortuna
++ $(INSTALL) -m 644 ./src/fortuna.h $(DESTDIR)$(PREFIX)/include/fortuna/
++ $(INSTALL) -m 644 ./src/px.h $(DESTDIR)$(PREFIX)/include/fortuna/
++ $(INSTALL) -m 644 ./src/rijndael.h $(DESTDIR)$(PREFIX)/include/fortuna/
++ $(INSTALL) -m 644 ./src/sha2.h $(DESTDIR)$(PREFIX)/include/fortuna/
++ $(INSTALL) -m 644 ./src/c.h $(DESTDIR)$(PREFIX)/include/fortuna/
++ $(INSTALL) -m 644 ./src/blf.h $(DESTDIR)$(PREFIX)/include/fortuna/
++ $(INSTALL) -m 644 ./src/sha1.h $(DESTDIR)$(PREFIX)/include/fortuna/
++ $(INSTALL) -m 644 ./src/internal.h $(DESTDIR)$(PREFIX)/include/fortuna/
++ $(INSTALL) -m 644 ./src/md5.h $(DESTDIR)$(PREFIX)/include/fortuna/
++ $(INSTALL) -m 644 ./libfortuna.a $(DESTDIR)$(PREFIX)/lib/
++ $(INSTALL) -m 644 ./libfortuna.so $(DESTDIR)$(PREFIX)/lib/
+
+ deinstall:
+ rm -Rf $(PREFIX)/include/fortuna