aboutsummaryrefslogtreecommitdiff
path: root/devel/libftdi1/Makefile
diff options
context:
space:
mode:
authorBoris Samorodov <bsam@FreeBSD.org>2018-01-16 15:22:46 +0000
committerBoris Samorodov <bsam@FreeBSD.org>2018-01-16 15:22:46 +0000
commit5eded73d915c08b37aef907a5c2425adb51b485b (patch)
tree938a2eeffa73010d4554ddb0237050b8849a0674 /devel/libftdi1/Makefile
parent401b918bb2535921d922f12a432765ac3bade889 (diff)
downloadports-5eded73d915c08b37aef907a5c2425adb51b485b.tar.gz
ports-5eded73d915c08b37aef907a5c2425adb51b485b.zip
Notes
Diffstat (limited to 'devel/libftdi1/Makefile')
-rw-r--r--devel/libftdi1/Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/devel/libftdi1/Makefile b/devel/libftdi1/Makefile
index 83addbff0c7d..e67847569a8a 100644
--- a/devel/libftdi1/Makefile
+++ b/devel/libftdi1/Makefile
@@ -2,7 +2,7 @@
PORTNAME= libftdi1
PORTVERSION= 1.4
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= devel
MASTER_SITES= http://www.intra2net.com/en/developer/libftdi/download/
@@ -30,7 +30,8 @@ PORTDOCS= COPYING.LIB ChangeLog README
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MDOCS}
-CMAKE_ARGS+= -DDOCUMENTATION:BOOL=true
+CMAKE_ARGS+= -DDOCUMENTATION:BOOL=true \
+ -DPYTHON_BINDINGS:BOOL=false
.else
CMAKE_ARGS+= -DDOCUMENTATION:BOOL=false
.endif
@@ -43,7 +44,8 @@ CMAKE_ARGS+= -DEXAMPLES:BOOL=false
.if ${PORT_OPTIONS:MPYTHON}
USES+= python:2
-CMAKE_ARGS+= -DPYTHON_BINDINGS:BOOL=true
+CMAKE_ARGS+= -DPYTHON_BINDINGS:BOOL=true \
+ -DDOCUMENTATION:BOOL=false
BUILD_DEPENDS+= swig3.0:devel/swig30
BINARY_ALIAS= swig=swig3.0
.else