aboutsummaryrefslogtreecommitdiff
path: root/devel/libgii/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-12-06 21:34:48 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-12-06 21:34:48 +0000
commit7906e6c255d4434479ef7fab8ddedd8112fc162a (patch)
treeb24571071d70fea8fccdc0f555a82a1db9e4da72 /devel/libgii/Makefile
parent85f12eb3ab5789a1b829e58def588be33c4cf508 (diff)
downloadports-7906e6c255d4434479ef7fab8ddedd8112fc162a.tar.gz
ports-7906e6c255d4434479ef7fab8ddedd8112fc162a.zip
Notes
Diffstat (limited to 'devel/libgii/Makefile')
-rw-r--r--devel/libgii/Makefile30
1 files changed, 17 insertions, 13 deletions
diff --git a/devel/libgii/Makefile b/devel/libgii/Makefile
index 697010fed107..07a254eb78ec 100644
--- a/devel/libgii/Makefile
+++ b/devel/libgii/Makefile
@@ -6,9 +6,9 @@
#
PORTNAME= libgii
-PORTVERSION= 0.8.5
+PORTVERSION= 0.9.0
CATEGORIES= devel
-MASTER_SITES= ftp://ftp.ggi-project.org/pub/packages/ggi/ggi/v2.0/ \
+MASTER_SITES= http://www.ggi-project.org/ftp/ggi/v2.1/ \
${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ggi
DISTNAME= ${PORTNAME}-${PORTVERSION}.src
@@ -19,7 +19,6 @@ COMMENT= GGI API for input sources
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
USE_BZIP2= yes
USE_XLIB= yes
-USE_REINPLACE= yes
INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
@@ -30,9 +29,11 @@ PLIST_SUB+= KII=""
PLIST_SUB+= KII="@comment "
.endif
-MAN1= mhub.1
-MAN3= ggGetSwarType.3 ggGetUserDir.3 ggInit.3 \
- ggLockCreate.3 ggRegisterCleanup.3 giiEventPoll.3 \
+MAN1= mhub.1 xsendbut.1
+MAN3= ggAddTask.3 ggCurTime.3 \
+ ggGetSwarType.3 ggGetUserDir.3 ggInit.3 ggLoadModule.3 \
+ ggLockCreate.3 ggRegisterCleanup.3 ggstrlcpy.3 \
+ gg-error.3 gg-types.3 giiEventPoll.3 \
giiEventSend.3 giiInit.3 giiMTInit.3 \
giiOpen.3 giiPanic.3 giiQueryDeviceInfo.3 \
giiQueryValInfo.3 giiSetEventMask.3 gii_cmd_event.3 \
@@ -44,10 +45,17 @@ MAN7= filter-key.7 filter-mouse.7 filter-save.7 filter-tcp.7 \
input-directx.7 input-file.7 input-linux-evdev.7 \
input-linux-kbd.7 input-linux-mouse.7 input-lk201.7 \
input-mouse.7 input-tcp.7 libgg.7 libgii.7
-MLINKS= ggRegisterCleanup.3 ggCleanupForceExit.3 \
- - ggUnregisterCleanup.3 ggInit.3 ggExit.3 \
+MLINKS= ggAddTask.3 ggDelTask.3 - ggTimeBase.3 \
+ - GG_SCHED_TICKS2USECS.3 - GG_SCHED_USECS2TICKS.3 \
+ ggRegisterCleanup.3 ggCleanupForceExit.3 \
+ - ggUnregisterCleanup.3 \
+ ggCurTime.3 ggUSleep.3 - ggUSlumber.3 \
+ ggInit.3 ggExit.3 \
+ ggLoadModule.3 ggFreeModule.3 - ggGetSymbolAddress.3 \
ggLockCreate.3 ggLock.3 - ggLockDestroy.3 \
- ggTryLock.3 - ggUnlock.3 \
+ gg-error.3 ggi-error.3 - gii-error.3 \
+ ggstrlcpy.3 ggstrlcat.3 \
giiSetEventMask.3 giiAddEventMask.3 - giiGetEventMask.3 \
giiOpen.3 giiClose.3 - giiJoinInputs.3 - giiSplitInputs.3 \
giiEventPoll.3 giiEventRead.3 - giiEventSelect.3 \
@@ -60,8 +68,7 @@ MLINKS= ggRegisterCleanup.3 ggCleanupForceExit.3 \
gii_cmddata_getvalinfo.3 gii_phystype.3 - gii_valrange.3 \
filter-key.7 filter-keytrans.7
DOCSDIR= share/doc/libgii
-DOCS= ChangeLog NEWS README \
- doc/env.txt doc/inputs.txt
+DOCS= ChangeLog NEWS README
EXAMPLESDIR= share/examples/libgii
EXAMPLES= demos/demo.c demos/filter.c \
demos/mhub.c demos/xsendbut.c
@@ -75,9 +82,6 @@ PLIST_SUB+= VGL="@comment "
PLIST_SUB+= VGL=""
.endif
-post-configure:
- @${REINPLACE_CMD} -e 's/\(deplibs\) -lc/\1/;' ${WRKSRC}/libtool
-
post-install:
@${CP} ${WRKSRC}/libgii.conf ${PREFIX}/etc/ggi/libgii.conf.dist
@${CP} ${WRKSRC}/filter/mouse/mouse ${PREFIX}/etc/ggi/filter/mouse.dist