aboutsummaryrefslogtreecommitdiff
path: root/devel/libgit2/Makefile
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2011-05-27 09:45:29 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2011-05-27 09:45:29 +0000
commit100c9520c0b77b7f2d3aecb4812cbe6111ceda8e (patch)
treec10883c55f3ae5b2836250e1fcd820c3edfafcbb /devel/libgit2/Makefile
parentbd91313e45fd34e0f5581ad437e7dbb7d82fee85 (diff)
downloadports-100c9520c0b77b7f2d3aecb4812cbe6111ceda8e.tar.gz
ports-100c9520c0b77b7f2d3aecb4812cbe6111ceda8e.zip
Notes
Diffstat (limited to 'devel/libgit2/Makefile')
-rw-r--r--devel/libgit2/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/devel/libgit2/Makefile b/devel/libgit2/Makefile
new file mode 100644
index 000000000000..a075fe0513d5
--- /dev/null
+++ b/devel/libgit2/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: libgit2
+# Date created: 2011-05-27
+# Whom: Baptiste Daroussin <bapt@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libgit2
+PORTVERSION= 0.12.0
+CATEGORIES= devel
+MASTER_SITES= http://cloud.github.com/downloads/libgit2/libgit2/
+
+MAINTAINER= bapt@FreeBSD.org
+COMMENT= Portable, pure C implementation of the Git core
+
+LICENSE= GPLv2
+
+USE_PYTHON_BUILD= yes
+USE_LDCONFIG= yes
+
+WAF_ARGS= --sha1=builtin
+
+MAKE_JOBS_SAFE= yes
+
+post-configure:
+ @${REINPLACE_CMD} -e 's|LIBDIR}/pkgconfig|PREFIX}/libdata/pkgconfig|' ${WRKSRC}/wscript
+
+do-configure:
+ @cd ${WRKSRC}; ${CONFIGURE_ENV} ./waf configure ${WAF_ARGS}
+
+do-build:
+ @cd ${WRKSRC}; ${MAKE_ENV} ./waf build -j ${MAKE_JOBS_NUMBER}
+
+do-install:
+ @cd ${WRKSRC}; ${MAKE_ENV} ./waf install
+
+.include <bsd.port.mk>