aboutsummaryrefslogtreecommitdiff
path: root/devel/libgit2/Makefile
diff options
context:
space:
mode:
authorWilliam Grzybowski <wg@FreeBSD.org>2014-06-27 16:34:48 +0000
committerWilliam Grzybowski <wg@FreeBSD.org>2014-06-27 16:34:48 +0000
commitc7d0139944f3374d9e4cd4873c8ec0a7b2ba4ed1 (patch)
tree26b1a9112e2756cceffad48f7855430c3f4c1bde /devel/libgit2/Makefile
parentb4e6bff10db88b9084a39dcd908c35de3d4b4942 (diff)
downloadports-c7d0139944f3374d9e4cd4873c8ec0a7b2ba4ed1.tar.gz
ports-c7d0139944f3374d9e4cd4873c8ec0a7b2ba4ed1.zip
Notes
Diffstat (limited to 'devel/libgit2/Makefile')
-rw-r--r--devel/libgit2/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/devel/libgit2/Makefile b/devel/libgit2/Makefile
index a499cfd12d7b..0c24793dc483 100644
--- a/devel/libgit2/Makefile
+++ b/devel/libgit2/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= libgit2
-PORTVERSION= 0.20.0
-PORTREVISION= 1
+PORTVERSION= 0.21.0
CATEGORIES= devel
MAINTAINER= wg@FreeBSD.org
@@ -13,14 +12,15 @@ LICENSE= GPLv2
USE_GITHUB= yes
GH_ACCOUNT= libgit2
GH_TAGNAME= v${PORTVERSION}
-GH_COMMIT= 43cb8b3
+GH_COMMIT= 28f087c
USES= cmake
USE_LDCONFIG= yes
USE_PYTHON_BUILD= yes
USE_OPENSSL= yes
-PLIST_SUB= SHLIB_VER=${PORTVERSION}
+PLIST_SUB= SHLIB_VER1=${PORTVERSION} \
+ SHLIB_VER2=${PORTVERSION:R:E}
OPTIONS_DEFINE= SSH
OPTIONS_DEFAULT=SSH