aboutsummaryrefslogtreecommitdiff
path: root/devel/libglade2/Makefile
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2003-02-07 18:42:25 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2003-02-07 18:42:25 +0000
commit336b31c3940aea29270fc9fd9b51d3ba1633729e (patch)
treeab986f61fb6fef3625ba83cee9ea5d304243bfe8 /devel/libglade2/Makefile
parentd02465ee5bd1e47c51b942f66a4c99d7dc742601 (diff)
Notes
Diffstat (limited to 'devel/libglade2/Makefile')
-rw-r--r--devel/libglade2/Makefile9
1 files changed, 4 insertions, 5 deletions
diff --git a/devel/libglade2/Makefile b/devel/libglade2/Makefile
index 98deb4a32749..c606d5b68bcb 100644
--- a/devel/libglade2/Makefile
+++ b/devel/libglade2/Makefile
@@ -7,6 +7,7 @@
PORTNAME= libglade2
PORTVERSION= 2.0.1
+PORTREVISION= 1
CATEGORIES= devel gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME:S/2$//}/2.0
@@ -17,7 +18,7 @@ MAINTAINER= gnome@FreeBSD.org
BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/pyexpat.so:${PORTSDIR}/textproc/py-expat
LIB_DEPENDS= xml2.5:${PORTSDIR}/textproc/libxml2 \
- gtk-x11-2.0.0:${PORTSDIR}/x11-toolkits/gtk20
+ gtk-x11-2.0.200:${PORTSDIR}/x11-toolkits/gtk20
RUN_DEPENDS= ${PYTHON_SITELIBDIR}/pyexpat.so:${PORTSDIR}/textproc/py-expat
USE_BZIP2= yes
@@ -26,13 +27,11 @@ USE_REINPLACE= yes
USE_GMAKE= yes
USE_PYTHON= yes
USE_LIBTOOL= yes
+USE_GNOMENG= yes
+USE_GNOME= gnomehack
INSTALLS_SHLIB= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
-pre-patch:
- @find ${WRKSRC} -name Makefile.in | xargs ${REINPLACE_CMD} -e \
- 's|[(]libdir[)]/pkgconfig|(prefix)/libdata/pkgconfig|g'
-
.include <bsd.port.mk>