aboutsummaryrefslogtreecommitdiff
path: root/devel/libglade2
diff options
context:
space:
mode:
authorAlexander Nedotsukov <bland@FreeBSD.org>2004-12-17 08:06:29 +0000
committerAlexander Nedotsukov <bland@FreeBSD.org>2004-12-17 08:06:29 +0000
commit499b2c98feb0a8fc881e4f5b25d72405d0e307db (patch)
tree680e33fd8b3465aac4351dea49d53943c9859331 /devel/libglade2
parent78e849d0cd5bf33ac18baf4d47b938811dbd9aed (diff)
downloadports-499b2c98feb0a8fc881e4f5b25d72405d0e307db.tar.gz
ports-499b2c98feb0a8fc881e4f5b25d72405d0e307db.zip
Notes
Diffstat (limited to 'devel/libglade2')
-rw-r--r--devel/libglade2/Makefile22
-rw-r--r--devel/libglade2/pkg-plist2
2 files changed, 18 insertions, 6 deletions
diff --git a/devel/libglade2/Makefile b/devel/libglade2/Makefile
index 197a137fe79d..25811537cb60 100644
--- a/devel/libglade2/Makefile
+++ b/devel/libglade2/Makefile
@@ -7,6 +7,7 @@
PORTNAME= libglade2
PORTVERSION= 2.4.1
+PORTREVISION= 1
CATEGORIES= devel gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME:S/2$//}/2.4
@@ -16,15 +17,11 @@ DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
COMMENT= GNOME glade library
-BUILD_DEPENDS= ${PYEXPAT}
-RUN_DEPENDS= ${PYEXPAT} \
- xmlcatmgr:${PORTSDIR}/textproc/xmlcatmgr
+RUN_DEPENDS= xmlcatmgr:${PORTSDIR}/textproc/xmlcatmgr
USE_BZIP2= yes
USE_X_PREFIX= yes
-USE_REINPLACE= yes
USE_GMAKE= yes
-USE_PYTHON= yes
USE_LIBTOOL_VER=15
USE_GNOME= gnomehack libxml2 gtk20
INSTALLS_SHLIB= yes
@@ -37,4 +34,19 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
PLIST_SUB= XMLCATALOG="${LOCALBASE}/bin/xmlcatalog" \
CATALOG_PORTS_XML="${LOCALBASE}/share/xml/catalog.ports"
+.if !defined(WITHOUT_PYTHON)
+BUILD_DEPENDS+= ${PYEXPAT}
+RUN_DEPENDS+= ${PYEXPAT}
+
+USE_PYTHON= yes
+PLIST_SUB+= PYTHON=""
+.else
+USE_REINPLACE= yes
+PLIST_SUB+= PYTHON="@comment "
+
+post-patch:
+ @${REINPLACE_CMD} -E 's/in (python.*)+ none/in none/' \
+ ${WRKSRC}/configure
+.endif
+
.include <bsd.port.mk>
diff --git a/devel/libglade2/pkg-plist b/devel/libglade2/pkg-plist
index cba156fe6624..588f41a86546 100644
--- a/devel/libglade2/pkg-plist
+++ b/devel/libglade2/pkg-plist
@@ -1,4 +1,4 @@
-bin/libglade-convert
+%%PYTHON%%bin/libglade-convert
include/libglade-2.0/glade/glade-build.h
include/libglade-2.0/glade/glade-init.h
include/libglade-2.0/glade/glade-parser.h