aboutsummaryrefslogtreecommitdiff
path: root/devel/libglademm
diff options
context:
space:
mode:
authorAlexander Nedotsukov <bland@FreeBSD.org>2005-10-13 05:38:06 +0000
committerAlexander Nedotsukov <bland@FreeBSD.org>2005-10-13 05:38:06 +0000
commitfeac2a1be7737dde55630d91d520c6e9019d0099 (patch)
treefda35a4eec977e4883079f0344ddbf9b4f4157cd /devel/libglademm
parent5d6782e8fe2dff275b4bf2a26eb667fa84585c0f (diff)
downloadports-feac2a1be7737dde55630d91d520c6e9019d0099.tar.gz
ports-feac2a1be7737dde55630d91d520c6e9019d0099.zip
Notes
Diffstat (limited to 'devel/libglademm')
-rw-r--r--devel/libglademm/Makefile5
-rw-r--r--devel/libglademm/distinfo4
-rw-r--r--devel/libglademm/files/patch-configure10
-rw-r--r--devel/libglademm/files/patch-libglade__libglademm__xml.h11
4 files changed, 15 insertions, 15 deletions
diff --git a/devel/libglademm/Makefile b/devel/libglademm/Makefile
index 809055038f67..a791fb38b43f 100644
--- a/devel/libglademm/Makefile
+++ b/devel/libglademm/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= libglademm
-PORTVERSION= 2.1.2
-PORTREVISION= 4
+PORTVERSION= 2.1.3
CATEGORIES= devel gnome
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= gtkmm
@@ -22,7 +21,7 @@ BUILD_DEPENDS= gm4:${PORTSDIR}/devel/m4
USE_X_PREFIX= yes
USE_GMAKE= yes
USE_GNOME= gnomehack libglade2
-USE_INC_LIBTOOL_VER= 13
+USE_LIBTOOL_VER= 15
INSTALLS_SHLIB= yes
CONFIGURE_ARGS= --enable-static
diff --git a/devel/libglademm/distinfo b/devel/libglademm/distinfo
index 2cdb0dead21a..8aa9edff3b0d 100644
--- a/devel/libglademm/distinfo
+++ b/devel/libglademm/distinfo
@@ -1,2 +1,2 @@
-MD5 (gnome2/libglademm-2.1.2.tar.gz) = 5f108b774fd5a583404c4fa067374ddd
-SIZE (gnome2/libglademm-2.1.2.tar.gz) = 335177
+MD5 (gnome2/libglademm-2.1.3.tar.gz) = 9f950bb0cdd410cb36d1d0c3e23eca6a
+SIZE (gnome2/libglademm-2.1.3.tar.gz) = 340596
diff --git a/devel/libglademm/files/patch-configure b/devel/libglademm/files/patch-configure
deleted file mode 100644
index 8c117297dcb6..000000000000
--- a/devel/libglademm/files/patch-configure
+++ /dev/null
@@ -1,10 +0,0 @@
---- configure.orig Wed May 21 15:52:43 2003
-+++ configure Wed May 21 15:53:07 2003
-@@ -7854,6 +7854,7 @@
-
- # This can be used to rebuild libtool when needed
- LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
-+$ac_aux_dir/ltconfig $LIBTOOL_DEPS
-
- # Always use our own libtool.
- LIBTOOL='$(SHELL) $(top_builddir)/libtool'
diff --git a/devel/libglademm/files/patch-libglade__libglademm__xml.h b/devel/libglademm/files/patch-libglade__libglademm__xml.h
new file mode 100644
index 000000000000..470271746be5
--- /dev/null
+++ b/devel/libglademm/files/patch-libglade__libglademm__xml.h
@@ -0,0 +1,11 @@
+--- libglade/libglademm/xml.h.orig Tue Oct 11 11:18:23 2005
++++ libglade/libglademm/xml.h Tue Oct 11 11:18:51 2005
+@@ -240,7 +240,7 @@
+ //If there is already a C++ instance, then return it again:
+ if(pObjectBase)
+ {
+- widget = dynamic_cast<T_Widget*>( Glib::wrap(pCWidget) );
++ widget = dynamic_cast<T_Widget*>( Glib::wrap((GtkWidget*)pCWidget) );
+
+ //The dynamic cast checks that it is of the correct type.
+ //Somebody might be trying to call get_widget_derived() after already calling get_widget(),