aboutsummaryrefslogtreecommitdiff
path: root/devel/libgsf-gnome
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-05-22 20:56:52 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-05-22 20:56:52 +0000
commit6b8fe3db6b25f7bcd01a20760cb167db1cbb4d2e (patch)
tree89ef1f1c6a4870e8316e08015ab4ee035b7f8ab2 /devel/libgsf-gnome
parentccac9ebe1b29570efcf236b4f38e6747a4587b1d (diff)
- Split libgsf port to two standalone ports:
* devel/libgsf is the old port minus gsf-gnome bits * devel/libgsf-gnome contains libgsf-gnome-1 library and it's header files This greatly reduces number of dependencies for ports that was using only non-gnome part of this library. - Point USE_GNOME parameter libgsf to GNOME-less port and create new parameter libgsf_gnome for libgsf-gnome port. - Convert all consumers of libgsf-gnome-1 library to depend on libgsf-gnome port (read all as: Gnumeric) PR: ports/63851 (in the spirit of) Submitted by: Sybolt de Boer <sybolt@xs4all.nl> Prodded by: lofi (KDE team) Reviewed by: marcus (GNOME team)
Notes
Notes: svn path=/head/; revision=109734
Diffstat (limited to 'devel/libgsf-gnome')
-rw-r--r--devel/libgsf-gnome/Makefile31
-rw-r--r--devel/libgsf-gnome/pkg-descr3
-rw-r--r--devel/libgsf-gnome/pkg-plist10
3 files changed, 44 insertions, 0 deletions
diff --git a/devel/libgsf-gnome/Makefile b/devel/libgsf-gnome/Makefile
new file mode 100644
index 000000000000..226e3d388364
--- /dev/null
+++ b/devel/libgsf-gnome/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: libgsf
+# Date created: 11 September 2002
+# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+CATEGORIES= devel gnome
+PKGNAMESUFFIX= -gnome
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= A GNOME wrapper for libgsf
+
+MASTERDIR= ${.CURDIR}/../libgsf
+DESCR= ${.CURDIR}/pkg-descr
+PLIST= ${.CURDIR}/pkg-plist
+
+USE_GNOME= gnomehack libgsf gnomevfs2
+CONFIGURE_ARGS= --with-html-dir=${PREFIX}/share/doc/gsf \
+ --disable-gtk-doc --with-bz2 --with-gnome
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib -lgsf-1"
+
+do-build:
+ @cd ${WRKSRC}/gsf-gnome && ${MAKE}
+
+do-install:
+ @cd ${WRKSRC}/gsf-gnome && ${MAKE} install
+ @${INSTALL_DATA} ${WRKSRC}/libgsf-gnome-1.pc ${PREFIX}/libdata/pkgconfig
+
+.include "${MASTERDIR}/Makefile"
diff --git a/devel/libgsf-gnome/pkg-descr b/devel/libgsf-gnome/pkg-descr
new file mode 100644
index 000000000000..0252aadf0f92
--- /dev/null
+++ b/devel/libgsf-gnome/pkg-descr
@@ -0,0 +1,3 @@
+The library is a bonobo and gnomevfs wrapper for libgsf, providing a high level
+API for GNOME applications to access and exchange various structured file
+formats.
diff --git a/devel/libgsf-gnome/pkg-plist b/devel/libgsf-gnome/pkg-plist
new file mode 100644
index 000000000000..a51dfcc8744e
--- /dev/null
+++ b/devel/libgsf-gnome/pkg-plist
@@ -0,0 +1,10 @@
+include/libgsf-1/gsf-gnome/gsf-input-bonobo.h
+include/libgsf-1/gsf-gnome/gsf-input-gnomevfs.h
+include/libgsf-1/gsf-gnome/gsf-output-bonobo.h
+include/libgsf-1/gsf-gnome/gsf-output-gnomevfs.h
+include/libgsf-1/gsf-gnome/gsf-shared-bonobo-stream.h
+lib/libgsf-gnome-1.a
+lib/libgsf-gnome-1.so
+lib/libgsf-gnome-1.so.10
+libdata/pkgconfig/libgsf-gnome-1.pc
+@dirrm include/libgsf-1/gsf-gnome