aboutsummaryrefslogtreecommitdiff
path: root/devel/libgsf/Makefile
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2002-09-11 12:12:58 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2002-09-11 12:12:58 +0000
commit945e7059e8faddcd4b4ab472351bb1d492be6cc0 (patch)
tree23db267ede4f8850726e89e6687c4f7b7c89b610 /devel/libgsf/Makefile
parentdc7ea47235e4b28cc5dcb9e3da6181e3e5e83304 (diff)
Notes
Diffstat (limited to 'devel/libgsf/Makefile')
-rw-r--r--devel/libgsf/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/devel/libgsf/Makefile b/devel/libgsf/Makefile
new file mode 100644
index 000000000000..d19054d11488
--- /dev/null
+++ b/devel/libgsf/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: libgsf
+# Date created: 11 September 2002
+# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libgsf
+PORTVERSION= 1.3.0
+CATEGORIES= devel gnome
+MASTER_SITES= ${MASTER_SITE_GNOME}
+MASTER_SITE_SUBDIR= unstable/sources/${PORTNAME}
+DIST_SUBDIR= gnome2
+
+MAINTAINER= gnome@FreeBSD.org
+
+LIB_DEPENDS= bonobo-2.0:${PORTSDIR}/devel/libbonobo \
+ gnomevfs-2.0:${PORTSDIR}/devel/gnomevfs2
+
+USE_BZIP2= yes
+USE_GMAKE= yes
+INSTALLS_SHLIB= yes
+USE_GNOMENG= yes
+USE_GNOME= gnomehack
+USE_LIBTOOL= yes
+CONFIGURE_ARGS= --with-html-dir=${PREFIX}/share/doc \
+ --disable-gtk-doc --with-gnome
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
+
+.include <bsd.port.mk>