aboutsummaryrefslogtreecommitdiff
path: root/devel/libgtop/Makefile
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2002-07-12 13:59:45 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2002-07-12 13:59:45 +0000
commit7ef405a20834f9ccb7962a07959afc156be3c4c6 (patch)
tree86f5e631531932eca0922d4d717f6217dc131010 /devel/libgtop/Makefile
parent0dd8f257e325529095bdc4272b0ca6d63aad7946 (diff)
downloadports-7ef405a20834f9ccb7962a07959afc156be3c4c6.tar.gz
ports-7ef405a20834f9ccb7962a07959afc156be3c4c6.zip
Notes
Diffstat (limited to 'devel/libgtop/Makefile')
-rw-r--r--devel/libgtop/Makefile13
1 files changed, 6 insertions, 7 deletions
diff --git a/devel/libgtop/Makefile b/devel/libgtop/Makefile
index 4d2c32798b85..3c21eb2860fa 100644
--- a/devel/libgtop/Makefile
+++ b/devel/libgtop/Makefile
@@ -17,18 +17,17 @@ LIB_DEPENDS= guile.10:${PORTSDIR}/lang/guile
USE_PERL5= yes
USE_GMAKE= yes
-USE_GNOMELIBS= yes
+USE_REINPLACE= yes
+USE_GNOMENG= yes
+USE_GNOME= gnomelibs
INSTALLS_SHLIB= yes
-GNU_CONFIGURE= yes
+USE_LIBTOOL= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
-pre-patch:
- @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
+post-patch:
+ @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
- @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
- 's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
- s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
post-install:
install-info --section="Programming \& development tools" \