aboutsummaryrefslogtreecommitdiff
path: root/devel/libgtop
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2014-11-19 11:49:04 +0000
committerKoop Mast <kwm@FreeBSD.org>2014-11-19 11:49:04 +0000
commitaf3811313c14afb06fe2d1f6158e3e431bbfc2b6 (patch)
tree1ad98a4e8faecd0e2fa9ac2c18e65da4cf89c236 /devel/libgtop
parentc7d4d6bd7ef6ff4955eab2863a5c6e2feb14b839 (diff)
Notes
Diffstat (limited to 'devel/libgtop')
-rw-r--r--devel/libgtop/Makefile12
-rw-r--r--devel/libgtop/distinfo4
-rw-r--r--devel/libgtop/files/patch-configure37
-rw-r--r--devel/libgtop/files/patch-libgtop-sysdeps.m412
-rw-r--r--devel/libgtop/files/patch-src_daemon_server.c17
-rw-r--r--devel/libgtop/files/patch-sysdeps_freebsd_netload.c136
-rw-r--r--devel/libgtop/files/patch-sysdeps_freebsd_open.c14
-rw-r--r--devel/libgtop/pkg-plist17
8 files changed, 113 insertions, 136 deletions
diff --git a/devel/libgtop/Makefile b/devel/libgtop/Makefile
index 28ef42d65a34..58d6abffc700 100644
--- a/devel/libgtop/Makefile
+++ b/devel/libgtop/Makefile
@@ -1,10 +1,10 @@
# Created by: Joe Marcus Clarke <marcus@FreeBSD.org>
# $FreeBSD$
-# $MCom: ports/trunk/devel/libgtop/Makefile 18610 2013-06-30 16:33:05Z marcus $
+# $MCom: ports/trunk/devel/libgtop/Makefile 19959 2014-10-15 14:06:28Z kwm $
PORTNAME= libgtop
-PORTVERSION= 2.28.4
-PORTREVISION= 3
+PORTVERSION= 2.30.0
+PORTREVISION= 2
CATEGORIES= devel gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
@@ -15,13 +15,13 @@ COMMENT= GNOME 2 top library
USE_PERL5= build
USE_XORG= xau
USES= gettext gmake libtool pathfix perl5 pkgconfig tar:xz
-USE_GNOME= gnomeprefix glib20 intlhack
+USE_GNOME= gnomeprefix glib20 intlhack introspection:build
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include -DHAVE_NET_IF_VAR_H -D_WANT_IFADDR
-LDFLAGS+= -L${LOCALBASE}/lib
+LDFLAGS+= -L${LOCALBASE}/lib -lutil
INSTALL_TARGET= install-strip
-CONFIGURE_ARGS= --disable-introspection
+CONFIGURE_ARGS= --enable-introspection
INFO= libgtop2
diff --git a/devel/libgtop/distinfo b/devel/libgtop/distinfo
index 96dc6955eeb1..ac73cba277ff 100644
--- a/devel/libgtop/distinfo
+++ b/devel/libgtop/distinfo
@@ -1,2 +1,2 @@
-SHA256 (gnome2/libgtop-2.28.4.tar.xz) = b6619cfd1540267ee81d456d1a26c72c793261586f1b00a7b9a7a229d0abe1d8
-SIZE (gnome2/libgtop-2.28.4.tar.xz) = 653940
+SHA256 (gnome2/libgtop-2.30.0.tar.xz) = 463bcbe5737b1b93f3345ee34abf601e8eb864f507c49ff1921c2737abafc1e5
+SIZE (gnome2/libgtop-2.30.0.tar.xz) = 664476
diff --git a/devel/libgtop/files/patch-configure b/devel/libgtop/files/patch-configure
index 5c7cb8a2a8a6..7ff8677ab4a2 100644
--- a/devel/libgtop/files/patch-configure
+++ b/devel/libgtop/files/patch-configure
@@ -1,10 +1,10 @@
---- configure.orig 2011-03-30 10:06:27.000000000 +0200
-+++ configure 2011-03-30 10:07:52.000000000 +0200
-@@ -13230,6 +13230,78 @@
- if test -n "${osreldate}" && test ${osreldate} -ge 600000 ; then
- EXTRA_SYSDEPS_LIBS="-lgeom -ldevstat"
- fi
-+ { echo "$as_me:$LINENO: checking for kinfo_getfile in -lutil" >&5
+--- configure.orig 2014-04-29 10:12:29.633996234 +0000
++++ configure 2014-04-29 10:14:19.976988652 +0000
+@@ -13638,6 +13638,79 @@
+
+ done
+
++ { echo "$as_me:$LINENO: checking for kinfo_getfile in -lutil" >&5
+echo $ECHO_N "checking for kinfo_getfile in -lutil... $ECHO_C" >&6; }
+if test "${ac_cv_lib_util_kinfo_getfile+set}" = set; then
+ echo $ECHO_N "(cached) $ECHO_C" >&6
@@ -47,35 +47,36 @@
+ cat conftest.err >&5
+ echo "$as_me:$LINENO: \$? = $ac_status" >&5
+ (exit $ac_status); } && {
-+ test -z "$ac_c_werror_flag" ||
-+ test ! -s conftest.err
++ test -z "$ac_c_werror_flag" ||
++ test ! -s conftest.err
+ } && test -s conftest$ac_exeext &&
-+ $as_test_x conftest$ac_exeext; then
++ $as_test_x conftest$ac_exeext; then
+ ac_cv_lib_util_kinfo_getfile=yes
+else
+ echo "$as_me: failed program was:" >&5
+sed 's/^/| /' conftest.$ac_ext >&5
+
-+ ac_cv_lib_util_kinfo_getfile=no
++ ac_cv_lib_util_kinfo_getfile=no
+fi
-+
++
+rm -f core conftest.err conftest.$ac_objext conftest_ipa8_conftest.oo \
-+ conftest$ac_exeext conftest.$ac_ext
++ conftest$ac_exeext conftest.$ac_ext
+LIBS=$ac_check_lib_save_LIBS
+fi
+{ echo "$as_me:$LINENO: result: $ac_cv_lib_util_kinfo_getfile" >&5
+echo "${ECHO_T}$ac_cv_lib_util_kinfo_getfile" >&6; }
+if test $ac_cv_lib_util_kinfo_getfile = yes; then
+ EXTRA_SYSDEPS_LIBS="${EXTRA_SYSDEPS_LIBS} -lutil"
-+
++
+cat >>confdefs.h <<\_ACEOF
+#define HAVE_KINFO_GETFILE 1
+_ACEOF
-+
++
+else
+ :
+fi
+
- ;;
- esac
-
++
+ { $as_echo "$as_me:${as_lineno-$LINENO}: checking for I4B" >&5
+ $as_echo_n "checking for I4B... " >&6; }
+ cat confdefs.h - <<_ACEOF >conftest.$ac_ext
diff --git a/devel/libgtop/files/patch-libgtop-sysdeps.m4 b/devel/libgtop/files/patch-libgtop-sysdeps.m4
deleted file mode 100644
index 1805da02a85d..000000000000
--- a/devel/libgtop/files/patch-libgtop-sysdeps.m4
+++ /dev/null
@@ -1,12 +0,0 @@
---- libgtop-sysdeps.m4.orig 2008-04-21 14:58:38.000000000 -0400
-+++ libgtop-sysdeps.m4 2008-12-06 16:16:00.000000000 -0500
-@@ -158,6 +160,9 @@ AC_DEFUN([GNOME_LIBGTOP_SYSDEPS],[
- if test -n "${osreldate}" && test ${osreldate} -ge 600000 ; then
- EXTRA_SYSDEPS_LIBS="-lgeom -ldevstat"
- fi
-+ AC_CHECK_LIB(util, kinfo_getfile,
-+ [EXTRA_SYSDEPS_LIBS="${EXTRA_SYSDEPS_LIBS} -lutil"
-+ AC_DEFINE(HAVE_KINFO_GETFILE, 1, [Define if you have the kinfo_getfile function])], [:])
- ;;
- esac
-
diff --git a/devel/libgtop/files/patch-src_daemon_server.c b/devel/libgtop/files/patch-src_daemon_server.c
deleted file mode 100644
index bf0bba5c7f21..000000000000
--- a/devel/libgtop/files/patch-src_daemon_server.c
+++ /dev/null
@@ -1,17 +0,0 @@
---- src/daemon/server.c.orig Mon Feb 17 15:22:19 2003
-+++ src/daemon/server.c Mon Feb 17 15:23:31 2003
-@@ -88,11 +88,12 @@
- if (strcmp (uts.sysname, LIBGTOP_COMPILE_SYSTEM) ||
- strcmp (uts.release, LIBGTOP_COMPILE_RELEASE) ||
- strcmp (uts.machine, LIBGTOP_COMPILE_MACHINE)) {
-- fprintf (stderr, "Can only run on %s %s %s\n",
-+ fprintf (stderr, "This libgtop was compiled on %s %s %s\n",
- LIBGTOP_COMPILE_SYSTEM,
- LIBGTOP_COMPILE_RELEASE,
- LIBGTOP_COMPILE_MACHINE);
-- _exit (1);
-+ fprintf (stderr, "If you see strange problems caused by it,\n");
-+ fprintf (stderr, "you should recompile libgtop and dependent applications\n");
- }
- #endif
-
diff --git a/devel/libgtop/files/patch-sysdeps_freebsd_netload.c b/devel/libgtop/files/patch-sysdeps_freebsd_netload.c
index b5c1e17e9a06..19d810866615 100644
--- a/devel/libgtop/files/patch-sysdeps_freebsd_netload.c
+++ b/devel/libgtop/files/patch-sysdeps_freebsd_netload.c
@@ -1,18 +1,24 @@
---- sysdeps/freebsd/netload.c.orig 2011-06-01 15:40:47 UTC
-+++ sysdeps/freebsd/netload.c
-@@ -1,6 +1,8 @@
+--- sysdeps/freebsd/netload.c.orig 2014-10-02 18:05:51.932132157 +0200
++++ sysdeps/freebsd/netload.c 2014-10-02 18:06:23.435130545 +0200
+@@ -1,7 +1,8 @@
-/* Copyright (C) 1998-99 Martin Baulig
+/* Copyright (C) 2014 Gleb Smirnoff
+ Copyright (C) 1998-99 Martin Baulig
This file is part of LibGTop 1.0.
+- Contributed by Martin Baulig <martin@home-of-linux.org>, October 1998.
+ Contributed by Gleb Smirnoff <glebius@FreeBSD.org>, September 2014.
- Contributed by Martin Baulig <martin@home-of-linux.org>, October 1998.
LibGTop is free software; you can redistribute it and/or modify it
-@@ -31,17 +33,11 @@
- #include <sys/types.h>
- #include <sys/socket.h>
+ under the terms of the GNU General Public License as published by
+@@ -26,22 +27,12 @@
+
+ #include <glibtop_suid.h>
+
+-#include <string.h>
+-
+-#include <sys/types.h>
+-#include <sys/socket.h>
#include <sys/ioctl.h>
-
+#include <sys/sockio.h>
@@ -31,7 +37,7 @@
static const unsigned long _glibtop_sysdeps_netload =
(1L << GLIBTOP_NETLOAD_IF_FLAGS) +
-@@ -64,24 +60,9 @@
+@@ -64,24 +55,9 @@
(1L << GLIBTOP_NETLOAD_ADDRESS6) +
(1L << GLIBTOP_NETLOAD_SCOPE6);
@@ -56,7 +62,7 @@
server->sysdeps.netload = _glibtop_sysdeps_netload;
}
-@@ -91,164 +72,129 @@
+@@ -91,164 +67,129 @@
glibtop_get_netload_p (glibtop *server, glibtop_netload *buf,
const char *interface)
{
@@ -69,7 +75,7 @@
- struct ifaddr ifa;
- struct in_ifaddr in;
- } ifaddr;
-+ static struct ifaddrs *ifap, *ifa;
++ struct ifaddrs *ifap, *ifa;
glibtop_init_p (server, (1L << GLIBTOP_SYSDEPS_NETLOAD), 0);
@@ -102,13 +108,17 @@
- "kvm_read (ifnetaddr)");
- continue;
- }
--
++#define IFA_STAT(s) (((struct if_data *)ifa->ifa_data)->ifi_ ## s)
+
- g_strlcpy (name, ifnet.if_xname, sizeof(name));
- ifnetaddr = (u_long) ifnet.if_link.tqe_next;
--
++ for (ifa = ifap; ifa; ifa = ifa->ifa_next) {
+
- if (strcmp (name, interface) != 0)
- continue;
--
++ if (strcmp(ifa->ifa_name, interface) != 0)
++ continue;
+
- ifaddraddr = (u_long) ifnet.if_addrhead.tqh_first;
- }
- if (ifnet.if_flags & IFF_UP)
@@ -155,38 +165,35 @@
- buf->packets_in = ifnet.if_ipackets;
- buf->packets_out = ifnet.if_opackets;
- buf->packets_total = buf->packets_in + buf->packets_out;
-+#define IFA_STAT(s) (((struct if_data *)ifa->ifa_data)->ifi_ ## s)
-
+-
- buf->bytes_in = ifnet.if_ibytes;
- buf->bytes_out = ifnet.if_obytes;
- buf->bytes_total = buf->bytes_in + buf->bytes_out;
-+ for (ifa = ifap; ifa; ifa = ifa->ifa_next) {
-
+-
- buf->errors_in = ifnet.if_ierrors;
- buf->errors_out = ifnet.if_oerrors;
- buf->errors_total = buf->errors_in + buf->errors_out;
-+ if (strcmp(ifa->ifa_name, interface) != 0)
-+ continue;
-
+-
- buf->collisions = ifnet.if_collisions;
- buf->flags = _glibtop_sysdeps_netload;
-+ switch (ifa->ifa_addr->sa_family) {
-+ case AF_LINK: {
-+ struct sockaddr_dl *sdl;
-+ struct ifreq ifr;
-+ int s, flags;
-
+-
- while (ifaddraddr) {
- if ((kvm_read (server->machine.kd, ifaddraddr, &ifaddr,
- sizeof (ifaddr)) != sizeof (ifaddr))) {
- glibtop_warn_io_r (server,
- "kvm_read (ifaddraddr)");
- continue;
++ switch (ifa->ifa_addr->sa_family) {
++ case AF_LINK: {
++ struct sockaddr_dl *sdl;
++ struct ifreq ifr;
++ int s, flags;
++
+ s = socket(AF_INET, SOCK_DGRAM, 0);
+ if (s < 0) {
+ glibtop_warn_io_r(server, "socket(AF_INET)");
+ break;
- }
++ }
+ memset(&ifr, 0, sizeof(ifr));
+ (void )strlcpy(ifr.ifr_name, ifa->ifa_name,
+ sizeof(ifr.ifr_name));
@@ -195,16 +202,9 @@
+ "ioctl(SIOCGIFFLAGS)");
+ close(s);
+ break;
-+ }
+ }
+ close(s);
-
--#define CP(x) ((char *)(x))
-- cp = (CP(ifaddr.ifa.ifa_addr) - CP(ifaddraddr)) +
-- CP(&ifaddr);
-- sa = (struct sockaddr *)cp;
--
-- if (sa->sa_family == AF_LINK) {
-- struct sockaddr_dl *dl = (struct sockaddr_dl *) sa;
++
+ flags = (ifr.ifr_flags & 0xffff) |
+ (ifr.ifr_flagshigh << 16);
+
@@ -250,35 +250,18 @@
+ buf->errors_total = buf->errors_in + buf->errors_out;
+ buf->collisions = IFA_STAT(collisions);
+ buf->flags = _glibtop_sysdeps_netload;
-
-- memcpy (buf->hwaddress, LLADDR (dl),
-- sizeof (buf->hwaddress));
-- buf->flags |= GLIBTOP_NETLOAD_HWADDRESS;
-- } else if (sa->sa_family == AF_INET) {
-- sin = (struct sockaddr_in *)sa;
-- /* Commenting out to "fix" #13345. */
-- buf->subnet = htonl (ifaddr.in.ia_subnet);
-- buf->address = sin->sin_addr.s_addr;
-- buf->mtu = ifnet.if_mtu;
++
+ sdl = (struct sockaddr_dl *)ifa->ifa_addr;
+ memcpy(buf->hwaddress, LLADDR(sdl),
+ sizeof(buf->hwaddress));
+ buf->mtu = IFA_STAT(mtu);
-+ buf->flags |= (1L << GLIBTOP_NETLOAD_HWADDRESS);
-
-- buf->flags |= _glibtop_sysdeps_netload_data;
-- } else if (sa->sa_family == AF_INET6) {
-- struct sockaddr_in6 *sin6 = (struct sockaddr_in6 *) sa;
-- int in6fd;
++ buf->flags |= GLIBTOP_NETLOAD_HWADDRESS;
++
+ break;
+ }
+ case AF_INET: {
+ struct sockaddr_in *sin;
-
-- memcpy (buf->address6, &sin6->sin6_addr,
-- sizeof (buf->address6));
-- buf->scope6 = (guint8) sin6->sin6_scope_id;
-- buf->flags |= _glibtop_sysdeps_netload6;
++
+ sin = (struct sockaddr_in *)ifa->ifa_addr;
+ buf->address = sin->sin_addr.s_addr;
+ sin = (struct sockaddr_in *)ifa->ifa_netmask;
@@ -288,10 +271,7 @@
+ }
+ case AF_INET6: {
+ struct sockaddr_in6 *sin6;
-
-- in6fd = socket (AF_INET6, SOCK_DGRAM, 0);
-- if (in6fd >= 0) {
-- struct in6_ifreq ifr;
++
+ sin6 = (struct sockaddr_in6 *)ifa->ifa_addr;
+ memcpy(buf->address6, &sin6->sin6_addr,
+ sizeof(buf->address6));
@@ -300,12 +280,44 @@
+ sin6 = (struct sockaddr_in6 *)ifa->ifa_netmask;
+ memcpy(buf->prefix6, &sin6->sin6_addr,
+ sizeof(buf->prefix6));
-+ buf->flags |= (1L << GLIBTOP_NETLOAD_PREFIX6);
++ buf->flags |= GLIBTOP_NETLOAD_PREFIX6;
+ break;
+ }
+ }
+ }
+-#define CP(x) ((char *)(x))
+- cp = (CP(ifaddr.ifa.ifa_addr) - CP(ifaddraddr)) +
+- CP(&ifaddr);
+- sa = (struct sockaddr *)cp;
+-
+- if (sa->sa_family == AF_LINK) {
+- struct sockaddr_dl *dl = (struct sockaddr_dl *) sa;
+-
+- memcpy (buf->hwaddress, LLADDR (dl),
+- sizeof (buf->hwaddress));
+- buf->flags |= GLIBTOP_NETLOAD_HWADDRESS;
+- } else if (sa->sa_family == AF_INET) {
+- sin = (struct sockaddr_in *)sa;
+- /* Commenting out to "fix" #13345. */
+- buf->subnet = htonl (ifaddr.in.ia_subnet);
+- buf->address = sin->sin_addr.s_addr;
+- buf->mtu = ifnet.if_mtu;
+-
+- buf->flags |= _glibtop_sysdeps_netload_data;
+- } else if (sa->sa_family == AF_INET6) {
+- struct sockaddr_in6 *sin6 = (struct sockaddr_in6 *) sa;
+- int in6fd;
+-
+- memcpy (buf->address6, &sin6->sin6_addr,
+- sizeof (buf->address6));
+- buf->scope6 = (guint8) sin6->sin6_scope_id;
+- buf->flags |= _glibtop_sysdeps_netload6;
+-
+- in6fd = socket (AF_INET6, SOCK_DGRAM, 0);
+- if (in6fd >= 0) {
+- struct in6_ifreq ifr;
+-
- memset (&ifr, 0, sizeof (ifr));
- ifr.ifr_addr = *sin6;
- g_strlcpy (ifr.ifr_name, interface,
diff --git a/devel/libgtop/files/patch-sysdeps_freebsd_open.c b/devel/libgtop/files/patch-sysdeps_freebsd_open.c
deleted file mode 100644
index 985caa1f4a2b..000000000000
--- a/devel/libgtop/files/patch-sysdeps_freebsd_open.c
+++ /dev/null
@@ -1,14 +0,0 @@
---- sysdeps/freebsd/open.c.orig 2011-07-24 15:13:56.000000000 -0400
-+++ sysdeps/freebsd/open.c 2011-12-28 16:26:48.000000000 -0500
-@@ -42,11 +42,5 @@ glibtop_open_s (glibtop *server, const c
- sysctlbyname ("hw.ncpu", &ncpus, &len, NULL, 0);
- server->real_ncpu = ncpus - 1;
- server->ncpu = MIN(GLIBTOP_NCPU - 1, server->real_ncpu);
--
--#if defined(__FreeBSD_kernel__)
-- server->os_version_code = __FreeBSD_kernel_version;
--#else
- server->os_version_code = __FreeBSD_version;
--#endif
--
- }
diff --git a/devel/libgtop/pkg-plist b/devel/libgtop/pkg-plist
index 456146d2bd9d..0e8e6d5c17fb 100644
--- a/devel/libgtop/pkg-plist
+++ b/devel/libgtop/pkg-plist
@@ -47,14 +47,16 @@ include/libgtop-2.0/glibtop_private.h
include/libgtop-2.0/glibtop_server.h
include/libgtop-2.0/glibtop_suid.h
include/libgtop-2.0/libgtopconfig.h
+lib/girepository-1.0/GTop-2.0.typelib
lib/libgtop-2.0.a
lib/libgtop-2.0.so
-lib/libgtop-2.0.so.7
-lib/libgtop-2.0.so.7.2.0
+lib/libgtop-2.0.so.10
+lib/libgtop-2.0.so.10.0.0
libdata/pkgconfig/libgtop-2.0.pc
%%DOCSDIR%%/home.png
%%DOCSDIR%%/index.html
%%DOCSDIR%%/index.sgml
+%%DOCSDIR%%/left-insensitive.png
%%DOCSDIR%%/left.png
%%DOCSDIR%%/libgtop-Close.html
%%DOCSDIR%%/libgtop-Command.html
@@ -63,6 +65,9 @@ libdata/pkgconfig/libgtop-2.0.pc
%%DOCSDIR%%/libgtop-Net-List.html
%%DOCSDIR%%/libgtop-Net-Load.html
%%DOCSDIR%%/libgtop-PPP.html
+%%DOCSDIR%%/libgtop-Process-Arguments.html
+%%DOCSDIR%%/libgtop-Process-List.html
+%%DOCSDIR%%/libgtop-Process-Time.html
%%DOCSDIR%%/libgtop-Shared-Memory-Limits.html
%%DOCSDIR%%/libgtop-Uptime.html
%%DOCSDIR%%/libgtop-cpu.html
@@ -74,16 +79,13 @@ libdata/pkgconfig/libgtop-2.0.pc
%%DOCSDIR%%/libgtop-msg-limits.html
%%DOCSDIR%%/libgtop-open.html
%%DOCSDIR%%/libgtop-parameter.html
-%%DOCSDIR%%/libgtop-procargs.html
%%DOCSDIR%%/libgtop-prockernel.html
-%%DOCSDIR%%/libgtop-proclist.html
%%DOCSDIR%%/libgtop-procmap.html
%%DOCSDIR%%/libgtop-procmem.html
%%DOCSDIR%%/libgtop-procopenfiles.html
%%DOCSDIR%%/libgtop-procsegment.html
%%DOCSDIR%%/libgtop-procsignal.html
%%DOCSDIR%%/libgtop-procstate.html
-%%DOCSDIR%%/libgtop-proctime.html
%%DOCSDIR%%/libgtop-procuid.html
%%DOCSDIR%%/libgtop-sem-limits.html
%%DOCSDIR%%/libgtop-signal.html
@@ -95,9 +97,12 @@ libdata/pkgconfig/libgtop-2.0.pc
%%DOCSDIR%%/libgtop-white-paper-overview.html
%%DOCSDIR%%/libgtop-white-paper.html
%%DOCSDIR%%/libgtop.devhelp2
+%%DOCSDIR%%/right-insensitive.png
%%DOCSDIR%%/right.png
%%DOCSDIR%%/style.css
+%%DOCSDIR%%/up-insensitive.png
%%DOCSDIR%%/up.png
+share/gir-1.0/GTop-2.0.gir
share/locale/am/LC_MESSAGES/libgtop-2.0.mo
share/locale/ar/LC_MESSAGES/libgtop-2.0.mo
share/locale/as/LC_MESSAGES/libgtop-2.0.mo
@@ -126,6 +131,7 @@ share/locale/eu/LC_MESSAGES/libgtop-2.0.mo
share/locale/fa/LC_MESSAGES/libgtop-2.0.mo
share/locale/fi/LC_MESSAGES/libgtop-2.0.mo
share/locale/fr/LC_MESSAGES/libgtop-2.0.mo
+share/locale/fur/LC_MESSAGES/libgtop-2.0.mo
share/locale/ga/LC_MESSAGES/libgtop-2.0.mo
share/locale/gl/LC_MESSAGES/libgtop-2.0.mo
share/locale/gu/LC_MESSAGES/libgtop-2.0.mo
@@ -173,6 +179,7 @@ share/locale/sr@latin/LC_MESSAGES/libgtop-2.0.mo
share/locale/sv/LC_MESSAGES/libgtop-2.0.mo
share/locale/ta/LC_MESSAGES/libgtop-2.0.mo
share/locale/te/LC_MESSAGES/libgtop-2.0.mo
+share/locale/tg/LC_MESSAGES/libgtop-2.0.mo
share/locale/th/LC_MESSAGES/libgtop-2.0.mo
share/locale/tr/LC_MESSAGES/libgtop-2.0.mo
share/locale/ug/LC_MESSAGES/libgtop-2.0.mo