aboutsummaryrefslogtreecommitdiff
path: root/devel/libhash
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2002-04-02 16:10:39 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2002-04-02 16:10:39 +0000
commit5c64df18873ae2b93072d590502eec4a2853a546 (patch)
tree664338b767273d72fbcae6297d2c245bdaa49b81 /devel/libhash
parent111d55e923b7e1647c97a1e77fa2e26782b1efb5 (diff)
downloadports-5c64df18873ae2b93072d590502eec4a2853a546.tar.gz
ports-5c64df18873ae2b93072d590502eec4a2853a546.zip
Notes
Diffstat (limited to 'devel/libhash')
-rw-r--r--devel/libhash/Makefile36
-rw-r--r--devel/libhash/distinfo1
-rw-r--r--devel/libhash/pkg-comment1
-rw-r--r--devel/libhash/pkg-descr6
-rw-r--r--devel/libhash/pkg-plist4
5 files changed, 48 insertions, 0 deletions
diff --git a/devel/libhash/Makefile b/devel/libhash/Makefile
new file mode 100644
index 000000000000..90d9b50fa954
--- /dev/null
+++ b/devel/libhash/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: libhash
+# Date created: 14 Jan 2002
+# Whom: Andrew <andrew@ugh.net.au>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libhash
+PORTVERSION= 1.0
+CATEGORIES= devel
+MASTER_SITES= ftp://ftp.ugh.net.au/pub/unix/libhash/
+
+MAINTAINER= andrew@ugh.net.au
+
+WRKSRC= ${WRKDIR}/libhash
+
+MAN3= libhash.3 libhash_convenience.3
+MANCOMPRESSED= maybe
+MLINKS= libhash.3 hash_initialise.3 \
+ libhash.3 hash_insert.3 \
+ libhash.3 hash_retrieve.3 \
+ libhash.3 hash_delete.3 \
+ libhash.3 hash_iterator_initialise.3 \
+ libhash.3 hash_fetch_next.3 \
+ libhash.3 hash_iterator_deinitialise.3 \
+ libhash.3 hash_deinitialise.3 \
+ libhash_convenience.3 hash_compare_int.3 \
+ libhash_convenience.3 hash_compare_string.3 \
+ libhash_convenience.3 hash_hash_int.3 \
+ libhash_convenience.3 hash_hash_string.3 \
+ libhash_convenience.3 hash_copy_int.3 \
+ libhash_convenience.3 hash_copy_string.3
+
+INSTALLS_SHLIB= yes
+
+.include <bsd.port.mk>
diff --git a/devel/libhash/distinfo b/devel/libhash/distinfo
new file mode 100644
index 000000000000..36734b616518
--- /dev/null
+++ b/devel/libhash/distinfo
@@ -0,0 +1 @@
+MD5 (libhash-1.0.tar.gz) = cab97ab5212847baedff9241c22be629
diff --git a/devel/libhash/pkg-comment b/devel/libhash/pkg-comment
new file mode 100644
index 000000000000..2a5d4679a411
--- /dev/null
+++ b/devel/libhash/pkg-comment
@@ -0,0 +1 @@
+A library for manipulating hash tables
diff --git a/devel/libhash/pkg-descr b/devel/libhash/pkg-descr
new file mode 100644
index 000000000000..8716d9db06ae
--- /dev/null
+++ b/devel/libhash/pkg-descr
@@ -0,0 +1,6 @@
+This C library provides functions for manipulating in memory hash tables (aka
+associative arrays). Data is stored as void *'s so any data structure can be
+stored.
+
+Andrew Stevenson
+andrew@ugh.net.au
diff --git a/devel/libhash/pkg-plist b/devel/libhash/pkg-plist
new file mode 100644
index 000000000000..d29cab85b3dc
--- /dev/null
+++ b/devel/libhash/pkg-plist
@@ -0,0 +1,4 @@
+include/hash.h
+lib/libhash.so.1
+lib/libhash.so
+lib/libhash.a