aboutsummaryrefslogtreecommitdiff
path: root/devel/libhid
diff options
context:
space:
mode:
authorLi-Wen Hsu <lwhsu@FreeBSD.org>2007-07-28 09:54:57 +0000
committerLi-Wen Hsu <lwhsu@FreeBSD.org>2007-07-28 09:54:57 +0000
commit258413e67c5894b809f04009d8f099a36d385015 (patch)
treeabb0fdef5128b7df7c06521c5b976f1be50413ce /devel/libhid
parent5eb74c627b2028c4f5799099a38ce6d6d444fa28 (diff)
downloadports-258413e67c5894b809f04009d8f099a36d385015.tar.gz
ports-258413e67c5894b809f04009d8f099a36d385015.zip
Notes
Diffstat (limited to 'devel/libhid')
-rw-r--r--devel/libhid/Makefile27
-rw-r--r--devel/libhid/distinfo3
-rw-r--r--devel/libhid/files/patch-Makefile.in11
-rw-r--r--devel/libhid/files/patch-hidparser-hidtypes.h11
-rw-r--r--devel/libhid/pkg-descr9
-rw-r--r--devel/libhid/pkg-plist9
6 files changed, 70 insertions, 0 deletions
diff --git a/devel/libhid/Makefile b/devel/libhid/Makefile
new file mode 100644
index 000000000000..4095536410bd
--- /dev/null
+++ b/devel/libhid/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: libhid
+# Date created: 16 July 2007
+# Whom: ntarmos@ceid.upatras.gr
+#
+# $FreeBSD$
+#
+
+PORTNAME= libhid
+PORTVERSION= 0.2.16
+CATEGORIES= devel
+MASTER_SITES= http://alioth.debian.org/frs/download.php/1958/
+
+MAINTAINER= ntarmos@ceid.upatras.gr
+COMMENT= A user-space HID access library written in C
+
+MAN1= libhid-detach-device.1
+MANCOMPRESSED= no
+USE_LDCONFIG= yes
+
+LIB_DEPENDS+= usb-0.1.8:${PORTSDIR}/devel/libusb
+BUILD_DEPENDS+= ${LOCALBASE}/bin/xsltproc:${PORTSDIR}/textproc/libxslt \
+ ${LOCALBASE}/share/xsl/docbook/html:${PORTSDIR}/textproc/docbook-xsl
+
+HAS_CONFIGURE= yes
+CONFIGURE_ARGS+= --mandir=${MANPREFIX}/man
+
+.include <bsd.port.mk>
diff --git a/devel/libhid/distinfo b/devel/libhid/distinfo
new file mode 100644
index 000000000000..ea747162f254
--- /dev/null
+++ b/devel/libhid/distinfo
@@ -0,0 +1,3 @@
+MD5 (libhid-0.2.16.tar.gz) = f2a427a6d6b98a5db8d17e2777173af7
+SHA256 (libhid-0.2.16.tar.gz) = f6809ab3b9c907cbb05ceba9ee6ca23a705f85fd71588518e14b3a7d9f2550e5
+SIZE (libhid-0.2.16.tar.gz) = 435245
diff --git a/devel/libhid/files/patch-Makefile.in b/devel/libhid/files/patch-Makefile.in
new file mode 100644
index 000000000000..e11bb27241c6
--- /dev/null
+++ b/devel/libhid/files/patch-Makefile.in
@@ -0,0 +1,11 @@
+--- Makefile.in.orig 2007-07-16 13:40:13.000000000 +0300
++++ Makefile.in 2007-07-16 13:41:37.000000000 +0300
+@@ -273,7 +273,7 @@
+ include/compiler.h \
+ include/os.h
+
+-pkgconfigdir = $(libdir)/pkgconfig
++pkgconfigdir = $(prefix)/libdata/pkgconfig
+ pkgconfig_DATA = pkgconfig/libhid.pc
+ dist_noinst_DATA = \
+ debian/changelog \
diff --git a/devel/libhid/files/patch-hidparser-hidtypes.h b/devel/libhid/files/patch-hidparser-hidtypes.h
new file mode 100644
index 000000000000..43086c0b8506
--- /dev/null
+++ b/devel/libhid/files/patch-hidparser-hidtypes.h
@@ -0,0 +1,11 @@
+--- hidparser/hidtypes.h.orig 2007-07-16 12:21:55.000000000 +0300
++++ hidparser/hidtypes.h 2007-07-16 12:22:04.000000000 +0300
+@@ -21,7 +21,7 @@
+ typedef unsigned char uchar;
+ #endif
+
+-#if HPUX || __APPLE__
++#if HPUX || __APPLE__ || __FreeBSD__
+ typedef unsigned long ulong;
+ #endif
+
diff --git a/devel/libhid/pkg-descr b/devel/libhid/pkg-descr
new file mode 100644
index 000000000000..4ff19da6b2a4
--- /dev/null
+++ b/devel/libhid/pkg-descr
@@ -0,0 +1,9 @@
+LibHID is a user-space HID access library written in C. It provides a
+generic and flexible way to access and interact with USB HID devices,
+much like libusb does for plain USB devices. It is based on libusb, thus
+it requires no HID support in the kernel. Furthermore, it aims to
+support all operating system supported by libusb: Linux, BSD, OS X, and
+Windows.
+
+
+WWW: http://libhid.alioth.debian.org/
diff --git a/devel/libhid/pkg-plist b/devel/libhid/pkg-plist
new file mode 100644
index 000000000000..626bf1a08e60
--- /dev/null
+++ b/devel/libhid/pkg-plist
@@ -0,0 +1,9 @@
+bin/libhid-detach-device
+include/hid.h
+include/hidparser.h
+include/hidtypes.h
+lib/libhid.a
+lib/libhid.la
+lib/libhid.so
+lib/libhid.so.0
+libdata/pkgconfig/libhid.pc