aboutsummaryrefslogtreecommitdiff
path: root/devel/libhoard/Makefile
diff options
context:
space:
mode:
authorSergey A. Osokin <osa@FreeBSD.org>2003-06-25 14:37:49 +0000
committerSergey A. Osokin <osa@FreeBSD.org>2003-06-25 14:37:49 +0000
commit48c379e3562e676e32b17b48af6741dc93647b1d (patch)
tree1eff29f139c6baf14e86b90d2fac42440f8141d3 /devel/libhoard/Makefile
parentbe48a67e7f995007da5d348a468541066a7556bc (diff)
downloadports-48c379e3562e676e32b17b48af6741dc93647b1d.tar.gz
ports-48c379e3562e676e32b17b48af6741dc93647b1d.zip
Notes
Diffstat (limited to 'devel/libhoard/Makefile')
-rw-r--r--devel/libhoard/Makefile20
1 files changed, 3 insertions, 17 deletions
diff --git a/devel/libhoard/Makefile b/devel/libhoard/Makefile
index ea580ff87e4e..83ce7950a62b 100644
--- a/devel/libhoard/Makefile
+++ b/devel/libhoard/Makefile
@@ -7,6 +7,7 @@
PORTNAME= libhoard
PORTVERSION= 2.1.2d
+PORTREVISION?= 1
CATEGORIES= devel
MASTER_SITES= http://www.cs.umass.edu/~emery/software/
@@ -21,25 +22,10 @@ INSTALLS_SHLIB= YES
.include <bsd.port.pre.mk>
-TESTPROG= testos
-
-check-os:
-.if !defined(SKIP_OS_TEST)
- -@${MKDIR} ${WRKSRC} ; \
- ${RM} -f ${WRKSRC}/${TESTPROG} ; \
- ${CC} ${PTHREAD_CFLAGS} ${PTHREAD_LIBS} -o ${WRKSRC}/${TESTPROG} \
- ${PATCHDIR}/${TESTPROG}.c > /dev/null 2>&1 ;
- @if [ ! -f ${WRKSRC}/${TESTPROG} ] ; \
- then \
- ${ECHO_MSG} "You must have a version of FreeBSD later than 4.8-STABLE" ; \
- ${ECHO_MSG} "27 May 2003 or 5.1-RELEASE to compile and use libhoard" ; \
- exit 1 ; \
- fi
- @${WRKSRC}/${TESTPROG} 2>/dev/null
+.if ${OSVERSION} < 501100
+IGNORE= "You must have a FreeBSD 5.1-RELEASE or better"
.endif
-pre-fetch: check-os
-
do-install:
${INSTALL_DATA} ${WRKSRC}/libhoard.so ${PREFIX}/lib/libhoard.so.1
${LN} -sf ${PREFIX}/lib/libhoard.so.1 ${PREFIX}/lib/libhoard.so