aboutsummaryrefslogtreecommitdiff
path: root/devel/libhoard
diff options
context:
space:
mode:
authorSergey A. Osokin <osa@FreeBSD.org>2010-06-05 06:41:23 +0000
committerSergey A. Osokin <osa@FreeBSD.org>2010-06-05 06:41:23 +0000
commit1ec1d69cac7a056045054400dd836c9bc96118fc (patch)
treef74d2db5e233f46b7db2f0c601f01e69e0a52e25 /devel/libhoard
parenta73fb33f103e73059e9909043aabd47137d3389f (diff)
downloadports-1ec1d69cac7a056045054400dd836c9bc96118fc.tar.gz
ports-1ec1d69cac7a056045054400dd836c9bc96118fc.zip
Notes
Diffstat (limited to 'devel/libhoard')
-rw-r--r--devel/libhoard/Makefile13
-rw-r--r--devel/libhoard/distinfo6
-rw-r--r--devel/libhoard/files/patch-Makefile29
-rw-r--r--devel/libhoard/files/patch-heaplayers-wrapper.cpp14
4 files changed, 12 insertions, 50 deletions
diff --git a/devel/libhoard/Makefile b/devel/libhoard/Makefile
index 9c2f9bbf67aa..f4378f0f215a 100644
--- a/devel/libhoard/Makefile
+++ b/devel/libhoard/Makefile
@@ -6,22 +6,27 @@
#
PORTNAME= libhoard
-PORTVERSION= 3.6.1
+PORTVERSION= 3.8
CATEGORIES= devel
-MASTER_SITES= http://www.cs.umass.edu/~emery/hoard/hoard-${PORTVERSION}/
-DISTNAME= hoard-361
+MASTER_SITES= http://www.cs.umass.edu/~emery/hoard/hoard-${PORTVERSION}/source/
+DISTNAME= hoard-38
MAINTAINER= osa@FreeBSD.org
COMMENT= Fast, scalable and memory-efficient allocator for MP
+LICENSE= GPLv2
+
ONLY_FOR_ARCHS= i386
USE_LDCONFIG= yes
-WRKSRC= ${WRKDIR}/hoard-${PORTVERSION}/src
+WRKSRC= ${WRKDIR}/${DISTNAME}/src
ALL_TARGET= freebsd
PLIST_FILES= lib/libhoard.so lib/libhoard.so.1
+post-patch:
+ ${REINPLACE_CMD} 's!g++!${CXX}!; s!-O2!${CFLAGS}!' ${WRKSRC}/Makefile
+
do-install:
${INSTALL_DATA} ${WRKSRC}/libhoard.so ${PREFIX}/lib/libhoard.so.1
${LN} -sf ${PREFIX}/lib/libhoard.so.1 ${PREFIX}/lib/libhoard.so
diff --git a/devel/libhoard/distinfo b/devel/libhoard/distinfo
index 1c6b3e75d6ec..d1b2b2846174 100644
--- a/devel/libhoard/distinfo
+++ b/devel/libhoard/distinfo
@@ -1,3 +1,3 @@
-MD5 (hoard-361.tar.gz) = b0d4caf762282c29fbee99959b22d342
-SHA256 (hoard-361.tar.gz) = b485fccad5b5ee7b19ee79f10c2a0fdc6ad45ed78152b2a8594b950409c77e40
-SIZE (hoard-361.tar.gz) = 821285
+MD5 (hoard-38.tar.gz) = f2d8ec3a13d4d9ba7b1c48c777707ef5
+SHA256 (hoard-38.tar.gz) = bdd0ef8e90672714f861ca3f0f25280509abd842c5f804dd01bab325a3139b08
+SIZE (hoard-38.tar.gz) = 408711
diff --git a/devel/libhoard/files/patch-Makefile b/devel/libhoard/files/patch-Makefile
deleted file mode 100644
index 85a236be04ad..000000000000
--- a/devel/libhoard/files/patch-Makefile
+++ /dev/null
@@ -1,29 +0,0 @@
---- Makefile.orig Thu May 24 10:21:25 2007
-+++ Makefile Thu May 24 10:22:26 2007
-@@ -1,6 +1,8 @@
- # Commands to compile Hoard for various targets.
- # Run make (with no arguments) to see the complete target list.
-
-+FREEBSD_COMPILE := $(CXX) $(CFLAGS) -static -DNDEBUG -I. -Iheaplayers -Iheaplayers/util -D_REENTRANT=1 -shared libhoard.cpp -Bsymbolic -o libhoard.so -pthread -fPIC
-+
- DARWIN8_COMPILE := g++ -pipe -O2 -DNDEBUG -I. -Iheaplayers -Iheaplayers/util -D_REENTRANT=1 -compatibility_version 1 -current_version 1 -dynamiclib libhoard.cpp -o libhoard.dylib -ldl -lpthread
-
- DARWIN8_COMPILE_DEBUG := g++ -pipe -g -I. -Iheaplayers -Iheaplayers/util -D_REENTRANT=1 -compatibility_version 1 -current_version 1 -dynamiclib libhoard.cpp -o libhoard.dylib -ldl -lpthread
-@@ -36,6 +38,7 @@
- all:
- @echo "To build Hoard, specify the desired build target:"
-
-+ @echo " freebsd"
- @echo " darwin"
- @echo " linux-gcc-x86"
- @echo " linux-gcc-x86-64"
-@@ -47,6 +50,9 @@
- @echo " (for build instructions on Windows, see NOTES.Windows)"
-
- .PHONY: darwin linux-gcc-x86 linux-gcc-x86-debug solaris-sunw-sparc solaris-sunw-x86 solaris-gcc-sparc generic-gcc linux-gcc-x86-64 clean
-+
-+freebsd:
-+ $(FREEBSD_COMPILE)
-
- darwin:
- $(DARWIN8_COMPILE)
diff --git a/devel/libhoard/files/patch-heaplayers-wrapper.cpp b/devel/libhoard/files/patch-heaplayers-wrapper.cpp
deleted file mode 100644
index 4354780d247e..000000000000
--- a/devel/libhoard/files/patch-heaplayers-wrapper.cpp
+++ /dev/null
@@ -1,14 +0,0 @@
---- heaplayers/wrapper.cpp.orig Thu May 24 10:24:34 2007
-+++ heaplayers/wrapper.cpp Thu May 24 10:29:14 2007
-@@ -31,7 +31,11 @@
- */
-
- #include <string.h> // for memcpy
-+#ifdef __FreeBSD__
-+#include <stdlib.h>
-+#else
- #include <malloc.h> // for memalign
-+#endif
-
- #ifdef _WIN32
- #define WIN32_LEAN_AND_MEAN