aboutsummaryrefslogtreecommitdiff
path: root/devel/libjitterentropy
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2019-10-01 20:22:40 +0000
committerSteve Wills <swills@FreeBSD.org>2019-10-01 20:22:40 +0000
commitbfbdac07c77056ea1537263c7d88f7c40161cd34 (patch)
tree3476828f4d6f390bdf3f079d0920ce04cd3caafe /devel/libjitterentropy
parentda8f01e7a80ea1a37b812b0e8dfbc52a05af855c (diff)
downloadports-bfbdac07c77056ea1537263c7d88f7c40161cd34.tar.gz
ports-bfbdac07c77056ea1537263c7d88f7c40161cd34.zip
Notes
Diffstat (limited to 'devel/libjitterentropy')
-rw-r--r--devel/libjitterentropy/Makefile21
-rw-r--r--devel/libjitterentropy/distinfo3
-rw-r--r--devel/libjitterentropy/files/patch-Makefile15
-rw-r--r--devel/libjitterentropy/pkg-descr6
-rw-r--r--devel/libjitterentropy/pkg-plist6
5 files changed, 51 insertions, 0 deletions
diff --git a/devel/libjitterentropy/Makefile b/devel/libjitterentropy/Makefile
new file mode 100644
index 000000000000..1e75dbadda37
--- /dev/null
+++ b/devel/libjitterentropy/Makefile
@@ -0,0 +1,21 @@
+# $FreeBSD$
+
+PORTNAME= libjitterentropy
+PORTVERSION= 2.2.0
+DISTVERSIONPREFIX= v
+CATEGORIES= devel
+
+MAINTAINER= swills@FreeBSD.org
+COMMENT= Hardware RNG based on CPU timing jitter
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILES= ${WRKSRC}/COPYING.bsd
+
+USES= gmake
+USE_LDCONFIG= yes
+
+USE_GITHUB= yes
+GH_ACCOUNT= smuellerDD
+GH_PROJECT= jitterentropy-library
+
+.include <bsd.port.mk>
diff --git a/devel/libjitterentropy/distinfo b/devel/libjitterentropy/distinfo
new file mode 100644
index 000000000000..35791d9ada67
--- /dev/null
+++ b/devel/libjitterentropy/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1569954224
+SHA256 (smuellerDD-jitterentropy-library-v2.2.0_GH0.tar.gz) = 42d4bd1050b5f0d7b45b5453e5b6cfc45c0492bb428791f571d8f69b066351a4
+SIZE (smuellerDD-jitterentropy-library-v2.2.0_GH0.tar.gz) = 25556
diff --git a/devel/libjitterentropy/files/patch-Makefile b/devel/libjitterentropy/files/patch-Makefile
new file mode 100644
index 000000000000..3f016ca2a4a0
--- /dev/null
+++ b/devel/libjitterentropy/files/patch-Makefile
@@ -0,0 +1,15 @@
+--- Makefile.orig 2019-10-01 18:36:51 UTC
++++ Makefile
+@@ -56,9 +56,9 @@ cppcheck:
+ cppcheck --force -q --enable=performance --enable=warning --enable=portability *.h *.c
+
+ install:
+- install -d -m 0755 $(DESTDIR)$(PREFIX)/share/man/man3
+- install -m 644 doc/$(NAME).3 $(DESTDIR)$(PREFIX)/share/man/man3/
+- gzip -9 $(DESTDIR)$(PREFIX)/share/man/man3/$(NAME).3
++ install -d -m 0755 $(DESTDIR)$(PREFIX)/man/man3
++ install -m 644 doc/$(NAME).3 $(DESTDIR)$(PREFIX)/man/man3/
++ gzip -9 $(DESTDIR)$(PREFIX)/man/man3/$(NAME).3
+ install -d -m 0755 $(DESTDIR)$(PREFIX)/$(LIBDIR)
+ install -m 0755 -s lib$(NAME).so.$(LIBVERSION) $(DESTDIR)$(PREFIX)/$(LIBDIR)/
+ install -d -m 0755 $(DESTDIR)$(PREFIX)/$(INCDIR)
diff --git a/devel/libjitterentropy/pkg-descr b/devel/libjitterentropy/pkg-descr
new file mode 100644
index 000000000000..eb7bc940af38
--- /dev/null
+++ b/devel/libjitterentropy/pkg-descr
@@ -0,0 +1,6 @@
+The CPU Jitter Random Number Generator provides a non-physical true random
+number generator that works equally in kernel and user land. The only
+prerequisite is the availability of a high-resolution timer that is available
+in modern CPUs.
+
+WWW: http://www.chronox.de/jent.html
diff --git a/devel/libjitterentropy/pkg-plist b/devel/libjitterentropy/pkg-plist
new file mode 100644
index 000000000000..c56bb01b5390
--- /dev/null
+++ b/devel/libjitterentropy/pkg-plist
@@ -0,0 +1,6 @@
+include/jitterentropy-base-user.h
+include/jitterentropy.h
+lib/libjitterentropy.so
+lib/libjitterentropy.so.2
+lib/libjitterentropy.so.2.2.0
+man/man3/jitterentropy.3.gz