aboutsummaryrefslogtreecommitdiff
path: root/devel/libk8055
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2012-01-14 19:11:58 +0000
committerMartin Wilke <miwi@FreeBSD.org>2012-01-14 19:11:58 +0000
commit160c1853b7508ba10122793950935e24c63b532b (patch)
tree2303eb4a65dd81e6500456d3a4e92a2013a9bb56 /devel/libk8055
parentc76d7bff458717baecad7a7c86d5281688ba1f37 (diff)
downloadports-160c1853b7508ba10122793950935e24c63b532b.tar.gz
ports-160c1853b7508ba10122793950935e24c63b532b.zip
Notes
Diffstat (limited to 'devel/libk8055')
-rw-r--r--devel/libk8055/Makefile7
-rw-r--r--devel/libk8055/files/patch-Makefile47
2 files changed, 52 insertions, 2 deletions
diff --git a/devel/libk8055/Makefile b/devel/libk8055/Makefile
index 83f76db5fa61..1996aa81ff37 100644
--- a/devel/libk8055/Makefile
+++ b/devel/libk8055/Makefile
@@ -17,6 +17,7 @@ COMMENT= Velleman K8055 USB experimental board support and command line tool
MAN1= k8055.1
MANCOMPRESSED= yes
USE_LDCONFIG= yes
+USE_CSTD= gnu89
PLIST_FILES= bin/k8055 \
lib/libk8055.c \
@@ -27,8 +28,10 @@ PLIST_FILES= bin/k8055 \
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 800000
-BROKEN= does not compile on FreeBSD 7.X
+.if ${OSVERSION} < 800069
+LIB_DEPENDS+= usb:${PORTSDIR}/devel/libusb
+CFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
.endif
post-patch:
diff --git a/devel/libk8055/files/patch-Makefile b/devel/libk8055/files/patch-Makefile
new file mode 100644
index 000000000000..da6b21097653
--- /dev/null
+++ b/devel/libk8055/files/patch-Makefile
@@ -0,0 +1,47 @@
+--- Makefile.orig 2011-12-31 03:12:14.464658120 +0000
++++ Makefile 2011-12-31 03:12:42.754252842 +0000
+@@ -1,22 +1,22 @@
+-cc = gcc
++CC ?= gcc
+ exec = k8055
+-bindir = /usr/local/bin
+-libdir = /usr/local/lib
+-includedir = /usr/local/include
+-mandir = /usr/local/man/man1
++bindir = ${PREFIX}/bin
++libdir = ${PREFIX}/lib
++includedir = ${PREFIX}/include
++mandir = ${MANPREFIX}/man/man1
+ OBJS = main.o libk8055.o
+ # if your are using Linux comment out next line
+-CFLAGS = -DDAEMON -Wall -D_BSD
++CFLAGS += -DDAEMON -Wall -D_BSD
+ # if you are using Linux incomment following line
+ #CFLAGS = -DDAEMON -Wall
+
+-libs = -lusb -L/usr/lib -lm
++libs = -lusb -L/usr/lib ${LDFLAGS} -lm
+
+ libk8055.so.0.1: libk8055.o
+- $(cc) -Wall -o libk8055.so.0.2 -shared libk8055.o
++ $(CC) -Wall -o libk8055.so.0.2 -shared libk8055.o
+
+ libk8055.o: libk8055.c
+- $(cc) -Wall -O -c -g -fPIC $(CFLAGS) libk8055.c
++ $(CC) -Wall -O -c -g -fPIC $(CFLAGS) libk8055.c
+ -ln -sf libk8055.so.0.2 libk8055.so
+
+ libk8055.c: k8055.h
+@@ -24,10 +24,10 @@
+ all: k8055_prog libk8055.so.0.1
+
+ %.o: %.c
+- $(cc) $(CFLAGS) -c $<
++ $(CC) $(CFLAGS) -c $<
+
+ k8055_prog: $(OBJS)
+- $(cc) $(OBJS) -o $(exec) $(libs)
++ $(CC) $(OBJS) -o $(exec) $(libs)
+ strip $(exec)
+
+ clean: