aboutsummaryrefslogtreecommitdiff
path: root/devel/liblouis
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-03-21 09:41:29 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-03-21 09:41:29 +0000
commit39b03754360fdb0a2ec317f1f69cca48ece378d9 (patch)
tree6ce17a74a8388120a71df7382647da5eef41dd92 /devel/liblouis
parenta948135d2a46beac8add20ef25794404087731f6 (diff)
downloadports-39b03754360fdb0a2ec317f1f69cca48ece378d9.tar.gz
ports-39b03754360fdb0a2ec317f1f69cca48ece378d9.zip
Notes
Diffstat (limited to 'devel/liblouis')
-rw-r--r--devel/liblouis/Makefile39
-rw-r--r--devel/liblouis/distinfo3
-rw-r--r--devel/liblouis/pkg-descr10
-rw-r--r--devel/liblouis/pkg-plist120
4 files changed, 172 insertions, 0 deletions
diff --git a/devel/liblouis/Makefile b/devel/liblouis/Makefile
new file mode 100644
index 000000000000..f8ba7fcd4033
--- /dev/null
+++ b/devel/liblouis/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: liblouis
+# Date created: 06 Feb 2009
+# Whom: Wen Heping <wenheping@gmail.com>
+# $FreeBSD$
+
+PORTNAME= liblouis
+PORTVERSION= 1.5.2
+CATEGORIES= devel
+MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
+
+MAINTAINER= wenheping@gmail.com
+COMMENT= An Open-source Braille Translator And Back-translator
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_LDCONFIG= yes
+
+post-extract:
+ @${REINPLACE_CMD} -e \
+ 's#@libdir@#${PREFIX}/libdata#g' ${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -e \
+ 's#tables doc tests python#tests python#g' ${WRKSRC}/Makefile.in
+
+post-install:
+ ${MKDIR} ${DATADIR}/tables
+ ${INSTALL_DATA} ${WRKSRC}/tables/*.dic ${DATADIR}/tables/
+ ${INSTALL_DATA} ${WRKSRC}/tables/*.ctb ${DATADIR}/tables/
+ ${INSTALL_DATA} ${WRKSRC}/tables/*.utb ${DATADIR}/tables/
+ ${INSTALL_DATA} ${WRKSRC}/tables/*.cti ${DATADIR}/tables/
+ ${INSTALL_DATA} ${WRKSRC}/tables/*.utb2 ${DATADIR}/tables/
+ ${INSTALL_DATA} ${WRKSRC}/tables/*.dis ${DATADIR}/tables/
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+.for i in liblouis-guide.html liblouis-guide.txt
+ ${INSTALL_MAN} ${WRKSRC}/doc/${i} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/liblouis/distinfo b/devel/liblouis/distinfo
new file mode 100644
index 000000000000..0425a534d288
--- /dev/null
+++ b/devel/liblouis/distinfo
@@ -0,0 +1,3 @@
+MD5 (liblouis-1.5.2.tar.gz) = d143c6cc450f523cb643e7254313c60d
+SHA256 (liblouis-1.5.2.tar.gz) = 58e2f6d3001f1e0ac7896fed5535c8b288b928067aa4378948596f6b3eea219a
+SIZE (liblouis-1.5.2.tar.gz) = 1322468
diff --git a/devel/liblouis/pkg-descr b/devel/liblouis/pkg-descr
new file mode 100644
index 000000000000..f97b3182b30e
--- /dev/null
+++ b/devel/liblouis/pkg-descr
@@ -0,0 +1,10 @@
+Liblouis is an open-source braille translator and back-translator.
+It features support for computer and literary braille, supports
+contracted and uncontracted translation for many, many languages
+and has support for hyphenation. New languages can easily be added
+through tables that support a rule- or dictionary based approach.
+Included are also tools for testing and debugging tables. Liblouis
+also supports math braille (Nemeth and Marburg). The formatting of
+braille is provided by the companion project liblouisxml.
+
+WWW: http://code.google.com/p/liblouis/
diff --git a/devel/liblouis/pkg-plist b/devel/liblouis/pkg-plist
new file mode 100644
index 000000000000..fe9469c30d0b
--- /dev/null
+++ b/devel/liblouis/pkg-plist
@@ -0,0 +1,120 @@
+bin/lou_allround
+bin/lou_checktable
+bin/lou_debug
+bin/lou_translate
+include/liblouis/liblouis.h
+include/liblouis/louiscfg.h
+lib/liblouis.a
+lib/liblouis.la
+lib/liblouis.so
+lib/liblouis.so.2
+libdata/pkgconfig/liblouis.pc
+%%PORTDOCS%%%%DOCSDIR%%/liblouis-guide.html
+%%PORTDOCS%%%%DOCSDIR%%/liblouis-guide.txt
+%%DATADIR%%/tables/Cz-Cz-g1.utb
+%%DATADIR%%/tables/Es-Es-g1.utb
+%%DATADIR%%/tables/Fr-Ca-g2.ctb
+%%DATADIR%%/tables/Fr-Fr-g2.ctb
+%%DATADIR%%/tables/Lv-Lv-g1.utb
+%%DATADIR%%/tables/Nl-Nl-g1.utb
+%%DATADIR%%/tables/No-No-g0.utb
+%%DATADIR%%/tables/No-No-g1.ctb
+%%DATADIR%%/tables/No-No-g2.ctb
+%%DATADIR%%/tables/No-No-g3.ctb
+%%DATADIR%%/tables/Pl-Pl-g1.utb
+%%DATADIR%%/tables/Pt-Pt-g1.utb
+%%DATADIR%%/tables/Se-Se-g1.utb
+%%DATADIR%%/tables/UEBC-g1.utb
+%%DATADIR%%/tables/UEBC-g2.ctb
+%%DATADIR%%/tables/ar-ar-g1.utb
+%%DATADIR%%/tables/bg.ctb
+%%DATADIR%%/tables/boxes.ctb
+%%DATADIR%%/tables/chardefs.cti
+%%DATADIR%%/tables/compress.ctb
+%%DATADIR%%/tables/corrections.ctb
+%%DATADIR%%/tables/countries.cti
+%%DATADIR%%/tables/cy-cy-g1.utb
+%%DATADIR%%/tables/cy-cy-g2.ctb
+%%DATADIR%%/tables/da-1252.ctb
+%%DATADIR%%/tables/da-lt.ctb
+%%DATADIR%%/tables/da.ctb
+%%DATADIR%%/tables/dansk.dis
+%%DATADIR%%/tables/dansk.utb
+%%DATADIR%%/tables/de-chess.ctb
+%%DATADIR%%/tables/de-de-g0.utb
+%%DATADIR%%/tables/de-de-g1.ctb
+%%DATADIR%%/tables/de-de-g2.ctb
+%%DATADIR%%/tables/de-de.dis
+%%DATADIR%%/tables/en-GB-g2.ctb
+%%DATADIR%%/tables/en-chess.ctb
+%%DATADIR%%/tables/en-gb-g1.utb
+%%DATADIR%%/tables/en-us-brf.dis
+%%DATADIR%%/tables/en-us-comp6.ctb
+%%DATADIR%%/tables/en-us-comp8.ctb
+%%DATADIR%%/tables/en-us-compbrl.ctb
+%%DATADIR%%/tables/en-us-g1.ctb
+%%DATADIR%%/tables/en-us-g1.utb
+%%DATADIR%%/tables/en-us-g2.ctb
+%%DATADIR%%/tables/en-us-interline.ctb
+%%DATADIR%%/tables/en-us-mathtext.ctb
+%%DATADIR%%/tables/en_CA.ctb
+%%DATADIR%%/tables/eo.ctb
+%%DATADIR%%/tables/et.ctb
+%%DATADIR%%/tables/eurodefs.cti
+%%DATADIR%%/tables/fi-fi-8dot.ctb
+%%DATADIR%%/tables/fi-fi.ctb
+%%DATADIR%%/tables/fi1.ctb
+%%DATADIR%%/tables/fi2.ctb
+%%DATADIR%%/tables/fr-2007.ctb
+%%DATADIR%%/tables/fr-bfu-comp6.utb
+%%DATADIR%%/tables/fr-bfu-comp8.utb
+%%DATADIR%%/tables/fr-bfu-g2.ctb
+%%DATADIR%%/tables/fr-ca-g1.utb
+%%DATADIR%%/tables/fr-fr-g1.utb
+%%DATADIR%%/tables/gd.ctb
+%%DATADIR%%/tables/gr-bb.ctb
+%%DATADIR%%/tables/gr-gr-g1.utb
+%%DATADIR%%/tables/hi-in-g1.utb
+%%DATADIR%%/tables/hr.ctb
+%%DATADIR%%/tables/hy.ctb
+%%DATADIR%%/tables/hyph_de_DE.dic
+%%DATADIR%%/tables/hyph_en_US.dic
+%%DATADIR%%/tables/hyph_es_ES.dic
+%%DATADIR%%/tables/hyph_fr_FR.dic
+%%DATADIR%%/tables/hyph_it_IT.dic
+%%DATADIR%%/tables/hyph_nl_NL.dic
+%%DATADIR%%/tables/hyph_no_NO.dic
+%%DATADIR%%/tables/hyph_pl_PL.dic
+%%DATADIR%%/tables/hyph_pt_PT.dic
+%%DATADIR%%/tables/hyph_sv_SE.dic
+%%DATADIR%%/tables/is.ctb
+%%DATADIR%%/tables/it-it-g1.utb
+%%DATADIR%%/tables/it-it-g1.utb2
+%%DATADIR%%/tables/lt.ctb
+%%DATADIR%%/tables/marburg.ctb
+%%DATADIR%%/tables/marburg_edit.ctb
+%%DATADIR%%/tables/marburgdefs.cti
+%%DATADIR%%/tables/nemeth.ctb
+%%DATADIR%%/tables/nemeth_edit.ctb
+%%DATADIR%%/tables/nemethdefs.cti
+%%DATADIR%%/tables/nl-be-g1.utb
+%%DATADIR%%/tables/no-gen.dis
+%%DATADIR%%/tables/no-no.dis
+%%DATADIR%%/tables/printables.cti
+%%DATADIR%%/tables/ro.ctb
+%%DATADIR%%/tables/ru.ctb
+%%DATADIR%%/tables/se-se.dis
+%%DATADIR%%/tables/sk-sk-g1.utb
+%%DATADIR%%/tables/sk-sk.utb
+%%DATADIR%%/tables/spaces.ctb
+%%DATADIR%%/tables/text_nabcc.dis
+%%DATADIR%%/tables/tr.ctb
+%%DATADIR%%/tables/ukchardefs.cti
+%%DATADIR%%/tables/uni-text.dis
+%%DATADIR%%/tables/unicodedefs.cti
+%%DATADIR%%/tables/vi.ctb
+%%DATADIR%%/tables/zh-tw.ctb
+@dirrm %%DATADIR%%/tables
+@dirrm %%DATADIR%%
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@dirrm include/liblouis