aboutsummaryrefslogtreecommitdiff
path: root/devel/libltdl
diff options
context:
space:
mode:
authorAde Lovett <ade@FreeBSD.org>2010-12-08 19:58:49 +0000
committerAde Lovett <ade@FreeBSD.org>2010-12-08 19:58:49 +0000
commitf584da22ee03bf55f4db7ffa79c61aa8ad827ad6 (patch)
treef7da82208d8de3376467178192bb0f8181f73280 /devel/libltdl
parentdeb6a6b36bfd8259bc9c372e4698cb7c7a8233ce (diff)
downloadports-f584da22ee03bf55f4db7ffa79c61aa8ad827ad6.tar.gz
ports-f584da22ee03bf55f4db7ffa79c61aa8ad827ad6.zip
Notes
Diffstat (limited to 'devel/libltdl')
-rw-r--r--devel/libltdl/Makefile28
-rw-r--r--devel/libltdl/pkg-descr9
-rw-r--r--devel/libltdl/pkg-plist9
3 files changed, 46 insertions, 0 deletions
diff --git a/devel/libltdl/Makefile b/devel/libltdl/Makefile
new file mode 100644
index 000000000000..ad5b86096964
--- /dev/null
+++ b/devel/libltdl/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: libltdl
+# Date created: 23 January 2002
+# Whom: Jeremy Norris <ishmael27x@yahoo.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libltdl
+MASTERDIR= ${.CURDIR}/../../devel/libtool
+
+COMMENT= System independent dlopen wrapper
+
+LICENSE= LGPL21
+LICENSE_FILE= ${CONFIGURE_WRKSRC}/COPYING.LIB
+USE_GNOME= ltverhack
+USE_LDCONFIG= yes
+USE_AUTOTOOLS= libtool
+LIBTOOLFILES= libltdl/configure
+CONFIGURE_ARGS= --enable-ltdl-install
+
+CONFIGURE_WRKSRC=${WRKSRC}/libltdl
+BUILD_WRKSRC= ${CONFIGURE_WRKSRC}
+INSTALL_WRKSRC= ${CONFIGURE_WRKSRC}
+DESCR= ${.CURDIR}/pkg-descr
+PLIST= ${.CURDIR}/pkg-plist
+INFO= # empty
+
+.include "${MASTERDIR}/Makefile"
diff --git a/devel/libltdl/pkg-descr b/devel/libltdl/pkg-descr
new file mode 100644
index 000000000000..e57b99f21a5c
--- /dev/null
+++ b/devel/libltdl/pkg-descr
@@ -0,0 +1,9 @@
+This is GNU libltdl, a system independent dlopen wrapper for GNU libtool.
+
+It supports the following dlopen interfaces:
+* dlopen (Solaris, Linux and various BSD flavors)
+* shl_load (HP-UX)
+* LoadLibrary (Win16 and Win32)
+* load_add_on (BeOS)
+* GNU DLD (emulates dynamic linking for static libraries)
+* libtool's dlpreopen
diff --git a/devel/libltdl/pkg-plist b/devel/libltdl/pkg-plist
new file mode 100644
index 000000000000..bd6781079532
--- /dev/null
+++ b/devel/libltdl/pkg-plist
@@ -0,0 +1,9 @@
+include/libltdl/lt_dlloader.h
+include/libltdl/lt_error.h
+include/libltdl/lt_system.h
+include/ltdl.h
+lib/libltdl.a
+lib/libltdl.la
+lib/libltdl.so
+lib/libltdl.so.7
+@dirrm include/libltdl