aboutsummaryrefslogtreecommitdiff
path: root/devel/libmba/Makefile
diff options
context:
space:
mode:
authorNorikatsu Shigemura <nork@FreeBSD.org>2002-11-23 15:15:51 +0000
committerNorikatsu Shigemura <nork@FreeBSD.org>2002-11-23 15:15:51 +0000
commit663512aa6c82165dff33321afdf24a42e70382f9 (patch)
tree3fac7444dd164c9c638e2ac114f093ee139ddda6 /devel/libmba/Makefile
parente393e388ebd50f9700432331f4e12c134fd70b56 (diff)
downloadports-663512aa6c82165dff33321afdf24a42e70382f9.tar.gz
ports-663512aa6c82165dff33321afdf24a42e70382f9.zip
Notes
Diffstat (limited to 'devel/libmba/Makefile')
-rw-r--r--devel/libmba/Makefile20
1 files changed, 7 insertions, 13 deletions
diff --git a/devel/libmba/Makefile b/devel/libmba/Makefile
index 3c37b05f4957..f4ea5d65c98c 100644
--- a/devel/libmba/Makefile
+++ b/devel/libmba/Makefile
@@ -7,29 +7,23 @@
#
PORTNAME= libmba
-PORTVERSION= 0.3.6
+PORTVERSION= 0.4.5
CATEGORIES= devel
-MASTER_SITES= http://users.erols.com/mballen/libmba/src/
+MASTER_SITES= http://www.eskimo.com/~miallen/libmba/dl/
MAINTAINER= ports@FreeBSD.org
LIB_DEPENDS= expat.4:${PORTSDIR}/textproc/expat2
-SHLIB_MAJOR= 0
-
-USE_REINPLACE= yes
-CFLAGS= -I${LOCALBASE}/include -L${LOCALBASE}/lib
-MAKE_ENV= SHLIB_MAJOR="${SHLIB_MAJOR}" INSTDIR=${PREFIX}
-ALL_TARGET= # empty
+USE_GMAKE= yes
INSTALLS_SHLIB= yes
+SHLIB_MAJOR= 0
+MAKE_ENV= SHLIB_MAJOR="${SHLIB_MAJOR}"
PLIST_SUB= SHLIB_MAJOR="${SHLIB_MAJOR}"
+MAN3= cfg.3m domnode.3m mbs.3m msgno.3m hashmap.3m hexdump.3m \
+ linkedlist.3m stack.3m
MANCOMPRESSED= yes
-MAN3= domnode.3m hexdump.3m msgno.3m hashmap.3m linkedlist.3m stack.3m
-
-post-patch:
- @${REINPLACE_CMD} -e "s|/usr|${PREFIX}|g" \
- -e "s|gcc|${CC}|g" ${WRKSRC}/Makefile
.include <bsd.port.mk>