aboutsummaryrefslogtreecommitdiff
path: root/devel/libmba
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2014-08-15 06:55:11 +0000
committerJohn Marino <marino@FreeBSD.org>2014-08-15 06:55:11 +0000
commit19528f71b63a96f48fcf2a6564e4463592a47ec3 (patch)
tree7e3c8697a290ea968cc86a725c70a7186ca171a3 /devel/libmba
parentbfb43a501784ba5fd98d657dbb4e7e7fecbc0502 (diff)
downloadports-19528f71b63a96f48fcf2a6564e4463592a47ec3.tar.gz
ports-19528f71b63a96f48fcf2a6564e4463592a47ec3.zip
Notes
Diffstat (limited to 'devel/libmba')
-rw-r--r--devel/libmba/Makefile5
-rw-r--r--devel/libmba/files/patch-mktool.c23
2 files changed, 25 insertions, 3 deletions
diff --git a/devel/libmba/Makefile b/devel/libmba/Makefile
index 1688617908a4..5fed64e635fa 100644
--- a/devel/libmba/Makefile
+++ b/devel/libmba/Makefile
@@ -3,6 +3,7 @@
PORTNAME= libmba
PORTVERSION= 0.9.1
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= http://www.ioplex.com/~miallen/libmba/dl/ \
${MASTER_SITE_LOCAL}
@@ -13,12 +14,10 @@ COMMENT= Collection of C modules potentially useful to any project
MAKE_JOBS_UNSAFE= yes
USE_LDCONFIG= yes
-MAKE_ARGS= PREFIX=${STAGEDIR}${PREFIX}
+MAKE_ARGS= prefix="${STAGEDIR}${PREFIX}"
post-patch:
@${REINPLACE_CMD} -e 's,-g,$$(CFLAGS),' \
- -e '/^prefix/s/=/?=/' \
- -e 's/prefix/PREFIX/' \
${WRKSRC}/Makefile
@${REINPLACE_CMD} -Ee 's,"g?cc","${CC}",' \
${WRKSRC}/mktool.c
diff --git a/devel/libmba/files/patch-mktool.c b/devel/libmba/files/patch-mktool.c
new file mode 100644
index 000000000000..177a9ddf9f91
--- /dev/null
+++ b/devel/libmba/files/patch-mktool.c
@@ -0,0 +1,23 @@
+--- mktool.c~
++++ mktool.c
+@@ -89,18 +89,18 @@ static const char *arg_array[32] = {
+ "lib%n.%1.%2.%3.dylib",
+ "lib%n.%1.%2.dylib",
+ "lib%n.dylib",
+ "darwin",
+-#elif defined(__FreeBSD__) || defined(__NetBSD__)
++#elif defined(__DragonFly__) || defined(__FreeBSD__) || defined(__NetBSD__)
+ "gcc",
+ " -g",
+ " -Wall -W",
+ " -Wall -W -ansi -pedantic",
+ " -std=c99",
+ " -std=c89",
+ " -fpic",
+ " -fPIC",
+- " -Wl,-soname,lib%n.so.%1.%2",
++ " -Wl,-soname,lib%n.so.%1",
+ "",
+ " -shared",
+ " -Wl,-rpath,%s",
+ "lib%n.so.%1",