aboutsummaryrefslogtreecommitdiff
path: root/devel/libmba
diff options
context:
space:
mode:
authorSimon Barner <barner@FreeBSD.org>2005-03-08 16:21:34 +0000
committerSimon Barner <barner@FreeBSD.org>2005-03-08 16:21:34 +0000
commite057bad313c54711d8d921be00baa7f74371fb93 (patch)
tree5dece436b0c9719d29e58921650698de1b98070d /devel/libmba
parent90276af3c21bea73e4979436150bac5d87dcdd3a (diff)
downloadports-e057bad313c54711d8d921be00baa7f74371fb93.tar.gz
ports-e057bad313c54711d8d921be00baa7f74371fb93.zip
Notes
Diffstat (limited to 'devel/libmba')
-rw-r--r--devel/libmba/Makefile21
-rw-r--r--devel/libmba/distinfo4
-rw-r--r--devel/libmba/files/patch-src::hashmap.c10
-rw-r--r--devel/libmba/files/patch-src::mba::shellout.h10
-rw-r--r--devel/libmba/files/patch-src::mba::svsem.h11
-rw-r--r--devel/libmba/files/patch-src::shellout.c16
-rw-r--r--devel/libmba/files/patch-src::svsem.c29
-rw-r--r--devel/libmba/pkg-plist15
8 files changed, 100 insertions, 16 deletions
diff --git a/devel/libmba/Makefile b/devel/libmba/Makefile
index 9e2eb7f70aea..188280ab6987 100644
--- a/devel/libmba/Makefile
+++ b/devel/libmba/Makefile
@@ -7,8 +7,7 @@
#
PORTNAME= libmba
-PORTVERSION= 0.6.1
-PORTREVISION= 2
+PORTVERSION= 0.8.10
CATEGORIES= devel
MASTER_SITES= http://www.ioplex.com/~miallen/libmba/dl/
@@ -26,11 +25,18 @@ MAKE_ENV= prefix="${PREFIX}" CC="${CC}" \
PLIST_SUB= SHLIB_MAJOR="${SHLIB_MAJOR}"
INSTALLS_SHLIB= yes
-MAN3= cfg.3m csv.3m domnode.3m mbs.3m msgno.3m hashmap.3m hexdump.3m \
- linkedlist.3m pool.3m shellout.3m stack.3m varray.3m
+MAN3= allocator.3m bitset.3m cfg.3m csv.3m diff.3m eval.3m hashmap.3m \
+ hexdump.3m linkedlist.3m msgno.3m path.3m pool.3m shellout.3m \
+ stack.3m suba.3m svcond.3m svsem.3m text.3m time.3m varray.3m
MANCOMPRESSED= yes
-SHLIB_MAJOR= 0
+SHLIB_MAJOR= 1
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500039
+IGNORE= requires wchar functions for compilation
+.endif
post-patch:
@${REINPLACE_CMD} -e 's|/usr/local|\$${PREFIX}|g ; \
@@ -41,6 +47,7 @@ post-patch:
s|^RPM_OPT_FLAGS|#RPM_OPT_FLAGS|g ; \
s| -lc| \$${LDFLAGS}|g ; \
s|install -m ...|\$${BSD_INSTALL_DATA}|g ; \
- s|-/sbin/ldconfig.*$$||g' ${WRKSRC}/Makefile
+ s|-/sbin/ldconfig.*$$||g ; \
+ s|-D_XOPEN_SOURCE=500||g' ${WRKSRC}/Makefile
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/devel/libmba/distinfo b/devel/libmba/distinfo
index 417f50f5ef53..84ff76f4672c 100644
--- a/devel/libmba/distinfo
+++ b/devel/libmba/distinfo
@@ -1,2 +1,2 @@
-MD5 (libmba-0.6.1.tar.gz) = 88e51830bf6ba11d2c78f53228d259ea
-SIZE (libmba-0.6.1.tar.gz) = 122048
+MD5 (libmba-0.8.10.tar.gz) = 868dc9cc9f1115868ad0e0cec7bcf65b
+SIZE (libmba-0.8.10.tar.gz) = 259427
diff --git a/devel/libmba/files/patch-src::hashmap.c b/devel/libmba/files/patch-src::hashmap.c
new file mode 100644
index 000000000000..7abc3b6db771
--- /dev/null
+++ b/devel/libmba/files/patch-src::hashmap.c
@@ -0,0 +1,10 @@
+--- src/hashmap.c.orig Tue May 25 18:10:09 2004
++++ src/hashmap.c Mon Feb 21 00:31:21 2005
+@@ -26,6 +26,7 @@
+ #include <string.h>
+ #include <errno.h>
+ #include <stdio.h>
++#include <wchar.h>
+ #include "mba/msgno.h"
+ #include "mba/iterator.h"
+ #include "mba/allocator.h"
diff --git a/devel/libmba/files/patch-src::mba::shellout.h b/devel/libmba/files/patch-src::mba::shellout.h
new file mode 100644
index 000000000000..f9377fd383bf
--- /dev/null
+++ b/devel/libmba/files/patch-src::mba::shellout.h
@@ -0,0 +1,10 @@
+--- src/mba/shellout.h.orig Tue May 18 18:07:17 2004
++++ src/mba/shellout.h Mon Feb 21 01:54:34 2005
+@@ -9,6 +9,7 @@
+ #endif
+
+ #include <termios.h>
++#include <unistd.h>
+
+ #define SHO_FLAGS_INTERACT 0x0001
+ #define SHO_FLAGS_ISATTY 0x0100
diff --git a/devel/libmba/files/patch-src::mba::svsem.h b/devel/libmba/files/patch-src::mba::svsem.h
new file mode 100644
index 000000000000..8d46cc1bc442
--- /dev/null
+++ b/devel/libmba/files/patch-src::mba::svsem.h
@@ -0,0 +1,11 @@
+--- src/mba/svsem.h.orig Wed May 26 16:32:35 2004
++++ src/mba/svsem.h Mon Feb 21 00:31:21 2005
+@@ -9,6 +9,8 @@
+ #endif
+
+ #include <fcntl.h>
++#include <sys/types.h>
++#include <sys/ipc.h>
+ #include <sys/sem.h>
+ #include <mba/pool.h>
+ #include <mba/varray.h>
diff --git a/devel/libmba/files/patch-src::shellout.c b/devel/libmba/files/patch-src::shellout.c
index 57b7ec5a051e..74e17677cf99 100644
--- a/devel/libmba/files/patch-src::shellout.c
+++ b/devel/libmba/files/patch-src::shellout.c
@@ -1,11 +1,19 @@
---- src/shellout.c.orig Mon Mar 10 09:10:10 2003
-+++ src/shellout.c Tue Apr 15 12:46:00 2003
-@@ -27,7 +27,7 @@
+--- src/shellout.c.orig Fri May 28 23:52:03 2004
++++ src/shellout.c Tue Mar 8 16:56:58 2005
+@@ -27,12 +27,15 @@
#include <string.h>
#include <termios.h>
#include <unistd.h>
-#include <pty.h>
-+/* #include <pty.h> */
#include <errno.h>
#include <sys/types.h>
++#include <sys/ioctl.h>
#include <sys/wait.h>
+ #include <sys/time.h>
++#include <sys/select.h>
+ #include <signal.h>
++#include <termios.h>
++#include <libutil.h>
+ #include "mba/msgno.h"
+ #include "mba/text.h"
+ #include "mba/shellout.h"
diff --git a/devel/libmba/files/patch-src::svsem.c b/devel/libmba/files/patch-src::svsem.c
new file mode 100644
index 000000000000..90f0f44a8819
--- /dev/null
+++ b/devel/libmba/files/patch-src::svsem.c
@@ -0,0 +1,29 @@
+--- src/svsem.c.orig Wed May 26 16:32:24 2004
++++ src/svsem.c Mon Feb 21 00:31:21 2005
+@@ -42,7 +42,7 @@
+ #include "mba/msgno.h"
+ #include "defines.h"
+
+-#if defined(__GNU_LIBRARY__) && !defined(_SEM_SEMUN_UNDEFINED)
++#if defined(__GNU_LIBRARY__) && !defined(_SEM_SEMUN_UNDEFINED) || defined(__FreeBSD__)
+ /* union semun is defined by including <sys/sem.h> */
+ #include <sys/sem.h>
+ #else
+@@ -108,7 +108,7 @@
+ sleep(1);
+ }
+
+- errno = ETIME;
++ errno = ETIMEDOUT;
+ PMNF(errno, ": %s", name);
+ return -1;
+ } else if (errno != ENOENT) {
+@@ -296,7 +296,7 @@
+ int fd, cre;
+
+ va_start(ap, oflag);
+- mode = va_arg(ap, mode_t);
++ mode = va_arg(ap, int);
+ val = va_arg(ap, unsigned int);
+ va_end(ap);
+
diff --git a/devel/libmba/pkg-plist b/devel/libmba/pkg-plist
index 8c6dab83c390..c867dda2b616 100644
--- a/devel/libmba/pkg-plist
+++ b/devel/libmba/pkg-plist
@@ -1,16 +1,25 @@
+include/mba/allocator.h
+include/mba/bitset.h
include/mba/cfg.h
include/mba/csv.h
-include/mba/domnode.h
+include/mba/daemon.h
+include/mba/diff.h
+include/mba/eval.h
include/mba/hashmap.h
include/mba/hexdump.h
include/mba/iterator.h
include/mba/linkedlist.h
-include/mba/mbs.h
+include/mba/misc.h
include/mba/msgno.h
+include/mba/path.h
include/mba/pool.h
-include/mba/profile.h
include/mba/shellout.h
include/mba/stack.h
+include/mba/suba.h
+include/mba/svcond.h
+include/mba/svsem.h
+include/mba/text.h
+include/mba/time.h
include/mba/varray.h
lib/libmba.a
lib/libmba.so