aboutsummaryrefslogtreecommitdiff
path: root/devel/libmba
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2003-01-02 17:38:56 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2003-01-02 17:38:56 +0000
commit97588834887e7ec405b71a73e64688851dd6e977 (patch)
treed1f0e9658389699c1f13e52548685a31a1977861 /devel/libmba
parent5594cddd276f78e6b5d557e09b44a20571b557ef (diff)
downloadports-97588834887e7ec405b71a73e64688851dd6e977.tar.gz
ports-97588834887e7ec405b71a73e64688851dd6e977.zip
Notes
Diffstat (limited to 'devel/libmba')
-rw-r--r--devel/libmba/Makefile2
-rw-r--r--devel/libmba/distinfo2
-rw-r--r--devel/libmba/files/patch-Makefile19
3 files changed, 11 insertions, 12 deletions
diff --git a/devel/libmba/Makefile b/devel/libmba/Makefile
index f4ea5d65c98c..db44747aa43f 100644
--- a/devel/libmba/Makefile
+++ b/devel/libmba/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= libmba
-PORTVERSION= 0.4.5
+PORTVERSION= 0.4.6
CATEGORIES= devel
MASTER_SITES= http://www.eskimo.com/~miallen/libmba/dl/
diff --git a/devel/libmba/distinfo b/devel/libmba/distinfo
index d4fa4ba02e55..4d08e54999fa 100644
--- a/devel/libmba/distinfo
+++ b/devel/libmba/distinfo
@@ -1 +1 @@
-MD5 (libmba-0.4.5.tar.gz) = 979827b1ef8ee84369ea63e12ea861d6
+MD5 (libmba-0.4.6.tar.gz) = cff59d370cb12616fc3203d63b0c8bbb
diff --git a/devel/libmba/files/patch-Makefile b/devel/libmba/files/patch-Makefile
index 935233dc582c..137664cebe7d 100644
--- a/devel/libmba/files/patch-Makefile
+++ b/devel/libmba/files/patch-Makefile
@@ -1,5 +1,5 @@
---- Makefile.orig Sun Nov 17 10:37:18 2002
-+++ Makefile Tue Nov 19 07:54:45 2002
+--- Makefile.orig Thu Nov 21 06:09:41 2002
++++ Makefile Sat Nov 23 17:40:57 2002
@@ -1,17 +1,17 @@
-prefix = /usr/local
+prefix = ${PREFIX}
@@ -10,7 +10,7 @@
+CC ?= gcc
LIBNAME = mba
-MAJVERSION = 0.4
--MINVERSION = 0.4.5
+-MINVERSION = 0.4.6
+MAJVERSION = ${SHLIB_MAJOR}
+MINVERSION = ${SHLIB_MAJOR}
ARNAME = lib$(LIBNAME).a
@@ -22,7 +22,7 @@
+CFLAGS += -DMSGNO -I${LOCALBASE}/include
#CFLAGS = -Wall -W -DMSGNO -I$(includedir) -L$(libdir) $(RPM_OPT_FLAGS) -ansi -pedantic -Wbad-function-cast -Wcast-align -Wcast-qual -Wchar-subscripts -Winline -Wmissing-prototypes -Wnested-externs -Wpointer-arith -Wredundant-decls -Wshadow -Wstrict-prototypes -Wwrite-strings -Wtraditional -Wconversion -Waggregate-return -Wno-parentheses
OBJS = src/stack.o src/linkedlist.o src/hashmap.o src/profile.o src/hexdump.o src/msgno.o src/domnode.o src/mbs.o src/cfg.o
- HDRS = src/msgno.h src/stack.h src/linkedlist.h src/hashmap.h src/hexdump.h src/domnode.h src/profile.h src/mbs.h src/cfg.h
+ HDRS = src/mba/msgno.h src/mba/stack.h src/mba/linkedlist.h src/mba/hashmap.h src/mba/hexdump.h src/mba/domnode.h src/mba/profile.h src/mba/mbs.h src/mba/cfg.h
@@ -20,7 +20,7 @@
all: $(ARNAME)($(OBJS)) $(SONAME)
@@ -41,18 +41,17 @@
- install -d $(mandir)/man3
- install -m 644 $(ARNAME) $(libdir)
- install -m 755 $(SONAME) $(libdir)
-- cd $(libdir) && ln -sf $(SONAME) $(SOVERSION) && ln -sf $(SONAME) lib$(LIBNAME).so
-- install -m 444 $(HDRS) $(includedir)/mba
-- -install -m 444 docs/man/*.3m.gz $(mandir)/man3
-- -/sbin/ldconfig $(libdir)
+ mkdir -p $(libdir)
+ mkdir -p $(includedir)/mba
+ mkdir -p $(mandir)/man3
+ ${BSD_INSTALL_DATA} $(ARNAME) $(libdir)
+ ${BSD_INSTALL_DATA} $(SONAME) $(libdir)
-+ cd $(libdir) && ln -sf $(SONAME) lib$(LIBNAME).so
+ cd $(libdir) && ln -sf $(SONAME) $(SOVERSION) && ln -sf $(SONAME) lib$(LIBNAME).so
+- install -m 444 $(HDRS) $(includedir)/mba
+- -install -m 444 docs/man/*.3m.gz $(mandir)/man3
+- -/sbin/ldconfig $(libdir)
+ ${BSD_INSTALL_DATA} $(HDRS) $(includedir)/mba
-+ ${BSD_INSTALL_DATA} docs/man/*.3m.gz $(mandir)/man3
++ ${BSD_INSTALL_MAN} docs/man/*.3m.gz $(mandir)/man3
zip:
cd .. && zip -lr $(DISTRO)/.$(DISTRO).zip $(DISTRO) -x $(DISTRO)/.* $(DISTRO)/docs/man/* $(DISTRO)/tests/data* $(DISTRO)/libmba.lib $(DISTRO)/libmba.dll $(DISTRO)/libmba_s.lib