aboutsummaryrefslogtreecommitdiff
path: root/devel/libmba
diff options
context:
space:
mode:
authorChristian Weisgerber <naddy@FreeBSD.org>2003-04-23 22:44:31 +0000
committerChristian Weisgerber <naddy@FreeBSD.org>2003-04-23 22:44:31 +0000
commit2c58468101c9dc4b5081435933645e143cd41ae4 (patch)
tree66cd465bd5a2ea8d11a81bcddc82ba3b03865bad /devel/libmba
parente1c97b86a00f67148f1415dd53c5f8ab0c10995c (diff)
downloadports-2c58468101c9dc4b5081435933645e143cd41ae4.tar.gz
ports-2c58468101c9dc4b5081435933645e143cd41ae4.zip
Notes
Diffstat (limited to 'devel/libmba')
-rw-r--r--devel/libmba/Makefile6
-rw-r--r--devel/libmba/distinfo2
-rw-r--r--devel/libmba/files/patch-Makefile18
-rw-r--r--devel/libmba/files/patch-src::shellout.c11
-rw-r--r--devel/libmba/pkg-descr2
-rw-r--r--devel/libmba/pkg-plist3
6 files changed, 28 insertions, 14 deletions
diff --git a/devel/libmba/Makefile b/devel/libmba/Makefile
index 9de22ea31064..c5c516a58c38 100644
--- a/devel/libmba/Makefile
+++ b/devel/libmba/Makefile
@@ -7,9 +7,9 @@
#
PORTNAME= libmba
-PORTVERSION= 0.4.6
+PORTVERSION= 0.5.1
CATEGORIES= devel
-MASTER_SITES= http://www.eskimo.com/~miallen/libmba/dl/
+MASTER_SITES= http://www.ioplex.com/~miallen/libmba/dl/
MAINTAINER= ports@FreeBSD.org
COMMENT= A collection of C modules potentially useful to any project
@@ -24,7 +24,7 @@ MAKE_ENV= SHLIB_MAJOR="${SHLIB_MAJOR}"
PLIST_SUB= SHLIB_MAJOR="${SHLIB_MAJOR}"
MAN3= cfg.3m domnode.3m mbs.3m msgno.3m hashmap.3m hexdump.3m \
- linkedlist.3m stack.3m
+ linkedlist.3m pool.3m shellout.3m stack.3m varray.3m
MANCOMPRESSED= yes
.include <bsd.port.mk>
diff --git a/devel/libmba/distinfo b/devel/libmba/distinfo
index 4d08e54999fa..cb6e0c13af3c 100644
--- a/devel/libmba/distinfo
+++ b/devel/libmba/distinfo
@@ -1 +1 @@
-MD5 (libmba-0.4.6.tar.gz) = cff59d370cb12616fc3203d63b0c8bbb
+MD5 (libmba-0.5.1.tar.gz) = 1f635afda3dd02a9249ca51aff74d6f5
diff --git a/devel/libmba/files/patch-Makefile b/devel/libmba/files/patch-Makefile
index 137664cebe7d..ef1f8414c5c6 100644
--- a/devel/libmba/files/patch-Makefile
+++ b/devel/libmba/files/patch-Makefile
@@ -1,5 +1,5 @@
---- Makefile.orig Thu Nov 21 06:09:41 2002
-+++ Makefile Sat Nov 23 17:40:57 2002
+--- Makefile.orig Wed Apr 2 09:05:34 2003
++++ Makefile Tue Apr 15 12:37:37 2003
@@ -1,17 +1,17 @@
-prefix = /usr/local
+prefix = ${PREFIX}
@@ -9,8 +9,8 @@
-CC = gcc
+CC ?= gcc
LIBNAME = mba
--MAJVERSION = 0.4
--MINVERSION = 0.4.6
+-MAJVERSION = 0.5
+-MINVERSION = 0.5.1
+MAJVERSION = ${SHLIB_MAJOR}
+MINVERSION = ${SHLIB_MAJOR}
ARNAME = lib$(LIBNAME).a
@@ -21,14 +21,14 @@
-CFLAGS = -Wall -W -DMSGNO -I$(includedir) -L$(libdir) $(RPM_OPT_FLAGS)
+CFLAGS += -DMSGNO -I${LOCALBASE}/include
#CFLAGS = -Wall -W -DMSGNO -I$(includedir) -L$(libdir) $(RPM_OPT_FLAGS) -ansi -pedantic -Wbad-function-cast -Wcast-align -Wcast-qual -Wchar-subscripts -Winline -Wmissing-prototypes -Wnested-externs -Wpointer-arith -Wredundant-decls -Wshadow -Wstrict-prototypes -Wwrite-strings -Wtraditional -Wconversion -Waggregate-return -Wno-parentheses
- OBJS = src/stack.o src/linkedlist.o src/hashmap.o src/profile.o src/hexdump.o src/msgno.o src/domnode.o src/mbs.o src/cfg.o
- HDRS = src/mba/msgno.h src/mba/stack.h src/mba/linkedlist.h src/mba/hashmap.h src/mba/hexdump.h src/mba/domnode.h src/mba/profile.h src/mba/mbs.h src/mba/cfg.h
+ OBJS = src/stack.o src/linkedlist.o src/hashmap.o src/profile.o src/hexdump.o src/msgno.o src/domnode.o src/mbs.o src/cfg.o src/pool.o src/varray.o src/shellout.o
+ HDRS = src/mba/msgno.h src/mba/stack.h src/mba/linkedlist.h src/mba/hashmap.h src/mba/hexdump.h src/mba/domnode.h src/mba/profile.h src/mba/mbs.h src/mba/cfg.h src/mba/pool.h src/mba/varray.h src/mba/shellout.h
@@ -20,7 +20,7 @@
all: $(ARNAME)($(OBJS)) $(SONAME)
$(SONAME): $(ARNAME)($(OBJS)) $(OBJS)
-- $(CC) -shared $(OBJS) -L$(libdir) -lc -lexpat -Wl,-h,$(SOVERSION) -o $(SONAME)
-+ $(CC) -shared $(OBJS) -L${LOCALBASE}/lib -lexpat -Wl,-h,$(SOVERSION) -o $(SONAME)
+- $(CC) -shared $(OBJS) -L$(libdir) -lc -lexpat -lutil -Wl,-h,$(SOVERSION) -o $(SONAME)
++ $(CC) -shared $(OBJS) -L${LOCALBASE}/lib -lexpat -lutil -Wl,-h,$(SOVERSION) -o $(SONAME)
.c.a:
$(CC) $(CFLAGS) -c $< -o $*.o
@@ -54,4 +54,4 @@
+ ${BSD_INSTALL_MAN} docs/man/*.3m.gz $(mandir)/man3
zip:
- cd .. && zip -lr $(DISTRO)/.$(DISTRO).zip $(DISTRO) -x $(DISTRO)/.* $(DISTRO)/docs/man/* $(DISTRO)/tests/data* $(DISTRO)/libmba.lib $(DISTRO)/libmba.dll $(DISTRO)/libmba_s.lib
+ -rm docs/www/dl
diff --git a/devel/libmba/files/patch-src::shellout.c b/devel/libmba/files/patch-src::shellout.c
new file mode 100644
index 000000000000..57b7ec5a051e
--- /dev/null
+++ b/devel/libmba/files/patch-src::shellout.c
@@ -0,0 +1,11 @@
+--- src/shellout.c.orig Mon Mar 10 09:10:10 2003
++++ src/shellout.c Tue Apr 15 12:46:00 2003
+@@ -27,7 +27,7 @@
+ #include <string.h>
+ #include <termios.h>
+ #include <unistd.h>
+-#include <pty.h>
++/* #include <pty.h> */
+ #include <errno.h>
+ #include <sys/types.h>
+ #include <sys/wait.h>
diff --git a/devel/libmba/pkg-descr b/devel/libmba/pkg-descr
index b0f603431d1b..273522f159cf 100644
--- a/devel/libmba/pkg-descr
+++ b/devel/libmba/pkg-descr
@@ -4,4 +4,4 @@ like interface that can load and store XML files for simple XML processing, a
module for managing error codes and associated messages across separate C
libraries, and more.
-WWW: http://www.eskimo.com/~miallen/libmba/
+WWW: http://www.ioplex.com/~miallen/libmba/
diff --git a/devel/libmba/pkg-plist b/devel/libmba/pkg-plist
index 96634ae7ec8c..e6b32ed27fd6 100644
--- a/devel/libmba/pkg-plist
+++ b/devel/libmba/pkg-plist
@@ -5,8 +5,11 @@ include/mba/hexdump.h
include/mba/linkedlist.h
include/mba/mbs.h
include/mba/msgno.h
+include/mba/pool.h
include/mba/profile.h
+include/mba/shellout.h
include/mba/stack.h
+include/mba/varray.h
lib/libmba.a
lib/libmba.so
lib/libmba.so.%%SHLIB_MAJOR%%