aboutsummaryrefslogtreecommitdiff
path: root/devel/libnaji
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-05-19 14:50:15 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-05-19 14:50:15 +0000
commitb9133e7fcbca67f116dc2e86aa976bcae1dbea99 (patch)
treee9fc1bc0e7d585448e2966738639086ff7673055 /devel/libnaji
parent3c638910d82bc2975f123983115d71a757333774 (diff)
downloadports-b9133e7fcbca67f116dc2e86aa976bcae1dbea99.tar.gz
ports-b9133e7fcbca67f116dc2e86aa976bcae1dbea99.zip
Notes
Diffstat (limited to 'devel/libnaji')
-rw-r--r--devel/libnaji/Makefile25
-rw-r--r--devel/libnaji/distinfo2
-rw-r--r--devel/libnaji/pkg-descr9
-rw-r--r--devel/libnaji/pkg-plist2
4 files changed, 38 insertions, 0 deletions
diff --git a/devel/libnaji/Makefile b/devel/libnaji/Makefile
new file mode 100644
index 000000000000..b2804b71803c
--- /dev/null
+++ b/devel/libnaji/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: libnaji
+# Date created: 18 May 2005
+# Whom: NECDET COKYAZICI <cokyazici@yahoo.co.uk>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libnaji
+PORTVERSION= 0.3.0
+CATEGORIES= devel
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_EXTENDED}
+MASTER_SITE_SUBDIR= najitool
+
+MAINTAINER= cokyazici@yahoo.co.uk
+COMMENT= A library that generates, converts, and filters files
+
+MAKEFILE= makefile
+
+DISTVERSIONSUFFIX= .src
+
+do-install:
+ ${INSTALL_DATA} ${WRKSRC}/libnaji.h ${PREFIX}/include
+ ${INSTALL_DATA} ${WRKSRC}/libnaji.a ${PREFIX}/lib
+
+.include <bsd.port.mk>
diff --git a/devel/libnaji/distinfo b/devel/libnaji/distinfo
new file mode 100644
index 000000000000..5af1ab8eab22
--- /dev/null
+++ b/devel/libnaji/distinfo
@@ -0,0 +1,2 @@
+MD5 (libnaji-0.3.0.src.tar.gz) = 3c8af38bb18c43e02fa715ae284a2a9e
+SIZE (libnaji-0.3.0.src.tar.gz) = 24742
diff --git a/devel/libnaji/pkg-descr b/devel/libnaji/pkg-descr
new file mode 100644
index 000000000000..50f4cd222d2c
--- /dev/null
+++ b/devel/libnaji/pkg-descr
@@ -0,0 +1,9 @@
+libnaji is a library of functions which implement the features of najitool,
+a flexible file generator, converter, and filter. libnaji is being developed
+in the ANSI C standard so it should work and compile on any system that
+supports ANSI C, which should be every system.
+
+WWW: http://najitool.sf.net/
+
+- NECDET COKYAZICI
+cokyazici@yahoo.co.uk
diff --git a/devel/libnaji/pkg-plist b/devel/libnaji/pkg-plist
new file mode 100644
index 000000000000..9876c6b8f64d
--- /dev/null
+++ b/devel/libnaji/pkg-plist
@@ -0,0 +1,2 @@
+include/libnaji.h
+lib/libnaji.a