aboutsummaryrefslogtreecommitdiff
path: root/devel/libnfc
diff options
context:
space:
mode:
authorRomain Tartière <romain@FreeBSD.org>2010-02-01 21:18:04 +0000
committerRomain Tartière <romain@FreeBSD.org>2010-02-01 21:18:04 +0000
commit2752273a3f69885cc007d083103bccaf5579dce1 (patch)
tree729c8862d538f08c3f3fa0707d520c30eb4efdea /devel/libnfc
parentf89b15d117f3bceabae3dce61b7adbe12afb42a9 (diff)
downloadports-2752273a3f69885cc007d083103bccaf5579dce1.tar.gz
ports-2752273a3f69885cc007d083103bccaf5579dce1.zip
Notes
Diffstat (limited to 'devel/libnfc')
-rw-r--r--devel/libnfc/Makefile36
-rw-r--r--devel/libnfc/distinfo3
-rw-r--r--devel/libnfc/pkg-descr4
-rw-r--r--devel/libnfc/pkg-plist20
4 files changed, 63 insertions, 0 deletions
diff --git a/devel/libnfc/Makefile b/devel/libnfc/Makefile
new file mode 100644
index 000000000000..30e7083595c5
--- /dev/null
+++ b/devel/libnfc/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: libnfc
+# Date created: 2009-06-17
+# Whom: Romain Tartiere <romain@blogreen.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libnfc
+PORTVERSION= 1.3.2
+CATEGORIES= devel
+MASTER_SITES= http://${PORTNAME}.googlecode.com/files/ \
+ http://romain.blogreen.org/distfiles/
+
+MAINTAINER= romain@FreeBSD.org
+COMMENT= Near Field Communication (NFC) library
+
+LIB_DEPENDS= pcsclite.1:${PORTSDIR}/devel/pcsc-lite
+RUN_DEPENDS= RSA_SecurID_getpasswd:${PORTSDIR}/devel/libccid
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_LDCONFIG= yes
+USE_GNOME= gnomehack
+
+MAN1= nfc-mfclassic.1 nfc-emulate.1 nfc-list.1 nfc-mfultralight.1 \
+ nfc-relay.1 nfc-anticol.1
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 800069
+LIB_DEPENDS+= usb-0.1:${PORTSDIR}/devel/libusb
+CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
+ LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/libnfc/distinfo b/devel/libnfc/distinfo
new file mode 100644
index 000000000000..0bee8a92476b
--- /dev/null
+++ b/devel/libnfc/distinfo
@@ -0,0 +1,3 @@
+MD5 (libnfc-1.3.2.tar.gz) = 06ce0ad0ef0102ff9e40183db0bf32c3
+SHA256 (libnfc-1.3.2.tar.gz) = 2243f893b7327a908772647df7640349d767e95be161459722633d259f583769
+SIZE (libnfc-1.3.2.tar.gz) = 443162
diff --git a/devel/libnfc/pkg-descr b/devel/libnfc/pkg-descr
new file mode 100644
index 000000000000..515016d68815
--- /dev/null
+++ b/devel/libnfc/pkg-descr
@@ -0,0 +1,4 @@
+The libnfc provides a simple yet complete low-level API for handling NFC
+devices and building NFC applications.
+
+WWW: http://www.libnfc.org
diff --git a/devel/libnfc/pkg-plist b/devel/libnfc/pkg-plist
new file mode 100644
index 000000000000..2aeabdb342fe
--- /dev/null
+++ b/devel/libnfc/pkg-plist
@@ -0,0 +1,20 @@
+@comment $FreeBSD$
+bin/nfc-anticol
+bin/nfc-emulate
+bin/nfc-list
+bin/nfc-mfclassic
+bin/nfc-mfultralight
+bin/nfc-relay
+bin/nfcip-initiator
+bin/nfcip-target
+include/nfc/mifaretag.h
+include/nfc/mifareultag.h
+include/nfc/nfc-messages.h
+include/nfc/nfc-types.h
+include/nfc/nfc.h
+lib/libnfc.a
+lib/libnfc.la
+lib/libnfc.so
+lib/libnfc.so.0
+libdata/pkgconfig/libnfc.pc
+@dirrm include/nfc