aboutsummaryrefslogtreecommitdiff
path: root/devel/libnfc
diff options
context:
space:
mode:
authorRomain Tartière <romain@FreeBSD.org>2010-02-22 13:23:59 +0000
committerRomain Tartière <romain@FreeBSD.org>2010-02-22 13:23:59 +0000
commite9beab0cdb9fd70b0c8016a8b8a7abe53ee3c30e (patch)
tree46a5a363f2a5731a8631a62fcaa617c9bfc3f064 /devel/libnfc
parent46a8ae52c0827b9f72de1e9cf8ec3989cc67c371 (diff)
downloadports-e9beab0cdb9fd70b0c8016a8b8a7abe53ee3c30e.tar.gz
ports-e9beab0cdb9fd70b0c8016a8b8a7abe53ee3c30e.zip
Notes
Diffstat (limited to 'devel/libnfc')
-rw-r--r--devel/libnfc/Makefile27
-rw-r--r--devel/libnfc/distinfo6
-rw-r--r--devel/libnfc/pkg-plist2
3 files changed, 28 insertions, 7 deletions
diff --git a/devel/libnfc/Makefile b/devel/libnfc/Makefile
index 30e7083595c5..e10d45018ef8 100644
--- a/devel/libnfc/Makefile
+++ b/devel/libnfc/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= libnfc
-PORTVERSION= 1.3.2
+PORTVERSION= 1.3.3
CATEGORIES= devel
MASTER_SITES= http://${PORTNAME}.googlecode.com/files/ \
http://romain.blogreen.org/distfiles/
@@ -14,8 +14,8 @@ MASTER_SITES= http://${PORTNAME}.googlecode.com/files/ \
MAINTAINER= romain@FreeBSD.org
COMMENT= Near Field Communication (NFC) library
-LIB_DEPENDS= pcsclite.1:${PORTSDIR}/devel/pcsc-lite
-RUN_DEPENDS= RSA_SecurID_getpasswd:${PORTSDIR}/devel/libccid
+OPTIONS= PCSC "Compile with PC/SC Lite support" on \
+ USB "Compile with libusb support" on
GNU_CONFIGURE= yes
USE_GMAKE= yes
@@ -27,10 +27,29 @@ MAN1= nfc-mfclassic.1 nfc-emulate.1 nfc-list.1 nfc-mfultralight.1 \
.include <bsd.port.pre.mk>
+.if defined(WITH_PCSC)
+LIB_DEPENDS+= pcsclite.1:${PORTSDIR}/devel/pcsc-lite
+RUN_DEPENDS+= RSA_SecurID_getpasswd:${PORTSDIR}/devel/libccid
+CONFIGURE_ARGS+=--enable-pcsc-lite
+.else
+CONFIGURE_ARGS+=--disable-pcsc-lite
+.endif
+
+.if defined(WITH_USB)
+CONFIGURE_ARGS+=--enable-libusb
.if ${OSVERSION} < 800069
LIB_DEPENDS+= usb-0.1:${PORTSDIR}/devel/libusb
-CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
+CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
.endif
+.else
+CONFIGURE_ARGS+=--disable-libusb
+.endif
+
+post-install:
+.if !defined(NOPORTEXAMPLES)
+ ${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/pn53x.conf ${EXAMPLESDIR}
+.endif
.include <bsd.port.post.mk>
diff --git a/devel/libnfc/distinfo b/devel/libnfc/distinfo
index 0bee8a92476b..7c8169bdae70 100644
--- a/devel/libnfc/distinfo
+++ b/devel/libnfc/distinfo
@@ -1,3 +1,3 @@
-MD5 (libnfc-1.3.2.tar.gz) = 06ce0ad0ef0102ff9e40183db0bf32c3
-SHA256 (libnfc-1.3.2.tar.gz) = 2243f893b7327a908772647df7640349d767e95be161459722633d259f583769
-SIZE (libnfc-1.3.2.tar.gz) = 443162
+MD5 (libnfc-1.3.3.tar.gz) = 88aeb2f6c3ddf32ae52aedc9b179e49c
+SHA256 (libnfc-1.3.3.tar.gz) = dc30a274b9a35a88aa7189236c81c05125e797ccf882e0a2ed6eae4c5e31c738
+SIZE (libnfc-1.3.3.tar.gz) = 407042
diff --git a/devel/libnfc/pkg-plist b/devel/libnfc/pkg-plist
index 2aeabdb342fe..26758a9dffec 100644
--- a/devel/libnfc/pkg-plist
+++ b/devel/libnfc/pkg-plist
@@ -17,4 +17,6 @@ lib/libnfc.la
lib/libnfc.so
lib/libnfc.so.0
libdata/pkgconfig/libnfc.pc
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/pn53x.conf
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%
@dirrm include/nfc