aboutsummaryrefslogtreecommitdiff
path: root/devel/libnotify
diff options
context:
space:
mode:
authorRoman Bogorodskiy <novel@FreeBSD.org>2006-07-17 12:04:10 +0000
committerRoman Bogorodskiy <novel@FreeBSD.org>2006-07-17 12:04:10 +0000
commit8505699300f2681d5e8f52b0e6c18e36c53d8a54 (patch)
tree4411f1af710dbe71e118845720f6b5ba8bc2115e /devel/libnotify
parent184dd614d877aeb0d594909d29dc90d8d04138b3 (diff)
downloadports-8505699300f2681d5e8f52b0e6c18e36c53d8a54.tar.gz
ports-8505699300f2681d5e8f52b0e6c18e36c53d8a54.zip
Notes
Diffstat (limited to 'devel/libnotify')
-rw-r--r--devel/libnotify/Makefile1
-rw-r--r--devel/libnotify/files/patch-libnotify-notification.c21
2 files changed, 22 insertions, 0 deletions
diff --git a/devel/libnotify/Makefile b/devel/libnotify/Makefile
index 79e24be3a9b7..b3085265c065 100644
--- a/devel/libnotify/Makefile
+++ b/devel/libnotify/Makefile
@@ -7,6 +7,7 @@
PORTNAME= libnotify
PORTVERSION= 0.4.2
+PORTREVISION= 1
CATEGORIES= devel gnome
MASTER_SITES= http://www.galago-project.org/files/releases/source/libnotify/
diff --git a/devel/libnotify/files/patch-libnotify-notification.c b/devel/libnotify/files/patch-libnotify-notification.c
new file mode 100644
index 000000000000..370f1db0bd47
--- /dev/null
+++ b/devel/libnotify/files/patch-libnotify-notification.c
@@ -0,0 +1,21 @@
+diff -Naur libnotify-0.4.2.orig/libnotify/notification.c libnotify-0.4.2/libnotify/notification.c
+--- libnotify/notification.c 2006-06-15 11:14:03.000000000 +0200
++++ libnotify/notification.c 2006-06-18 05:09:08.000000000 +0200
+@@ -901,7 +901,7 @@
+ return FALSE;
+ }
+
+- g_value_init(value, dbus_g_type_get_collection("GArray", G_TYPE_CHAR));
++ g_value_init(value, DBUS_TYPE_G_UCHAR_ARRAY);
+ g_value_set_boxed_take_ownership(value, byte_array);
+ g_value_array_append(array, value);
+
+@@ -961,7 +961,7 @@
+
+ value = g_new0(GValue, 1);
+ g_value_init(value, G_TYPE_VALUE_ARRAY);
+- g_value_set_boxed(value, image_struct);
++ g_value_set_boxed_take_ownership(value, image_struct);
+
+ g_hash_table_insert(notification->priv->hints,
+ g_strdup("icon_data"), value);