aboutsummaryrefslogtreecommitdiff
path: root/devel/libnxt/Makefile
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2007-09-23 02:56:44 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2007-09-23 02:56:44 +0000
commitce923a0103df941b9487eb5421226fce10dd60b6 (patch)
tree82b56ae68cb776ef3db134575c44ae293d528ede /devel/libnxt/Makefile
parent403f96dca0a890aeaa9118f7491dfad31b3a41f7 (diff)
Notes
Diffstat (limited to 'devel/libnxt/Makefile')
-rw-r--r--devel/libnxt/Makefile40
1 files changed, 40 insertions, 0 deletions
diff --git a/devel/libnxt/Makefile b/devel/libnxt/Makefile
new file mode 100644
index 000000000000..4fef57a5dab2
--- /dev/null
+++ b/devel/libnxt/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: libnxt
+# Date created: 2007-05-05
+# Whom: Jason Bacon <bacon11@tds.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libnxt
+PORTVERSION= 0.3
+CATEGORIES= devel
+MASTER_SITES= http://libnxt.googlecode.com/files/ \
+ http://personalpages.tds.net/~jwbacon/Ports/distfiles/
+
+MAINTAINER= bacon@smithers.neuro.mcw.edu
+COMMENT= Lego NXT library
+
+LIB_DEPENDS= usb-0.1.8:${PORTSDIR}/devel/libusb
+BUILD_DEPENDS= scons:${PORTSDIR}/devel/scons \
+ python:${PORTSDIR}/lang/python
+
+SUB_FILES= pkg-message
+USE_LDCONFIG= yes
+
+do-build:
+ (cd ${WRKSRC}; scons)
+
+do-install:
+ ${MKDIR} ${PREFIX}/include/libnxt
+ ${INSTALL_PROGRAM} ${WRKSRC}/fwflash ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/fwexec ${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKSRC}/libnxt.a ${PREFIX}/lib
+ ${MKDIR} ${PREFIX}/include/libnxt
+.for file in ${WRKSRC}/*.h
+ ${INSTALL_DATA} ${WRKSRC}/${file} ${PREFIX}/include/libnxt
+.endfor
+
+post-install:
+ @${CAT} ${WRKDIR}/pkg-message
+
+.include <bsd.port.mk>