aboutsummaryrefslogtreecommitdiff
path: root/devel/liboil/Makefile
diff options
context:
space:
mode:
authorMichael Johnson <ahze@FreeBSD.org>2006-11-19 23:25:49 +0000
committerMichael Johnson <ahze@FreeBSD.org>2006-11-19 23:25:49 +0000
commit0637d1df991ef736be8d2fbcb3f3318d6f574a36 (patch)
treeed415a0740cfc9776f83356b757680c6b6aae8ea /devel/liboil/Makefile
parent729e3a8e20939d22ad2e08df85728fcf98f36c57 (diff)
downloadports-0637d1df991ef736be8d2fbcb3f3318d6f574a36.tar.gz
ports-0637d1df991ef736be8d2fbcb3f3318d6f574a36.zip
Notes
Diffstat (limited to 'devel/liboil/Makefile')
-rw-r--r--devel/liboil/Makefile12
1 files changed, 9 insertions, 3 deletions
diff --git a/devel/liboil/Makefile b/devel/liboil/Makefile
index bd4d14f02931..ed1f61f98b80 100644
--- a/devel/liboil/Makefile
+++ b/devel/liboil/Makefile
@@ -24,13 +24,19 @@ CFLAGS+= -O2
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 600000 && ${OSVERSION} > 500000
-USE_GCC= 3.4+
-RUN_DEPENDS+= ${CC}:${PORTSDIR}/lang/${CC}
+.if ${OSVERSION} < 600000 && ${OSVERSION} > 500000 && !defined(WITH_3DNOW_GCC40)
+BUILD_DEPENDS+= gcc34:${PORTSDIR}/lang/gcc34
+RUN_DEPENDS+= gcc34:${PORTSDIR}/lang/gcc34
+CC:= gcc34
+CXX:= g++34
.endif
.if defined(WITH_3DNOW_GCC40)
USE_GCC= 4.0+
+.if ${OSVERSION} < 600000 && ${OSVERSION} > 500000
+# yeah yeah, I know other stuff will be added that shouldn't...
+RUN_DEPENDS+= ${BUILD_DEPENDS}
+.endif
.endif
pre-everything::